Upstream information

CVE-2019-6462 at MITRE

Description

An issue was discovered in cairo 1.16.0. There is an infinite loop in the function _arc_error_normalized in the file cairo-arc.c, related to _arc_max_angle_for_tolerance_normalized.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 3.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1122321 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • libcairo-gobject2 >= 1.15.2-25.6.2
  • libcairo2 >= 1.15.2-25.6.2
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-OCI-BYOS-SAP-BYOS
  • libcairo2 >= 1.15.2-25.6.2
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP5-SAP-Azure-LI-BYOS
Image SLES15-SP5-SAP-Azure-LI-BYOS-Production
Image SLES15-SP5-SAP-Azure-VLI-BYOS
Image SLES15-SP5-SAP-Azure-VLI-BYOS-Production
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
Image SLES15-SP5-Hardened-BYOS-GCE
Image SLES15-SP5-SAP-BYOS-EC2
Image SLES15-SP5-SAP-BYOS-GCE
Image SLES15-SP5-SAP-Hardened-BYOS-GCE
Image SLES15-SP5-SAP-Hardened-GCE
  • libcairo2 >= 1.16.0-150400.11.3.1
Image SLES15-SP5-SAPCAL-EC2
Image SLES15-SP5-SAPCAL-GCE
  • cairo-devel >= 1.16.0-150400.11.3.1
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo-script-interpreter2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • cairo-devel >= 1.16.0-150400.11.3.1
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo-script-interpreter2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
  • libcairo2-32bit >= 1.16.0-150400.11.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-1704
SUSE-SLE-Module-Desktop-Applications-15-SP5-2024-1704
SUSE Linux Enterprise Micro 5.3
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
Patchnames:
SUSE-SLE-Micro-5.3-2024-1704
SUSE Linux Enterprise Micro 5.4
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
Patchnames:
SUSE-SLE-Micro-5.4-2024-1704
SUSE Linux Enterprise Micro 5.5
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
Patchnames:
SUSE-SLE-Micro-5.5-2024-1704
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • cairo-devel >= 1.16.0-150400.11.3.1
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo-script-interpreter2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-1704
SUSE Linux Enterprise Module for Desktop Applications 15 SP5
  • libcairo2-32bit >= 1.16.0-150400.11.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP5-2024-1704
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • cairo-devel >= 1.15.2-25.6.2
  • libcairo-gobject2 >= 1.15.2-25.6.2
  • libcairo-gobject2-32bit >= 1.15.2-25.6.2
  • libcairo-script-interpreter2 >= 1.15.2-25.6.2
  • libcairo2 >= 1.15.2-25.6.2
  • libcairo2-32bit >= 1.15.2-25.6.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-3502
SUSE-SLE-SERVER-12-SP5-2021-3502
SUSE Linux Enterprise Software Development Kit 12 SP5
  • cairo-devel >= 1.15.2-25.6.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-3502
openSUSE Leap 15.5
  • cairo-devel >= 1.16.0-150400.11.3.1
  • cairo-devel-32bit >= 1.16.0-150400.11.3.1
  • cairo-tools >= 1.16.0-150400.11.3.1
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo-gobject2-32bit >= 1.16.0-150400.11.3.1
  • libcairo-script-interpreter2 >= 1.16.0-150400.11.3.1
  • libcairo-script-interpreter2-32bit >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
  • libcairo2-32bit >= 1.16.0-150400.11.3.1
Patchnames:
openSUSE-SLE-15.5-2024-1704
openSUSE Leap Micro 5.3
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
Patchnames:
openSUSE-Leap-Micro-5.3-2024-1704
openSUSE Leap Micro 5.4
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
Patchnames:
openSUSE-Leap-Micro-5.4-2024-1704
openSUSE Leap Micro 5.5
  • libcairo-gobject2 >= 1.16.0-150400.11.3.1
  • libcairo2 >= 1.16.0-150400.11.3.1
Patchnames:
openSUSE-Leap-Micro-5.5-2024-1704


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 cairo Affected
SUSE Linux Enterprise Desktop 15 SP5 cairo Released
SUSE Linux Enterprise High Performance Computing 12 SP5 cairo Released
SUSE Linux Enterprise High Performance Computing 15 SP5 cairo Released
SUSE Linux Enterprise Micro 5.2 cairo Affected
SUSE Linux Enterprise Micro 5.3 cairo Released
SUSE Linux Enterprise Micro 5.4 cairo Released
SUSE Linux Enterprise Micro 5.5 cairo Released
SUSE Linux Enterprise Micro 6.0 cairo Not affected
SUSE Linux Enterprise Micro for Rancher 5.3 cairo Released
SUSE Linux Enterprise Micro for Rancher 5.4 cairo Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 cairo Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 cairo Released
SUSE Linux Enterprise Server 12 SP5 cairo Released
SUSE Linux Enterprise Server 15 SP5 cairo Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 cairo Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 cairo Released
SUSE Linux Enterprise Software Development Kit 12 SP5 cairo Released
SUSE Manager Proxy 4.3 cairo Not affected
SUSE Manager Retail Branch Server 4.3 cairo Not affected
SUSE Manager Server 4.3 cairo Not affected
openSUSE Leap 15.5 cairo Released
openSUSE Leap Micro 5.5 cairo Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 cairo Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 cairo Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS cairo Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS cairo Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 cairo Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS cairo Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS cairo Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 cairo Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS cairo Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS cairo Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 cairo Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 cairo Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 cairo Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 cairo Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 cairo Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 cairo Not affected
SUSE Linux Enterprise Server 15 SP2 cairo Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS cairo Affected
SUSE Linux Enterprise Server 15 SP3 cairo Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS cairo Affected
SUSE Linux Enterprise Server 15 SP4 cairo Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS cairo Affected
SUSE Linux Enterprise Server 15-ESPOS cairo Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 cairo Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 cairo Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 cairo Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 cairo Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 cairo Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 cairo Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 cairo Affected
SUSE CaaS Platform 4.0 cairo Unsupported
SUSE CaaS Platform 4.5 cairo Not affected
SUSE Enterprise Storage 6 cairo Affected
SUSE Enterprise Storage 7 cairo Not affected
SUSE Linux Enterprise Desktop 11 SP2 cairo Affected
SUSE Linux Enterprise Desktop 11 SP3 cairo Affected
SUSE Linux Enterprise Desktop 11 SP4 cairo Affected
SUSE Linux Enterprise Desktop 12 SP2 cairo Affected
SUSE Linux Enterprise Desktop 12 SP3 cairo Affected
SUSE Linux Enterprise Desktop 12 SP4 cairo Affected
SUSE Linux Enterprise Desktop 15 cairo Unsupported
SUSE Linux Enterprise Desktop 15 SP1 cairo Unsupported
SUSE Linux Enterprise Desktop 15 SP2 cairo Not affected
SUSE Linux Enterprise Desktop 15 SP3 cairo Not affected
SUSE Linux Enterprise High Performance Computing 15 cairo Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 cairo Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS cairo Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS cairo Unsupported
SUSE Linux Enterprise High Performance Computing 15-ESPOS cairo Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS cairo Unsupported
SUSE Linux Enterprise Micro 5.0 cairo Not affected
SUSE Linux Enterprise Module for Basesystem 15 cairo Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP1 cairo Unsupported
SUSE Linux Enterprise Module for Desktop Applications 15 cairo Unsupported
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 cairo Unsupported
SUSE Linux Enterprise Module for Package Hub 15 SP3 cairo Not affected
SUSE Linux Enterprise Point of Sale 11 SP3 cairo Affected
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT cairo Affected
SUSE Linux Enterprise Point of Service 11 SP3 cairo Unsupported
SUSE Linux Enterprise Real Time 15 SP2 cairo Not affected
SUSE Linux Enterprise Real Time 15 SP3 cairo Not affected
SUSE Linux Enterprise Real Time 15 SP4 cairo Affected
SUSE Linux Enterprise Server 11 SP1 cairo Released
SUSE Linux Enterprise Server 11 SP1-LTSS cairo Affected
SUSE Linux Enterprise Server 11 SP2 cairo Affected
SUSE Linux Enterprise Server 11 SP2-LTSS cairo Affected
SUSE Linux Enterprise Server 11 SP3 cairo Released
SUSE Linux Enterprise Server 11 SP3-LTSS cairo Affected
SUSE Linux Enterprise Server 11 SP4 cairo Affected
SUSE Linux Enterprise Server 11 SP4 LTSS cairo Unsupported
SUSE Linux Enterprise Server 11 SP4-LTSS cairo Released
SUSE Linux Enterprise Server 12 SP2 cairo Affected
SUSE Linux Enterprise Server 12 SP2-BCL cairo Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS cairo Affected
SUSE Linux Enterprise Server 12 SP2-LTSS cairo Affected
SUSE Linux Enterprise Server 12 SP3 cairo Affected
SUSE Linux Enterprise Server 12 SP3-BCL cairo Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS cairo Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS cairo Unsupported
SUSE Linux Enterprise Server 12 SP4 cairo Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS cairo Affected
SUSE Linux Enterprise Server 12 SP4-LTSS cairo Affected
SUSE Linux Enterprise Server 15 cairo Unsupported
SUSE Linux Enterprise Server 15 SP1 cairo Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL cairo Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS cairo Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL cairo Affected
SUSE Linux Enterprise Server 15 SP3-BCL cairo Affected
SUSE Linux Enterprise Server 15-LTSS cairo Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 cairo Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 cairo Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 cairo Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 cairo Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 cairo Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 cairo Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 cairo Affected
SUSE Linux Enterprise Server for SAP Applications 15 cairo Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 cairo Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP2 cairo Affected
SUSE Linux Enterprise Software Development Kit 11 SP3 cairo Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 cairo Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 cairo Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 cairo Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 cairo Affected
SUSE Manager Proxy 4.0 cairo Unsupported
SUSE Manager Proxy 4.1 cairo Not affected
SUSE Manager Proxy 4.2 cairo Not affected
SUSE Manager Retail Branch Server 4.0 cairo Unsupported
SUSE Manager Retail Branch Server 4.1 cairo Not affected
SUSE Manager Retail Branch Server 4.2 cairo Not affected
SUSE Manager Server 4.0 cairo Unsupported
SUSE Manager Server 4.1 cairo Not affected
SUSE Manager Server 4.2 cairo Not affected
SUSE OpenStack Cloud 7 cairo Affected
SUSE OpenStack Cloud 8 cairo Affected
SUSE OpenStack Cloud 9 cairo Affected
SUSE OpenStack Cloud Crowbar 8 cairo Affected
SUSE OpenStack Cloud Crowbar 9 cairo Affected
openSUSE Leap 15.3 cairo Affected
openSUSE Leap 15.4 cairo Released
openSUSE Leap Micro 5.2 cairo Affected
openSUSE Leap Micro 5.3 cairo Released
openSUSE Leap Micro 5.4 cairo Released
Products at an unknown state of their lifecycle.
SUSE CaaS Platform Toolchain 3 cairo Affected


SUSE Timeline for this CVE

CVE page created: Thu Jan 17 04:32:55 2019
CVE page last modified: Thu Jul 18 11:30:28 2024