Upstream information

CVE-2019-5057 at MITRE

Description

An exploitable code execution vulnerability exists in the PCX image-rendering functionality of SDL2_image 2.0.4. A specially crafted PCX image can cause a heap overflow, resulting in code execution. An attacker can display a specially crafted image to trigger this vulnerability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1143763 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 15 SP1
  • SDL2_image-debugsource >= 2.0.5-bp151.4.3.1
  • SDL_image-debugsource >= 1.2.12+hg695-bp151.4.3.1
  • libSDL2_image-2_0-0 >= 2.0.5-bp151.4.3.1
  • libSDL2_image-2_0-0-64bit >= 2.0.5-bp151.4.3.1
  • libSDL2_image-2_0-0-64bit-debuginfo >= 2.0.5-bp151.4.3.1
  • libSDL2_image-2_0-0-debuginfo >= 2.0.5-bp151.4.3.1
  • libSDL2_image-devel >= 2.0.5-bp151.4.3.1
  • libSDL2_image-devel-64bit >= 2.0.5-bp151.4.3.1
  • libSDL_image-1_2-0 >= 1.2.12+hg695-bp151.4.3.1
  • libSDL_image-1_2-0-64bit >= 1.2.12+hg695-bp151.4.3.1
  • libSDL_image-1_2-0-64bit-debuginfo >= 1.2.12+hg695-bp151.4.3.1
  • libSDL_image-1_2-0-debuginfo >= 1.2.12+hg695-bp151.4.3.1
  • libSDL_image-devel >= 1.2.12+hg695-bp151.4.3.1
  • libSDL_image-devel-64bit >= 1.2.12+hg695-bp151.4.3.1
Patchnames:
openSUSE-2019-2108
openSUSE-2019-2109
SUSE Package Hub for SUSE Linux Enterprise 15
  • libSDL2_image-2_0-0 >= 2.0.5-bp150.3.6.1
  • libSDL2_image-2_0-0-64bit >= 2.0.5-bp150.3.6.1
  • libSDL2_image-devel >= 2.0.5-bp150.3.6.1
  • libSDL2_image-devel-64bit >= 2.0.5-bp150.3.6.1
  • libSDL_image-1_2-0 >= 1.2.12+hg695-bp150.3.3.1
  • libSDL_image-1_2-0-64bit >= 1.2.12+hg695-bp150.3.3.1
  • libSDL_image-devel >= 1.2.12+hg695-bp150.3.3.1
  • libSDL_image-devel-64bit >= 1.2.12+hg695-bp150.3.3.1
Patchnames:
openSUSE-2019-2108
openSUSE-2019-2109
openSUSE Leap 15.0
  • SDL2_image-debugsource >= 2.0.5-lp150.9.1
  • SDL_image-debugsource >= 1.2.12+hg695-lp150.2.3.1
  • libSDL2_image-2_0-0 >= 2.0.5-lp150.9.1
  • libSDL2_image-2_0-0-32bit >= 2.0.5-lp150.9.1
  • libSDL2_image-2_0-0-32bit-debuginfo >= 2.0.5-lp150.9.1
  • libSDL2_image-2_0-0-debuginfo >= 2.0.5-lp150.9.1
  • libSDL2_image-devel >= 2.0.5-lp150.9.1
  • libSDL2_image-devel-32bit >= 2.0.5-lp150.9.1
  • libSDL_image-1_2-0 >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-1_2-0-32bit >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-1_2-0-32bit-debuginfo >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-1_2-0-debuginfo >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-devel >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-devel-32bit >= 1.2.12+hg695-lp150.2.3.1
Patchnames:
openSUSE-2019-2070
openSUSE-2019-2071
openSUSE Leap 15.1
  • SDL2_image-debugsource >= 2.0.5-lp151.2.5.1
  • SDL_image-debugsource >= 1.2.12+hg695-lp151.3.3.1
  • libSDL2_image-2_0-0 >= 2.0.5-lp151.2.5.1
  • libSDL2_image-2_0-0-32bit >= 2.0.5-lp151.2.5.1
  • libSDL2_image-2_0-0-32bit-debuginfo >= 2.0.5-lp151.2.5.1
  • libSDL2_image-2_0-0-debuginfo >= 2.0.5-lp151.2.5.1
  • libSDL2_image-devel >= 2.0.5-lp151.2.5.1
  • libSDL2_image-devel-32bit >= 2.0.5-lp151.2.5.1
  • libSDL_image-1_2-0 >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-1_2-0-32bit >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-1_2-0-32bit-debuginfo >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-1_2-0-debuginfo >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-devel >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-devel-32bit >= 1.2.12+hg695-lp151.3.3.1
Patchnames:
openSUSE-2019-2070
openSUSE-2019-2071
openSUSE Tumbleweed
  • libSDL2_image-2_0-0 >= 2.0.5-1.14
  • libSDL2_image-2_0-0-32bit >= 2.0.5-1.14
  • libSDL2_image-devel >= 2.0.5-1.14
  • libSDL2_image-devel-32bit >= 2.0.5-1.14
  • libSDL_image-1_2-0 >= 1.2.12+hg695-1.12
  • libSDL_image-1_2-0-32bit >= 1.2.12+hg695-1.12
  • libSDL_image-devel >= 1.2.12+hg695-1.12
  • libSDL_image-devel-32bit >= 1.2.12+hg695-1.12
Patchnames:
openSUSE Tumbleweed GA libSDL2_image-2_0-0-2.0.5-1.14
openSUSE Tumbleweed GA libSDL_image-1_2-0-1.2.12+hg695-1.12