Upstream information

CVE-2019-3836 at MITRE

Description

It was discovered in gnutls before version 3.6.7 upstream that there is an uninitialized pointer access in gnutls versions 3.6.3 or later which can be triggered by certain post-handshake messages.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.9
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1130682 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/389-ds:1.4.2
Container caasp/v4/busybox:1.34.1
Container caasp/v4/caasp-dex:2.16.0
Container caasp/v4/caaspctl-tooling:beta
Container caasp/v4/cert-exporter:2.3.0
Container caasp/v4/cilium-etcd-operator:2.0.5
Container caasp/v4/cilium-init:1.5.3
Container caasp/v4/cilium-operator:1.6.6
Container caasp/v4/cilium:1.6.6
Container caasp/v4/cloud-provider-openstack:1.15.0
Container caasp/v4/configmap-reload:0.3.0
Container caasp/v4/coredns:1.6.7
Container caasp/v4/curl:7.60.0
Container caasp/v4/etcd:3.4.13
Container caasp/v4/gangway:3.1.0
Container caasp/v4/grafana:7.5.12
Container caasp/v4/helm-tiller:2.16.12
Container caasp/v4/hyperkube:v1.17.17
Container caasp/v4/k8s-sidecar:0.1.75
Container caasp/v4/kube-state-metrics:1.9.3
Container caasp/v4/kubernetes-client:1.17.17
Container caasp/v4/kucero:1.3.0
Container caasp/v4/kured:1.3.0
Container caasp/v4/metrics-server:0.3.6
Container caasp/v4/prometheus-alertmanager:0.16.2
Container caasp/v4/prometheus-node-exporter:1.1.2
Container caasp/v4/prometheus-pushgateway:0.6.0
Container caasp/v4/prometheus-server:2.7.1
Container caasp/v4/rsyslog:8.39.0
Container caasp/v4/skuba-tooling:0.1.0
Container caasp/v4/test-update:beta
Container caasp/v4/velero-plugin-for-aws:1.0.1
Container caasp/v4/velero-plugin-for-gcp:1.0.1
Container caasp/v4/velero-plugin-for-microsoft-azure:1.0.1
Container caasp/v4/velero-restic-restore-helper:1.3.1
Container caasp/v4/velero:1.3.1
Container ses/6/cephcsi/cephcsi:1.1.0.0.1.5.2
Container ses/6/rook/ceph:1.0.0.1862.1.5.2
Container suse/sle15:15.0.4.13.1
Container suse/sle15:15.1.6.2.31
Image SLES15-Azure-BYOS
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-EC2-HVM-BYOS
Image SLES15-GCE-BYOS
Image SLES15-OCI-BYOS
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP1-Azure-BYOS
Image SLES15-SP1-Azure-HPC-BYOS
Image SLES15-SP1-CAP-Deployment-BYOS-EC2-HVM
Image SLES15-SP1-CAP-Deployment-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-EC2-HPC-HVM-BYOS
Image SLES15-SP1-EC2-HVM-BYOS
Image SLES15-SP1-GCE-BYOS
Image SLES15-SP1-Manager-4-0-Azure-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-Azure-BYOS-Server
Image SLES15-SP1-Manager-4-0-EC2-HVM-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-EC2-HVM-BYOS-Server
Image SLES15-SP1-Manager-4-0-GCE-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-GCE-BYOS-Server
Image SLES15-SP1-OCI-BYOS
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
  • libgnutls30 >= 3.6.7-6.8.1
Image SLES15-SAP-Azure
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-EC2-HVM
Image SLES15-SAP-EC2-HVM-BYOS
Image SLES15-SAP-GCE
Image SLES15-SAP-GCE-BYOS
Image SLES15-SAP-OCI-BYOS
Image SLES15-SP1-SAP-Azure
Image SLES15-SP1-SAP-Azure-BYOS
Image SLES15-SP1-SAP-EC2-HVM
Image SLES15-SP1-SAP-EC2-HVM-BYOS
Image SLES15-SP1-SAP-GCE
Image SLES15-SP1-SAP-GCE-BYOS
Image SLES15-SP1-SAP-OCI-BYOS
  • gnutls >= 3.6.7-6.8.1
  • libgnutls30 >= 3.6.7-6.8.1
Image SLES15-SP1-SAPCAL-Azure
Image SLES15-SP1-SAPCAL-EC2-HVM
Image SLES15-SP1-SAPCAL-GCE
  • libgnutls30 >= 3.6.7-6.8.1
  • libgnutls30-32bit >= 3.6.7-6.8.1
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • gnutls >= 3.6.7-6.8.1
  • libgnutls-devel >= 3.6.7-6.8.1
  • libgnutls30 >= 3.6.7-6.8.1
  • libgnutls30-32bit >= 3.6.7-6.8.1
  • libgnutlsxx-devel >= 3.6.7-6.8.1
  • libgnutlsxx28 >= 3.6.7-6.8.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA gnutls-3.6.7-6.8.1
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • gnutls >= 3.6.7-14.10.2
  • libgnutls-devel >= 3.6.7-14.10.2
  • libgnutls30 >= 3.6.7-14.10.2
  • libgnutls30-32bit >= 3.6.7-14.10.2
  • libgnutls30-hmac >= 3.6.7-14.10.2
  • libgnutls30-hmac-32bit >= 3.6.7-14.10.2
  • libgnutlsxx-devel >= 3.6.7-14.10.2
  • libgnutlsxx28 >= 3.6.7-14.10.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA gnutls-3.6.7-14.10.2
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • gnutls >= 3.6.7-12.1
  • libgnutls-devel >= 3.6.7-12.1
  • libgnutls30 >= 3.6.7-12.1
  • libgnutls30-32bit >= 3.6.7-12.1
  • libgnutls30-hmac >= 3.6.7-12.1
  • libgnutls30-hmac-32bit >= 3.6.7-12.1
  • libgnutlsxx-devel >= 3.6.7-12.1
  • libgnutlsxx28 >= 3.6.7-12.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA gnutls-3.6.7-12.1
SUSE Liberty Linux 8
  • gnutls >= 3.6.8-8.el8
  • gnutls-c++ >= 3.6.8-8.el8
  • gnutls-dane >= 3.6.8-8.el8
  • gnutls-devel >= 3.6.8-8.el8
  • gnutls-utils >= 3.6.8-8.el8
Patchnames:
RHSA-2019:3600
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • gnutls >= 3.7.3-150400.2.12
  • libgnutls-devel >= 3.7.3-150400.2.12
  • libgnutls30 >= 3.7.3-150400.2.12
  • libgnutls30-32bit >= 3.7.3-150400.2.12
  • libgnutls30-hmac >= 3.7.3-150400.2.12
  • libgnutls30-hmac-32bit >= 3.7.3-150400.2.12
  • libgnutlsxx-devel >= 3.7.3-150400.2.12
  • libgnutlsxx28 >= 3.7.3-150400.2.12
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA gnutls-3.7.3-150400.2.12
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • gnutls >= 3.7.3-150400.4.35.1
  • libgnutls-devel >= 3.7.3-150400.4.35.1
  • libgnutls30 >= 3.7.3-150400.4.35.1
  • libgnutls30-32bit >= 3.7.3-150400.4.35.1
  • libgnutls30-hmac >= 3.7.3-150400.4.35.1
  • libgnutls30-hmac-32bit >= 3.7.3-150400.4.35.1
  • libgnutlsxx-devel >= 3.7.3-150400.4.35.1
  • libgnutlsxx28 >= 3.7.3-150400.4.35.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA gnutls-3.7.3-150400.4.35.1
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • gnutls >= 3.6.7-6.8.1
  • libgnutls-devel >= 3.6.7-6.8.1
  • libgnutls30 >= 3.6.7-6.8.1
  • libgnutls30-32bit >= 3.6.7-6.8.1
  • libgnutlsxx-devel >= 3.6.7-6.8.1
  • libgnutlsxx28 >= 3.6.7-6.8.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1121
SUSE-SLE-Module-Desktop-Applications-15-2019-1121
SUSE Linux Enterprise Micro 5.0
  • libgnutls30 >= 3.6.7-14.7.1
Patchnames:
SUSE Linux Enterprise Micro 5.0 GA libgnutls30-3.6.7-14.7.1
SUSE Linux Enterprise Micro 5.1
  • libgnutls30 >= 3.6.7-14.13.5
  • libgnutls30-hmac >= 3.6.7-14.13.5
Patchnames:
SUSE Linux Enterprise Micro 5.1 GA libgnutls30-3.6.7-14.13.5
SUSE Linux Enterprise Micro 5.2
  • gnutls >= 3.6.7-14.16.1
  • libgnutls30 >= 3.6.7-14.16.1
  • libgnutls30-hmac >= 3.6.7-14.16.1
Patchnames:
SUSE Linux Enterprise Micro 5.2 GA gnutls-3.6.7-14.16.1
SUSE Linux Enterprise Micro 5.3
  • gnutls >= 3.7.3-150400.4.13.1
  • libgnutls30 >= 3.7.3-150400.4.13.1
  • libgnutls30-hmac >= 3.7.3-150400.4.13.1
Patchnames:
SUSE Linux Enterprise Micro 5.3 GA gnutls-3.7.3-150400.4.13.1
SUSE Linux Enterprise Micro 5.4
  • gnutls >= 3.7.3-150400.4.27.1
  • libgnutls30 >= 3.7.3-150400.4.27.1
  • libgnutls30-hmac >= 3.7.3-150400.4.27.1
Patchnames:
SUSE Linux Enterprise Micro 5.4 GA gnutls-3.7.3-150400.4.27.1
SUSE Linux Enterprise Micro 6.0
  • gnutls >= 3.8.3-1.13
  • libgnutls30 >= 3.8.3-1.13
Patchnames:
SUSE Linux Enterprise Micro 6.0 GA gnutls-3.8.3-1.13
SUSE Linux Enterprise Module for Basesystem 15
  • gnutls >= 3.6.7-6.8.1
  • libgnutls-devel >= 3.6.7-6.8.1
  • libgnutls30 >= 3.6.7-6.8.1
  • libgnutls30-32bit >= 3.6.7-6.8.1
  • libgnutlsxx-devel >= 3.6.7-6.8.1
  • libgnutlsxx28 >= 3.6.7-6.8.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1121
SUSE Linux Enterprise Module for Desktop Applications 15
  • libgnutls30-32bit >= 3.6.7-6.8.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-1121
openSUSE Leap 15.0
  • gnutls >= 3.6.7-lp150.9.1
  • gnutls-guile >= 3.6.7-lp150.9.1
  • libgnutls-dane-devel >= 3.6.7-lp150.9.1
  • libgnutls-dane0 >= 3.6.7-lp150.9.1
  • libgnutls-devel >= 3.6.7-lp150.9.1
  • libgnutls-devel-32bit >= 3.6.7-lp150.9.1
  • libgnutls30 >= 3.6.7-lp150.9.1
  • libgnutls30-32bit >= 3.6.7-lp150.9.1
  • libgnutlsxx-devel >= 3.6.7-lp150.9.1
  • libgnutlsxx28 >= 3.6.7-lp150.9.1
Patchnames:
openSUSE-2019-1353
openSUSE Leap 15.2
  • gnutls >= 3.6.7-lp152.8.3
  • libgnutls-dane0 >= 3.6.7-lp152.8.3
  • libgnutls30 >= 3.6.7-lp152.8.3
  • libgnutls30-32bit >= 3.6.7-lp152.8.1
Patchnames:
openSUSE Leap 15.2 GA gnutls-3.6.7-lp152.8.1
openSUSE Leap 15.3
  • gnutls >= 3.6.7-14.10.2
  • libgnutls30 >= 3.6.7-14.10.2
  • libgnutls30-32bit >= 3.6.7-14.10.2
Patchnames:
openSUSE Leap 15.3 GA gnutls-3.6.7-14.10.2
openSUSE Leap 15.4
  • gnutls >= 3.7.3-150400.2.12
  • libgnutls30 >= 3.7.3-150400.2.12
  • libgnutls30-32bit >= 3.7.3-150400.2.12
Patchnames:
openSUSE Leap 15.4 GA gnutls-3.7.3-150400.2.12
openSUSE Tumbleweed
  • gnutls >= 3.7.2-1.2
  • gnutls-guile >= 3.7.2-1.2
  • libgnutls-dane-devel >= 3.7.2-1.2
  • libgnutls-dane0 >= 3.7.2-1.2
  • libgnutls-devel >= 3.7.2-1.2
  • libgnutls-devel-32bit >= 3.7.2-1.2
  • libgnutls30 >= 3.7.2-1.2
  • libgnutls30-32bit >= 3.7.2-1.2
  • libgnutls30-hmac >= 3.7.2-1.2
  • libgnutlsxx-devel >= 3.7.2-1.2
  • libgnutlsxx28 >= 3.7.2-1.2
Patchnames:
openSUSE-Tumbleweed-2024-10801


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP6 gnutls Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP6 gnutls Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP6 gnutls Already fixed
SUSE Linux Enterprise Server 12 SP5 gnutls Not affected
SUSE Linux Enterprise Server 15 SP6 gnutls Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 gnutls Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 gnutls Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 15-ESPOS gnutls Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 gnutls Unsupported
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 gnutls Not affected
SLES for SAP Applications 11 SP3 gnutls Not affected
SUSE CaaS Platform 4.0 gnutls Affected
SUSE Enterprise Storage 6 gnutls Released
SUSE Linux Enterprise Desktop 11 SP4 gnutls Not affected
SUSE Linux Enterprise Desktop 12 gnutls Not affected
SUSE Linux Enterprise Desktop 12 SP1 gnutls Not affected
SUSE Linux Enterprise Desktop 12 SP2 gnutls Not affected
SUSE Linux Enterprise Desktop 12 SP3 gnutls Not affected
SUSE Linux Enterprise Desktop 12 SP4 gnutls Not affected
SUSE Linux Enterprise Desktop 15 gnutls Released
SUSE Linux Enterprise Desktop 15 SP1 gnutls Released
SUSE Linux Enterprise High Availability Extension 11 SP4 gnutls Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 gnutls Not affected
SUSE Linux Enterprise High Performance Computing 15 gnutls Released
SUSE Linux Enterprise High Performance Computing 15 SP1 gnutls Released
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS gnutls Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS gnutls Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS gnutls Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS gnutls Unsupported
SUSE Linux Enterprise Module for Basesystem 15 gnutls Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 gnutls Released
SUSE Linux Enterprise Module for Desktop Applications 15 gnutls Released
SUSE Linux Enterprise Server 11 SP3 gnutls Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS gnutls Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS gnutls Not affected
SUSE Linux Enterprise Server 11 SP4 gnutls Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS gnutls Not affected
SUSE Linux Enterprise Server 12 gnutls Not affected
SUSE Linux Enterprise Server 12 SP1 gnutls Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS gnutls Not affected
SUSE Linux Enterprise Server 12 SP2 gnutls Not affected
SUSE Linux Enterprise Server 12 SP2-BCL gnutls Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS gnutls Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS gnutls Not affected
SUSE Linux Enterprise Server 12 SP3 gnutls Not affected
SUSE Linux Enterprise Server 12 SP3-BCL gnutls Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS gnutls Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS gnutls Not affected
SUSE Linux Enterprise Server 12 SP4 gnutls Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS gnutls Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS gnutls Not affected
SUSE Linux Enterprise Server 12-LTSS gnutls Not affected
SUSE Linux Enterprise Server 15 gnutls Released
SUSE Linux Enterprise Server 15 SP1 gnutls Released
SUSE Linux Enterprise Server 15 SP1-BCL gnutls Affected
SUSE Linux Enterprise Server 15 SP1-LTSS gnutls Affected
SUSE Linux Enterprise Server 15-LTSS gnutls Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 12 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 15 gnutls Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 gnutls Released
SUSE Linux Enterprise Software Development Kit 11 SP4 gnutls Not affected
SUSE Linux Enterprise Software Development Kit 12 gnutls Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 gnutls Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 gnutls Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 gnutls Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 gnutls Not affected
SUSE Manager Proxy 4.0 gnutls Released
SUSE Manager Retail Branch Server 4.0 gnutls Released
SUSE Manager Server 4.0 gnutls Released
SUSE OpenStack Cloud 7 gnutls Not affected
SUSE OpenStack Cloud 8 gnutls Not affected
SUSE OpenStack Cloud 9 gnutls Not affected
SUSE OpenStack Cloud Crowbar 8 gnutls Not affected
SUSE OpenStack Cloud Crowbar 9 gnutls Not affected
Container Status
suse/sles/15.6/virt-launcher:1.1.1 gnutlsAlready fixed


SUSE Timeline for this CVE

CVE page created: Wed Mar 27 12:23:41 2019
CVE page last modified: Sun Jun 16 00:25:12 2024