Upstream information

CVE-2019-3827 at MITRE

Description

An incorrect permission check in the admin backend in gvfs before version 1.39.4 was found that allows reading and modify arbitrary files by privileged users without asking for password when no authentication agent is running. This vulnerability can be exploited by malicious programs running under privileges of users belonging to the wheel group to further escalate its privileges by modifying system files without user's knowledge. Successful exploitation requires uncommon system configuration.

SUSE information

SUSE Bugzilla entry: 1125084 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • gvfs >= 1.34.2.1-4.6.1
  • gvfs-backend-afc >= 1.34.2.1-4.6.1
  • gvfs-backend-samba >= 1.34.2.1-4.6.1
  • gvfs-backends >= 1.34.2.1-4.6.1
  • gvfs-devel >= 1.34.2.1-4.6.1
  • gvfs-fuse >= 1.34.2.1-4.6.1
  • gvfs-lang >= 1.34.2.1-4.6.1
SUSE Linux Enterprise Module for Desktop Applications 15
  • gvfs >= 1.34.2.1-4.6.1
  • gvfs-backend-afc >= 1.34.2.1-4.6.1
  • gvfs-backend-samba >= 1.34.2.1-4.6.1
  • gvfs-backends >= 1.34.2.1-4.6.1
  • gvfs-devel >= 1.34.2.1-4.6.1
  • gvfs-fuse >= 1.34.2.1-4.6.1
  • gvfs-lang >= 1.34.2.1-4.6.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-438
openSUSE Leap 15.0
  • gvfs >= 1.34.2.1-lp150.3.6.1
  • gvfs-32bit >= 1.34.2.1-lp150.3.6.1
  • gvfs-32bit-debuginfo >= 1.34.2.1-lp150.3.6.1
  • gvfs-backend-afc >= 1.34.2.1-lp150.3.6.1
  • gvfs-backend-afc-debuginfo >= 1.34.2.1-lp150.3.6.1
  • gvfs-backend-samba >= 1.34.2.1-lp150.3.6.1
  • gvfs-backend-samba-debuginfo >= 1.34.2.1-lp150.3.6.1
  • gvfs-backends >= 1.34.2.1-lp150.3.6.1
  • gvfs-backends-debuginfo >= 1.34.2.1-lp150.3.6.1
  • gvfs-debuginfo >= 1.34.2.1-lp150.3.6.1
  • gvfs-debugsource >= 1.34.2.1-lp150.3.6.1
  • gvfs-devel >= 1.34.2.1-lp150.3.6.1
  • gvfs-fuse >= 1.34.2.1-lp150.3.6.1
  • gvfs-fuse-debuginfo >= 1.34.2.1-lp150.3.6.1
  • gvfs-lang >= 1.34.2.1-lp150.3.6.1
Patchnames:
openSUSE-2019-261