Upstream information

CVE-2019-3825 at MITRE

Description

A vulnerability was discovered in gdm before 3.31.4. When timed login is enabled in configuration, an attacker could bypass the lock screen by selecting the timed login user and waiting for the timer to expire, at which time they would gain access to the logged-in user's session.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.4 6.2
Vector AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H AV:P/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Physical Physical
Access Complexity High High
Privileges Required None Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entry: 1124628 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
  • gdm >= 3.26.2.1-13.19.2
  • gdm-devel >= 3.26.2.1-13.19.2
  • gdm-lang >= 3.26.2.1-13.19.2
  • gdmflexiserver >= 3.26.2.1-13.19.2
  • libgdm1 >= 3.26.2.1-13.19.2
  • typelib-1_0-Gdm-1_0 >= 3.26.2.1-13.19.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-527
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • gdm >= 3.26.2.1-13.19.2
  • gdm-devel >= 3.26.2.1-13.19.2
  • gdm-lang >= 3.26.2.1-13.19.2
  • gdmflexiserver >= 3.26.2.1-13.19.2
  • libgdm1 >= 3.26.2.1-13.19.2
  • typelib-1_0-Gdm-1_0 >= 3.26.2.1-13.19.2
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA gdm
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • gdm >= 3.26.2.1-13.19.2
  • gdm-branding-upstream >= 3.26.2.1-13.19.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-527
openSUSE Leap 15.0
  • gdm >= 3.26.2.1-lp150.11.9.1
  • gdm-branding-upstream >= 3.26.2.1-lp150.11.9.1
  • gdm-debuginfo >= 3.26.2.1-lp150.11.9.1
  • gdm-debugsource >= 3.26.2.1-lp150.11.9.1
  • gdm-devel >= 3.26.2.1-lp150.11.9.1
  • gdm-lang >= 3.26.2.1-lp150.11.9.1
  • gdmflexiserver >= 3.26.2.1-lp150.11.9.1
  • libgdm1 >= 3.26.2.1-lp150.11.9.1
  • libgdm1-debuginfo >= 3.26.2.1-lp150.11.9.1
  • typelib-1_0-Gdm-1_0 >= 3.26.2.1-lp150.11.9.1
Patchnames:
openSUSE-2019-310