Upstream information

CVE-2019-3825 at MITRE

Description

A vulnerability was discovered in gdm before 3.31.4. When timed login is enabled in configuration, an attacker could bypass the lock screen by selecting the timed login user and waiting for the timer to expire, at which time they would gain access to the logged-in user's session.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.4 6.2
Vector CVSS:3.0/AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:P/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Physical Physical
Access Complexity High High
Privileges Required None Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1124628 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • gdm >= 3.26.2.1-13.19.2
  • gdm-devel >= 3.26.2.1-13.19.2
  • gdm-lang >= 3.26.2.1-13.19.2
  • gdmflexiserver >= 3.26.2.1-13.19.2
  • libgdm1 >= 3.26.2.1-13.19.2
  • typelib-1_0-Gdm-1_0 >= 3.26.2.1-13.19.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • gdm >= 3.34.1-6.19
  • gdm-devel >= 3.34.1-6.19
  • gdm-lang >= 3.34.1-6.19
  • gdm-systemd >= 3.34.1-6.19
  • gdmflexiserver >= 3.34.1-6.19
  • libgdm1 >= 3.34.1-6.19
  • typelib-1_0-Gdm-1_0 >= 3.34.1-6.19
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • gdm >= 3.34.1-8.15.1
  • gdm-devel >= 3.34.1-8.15.1
  • gdm-lang >= 3.34.1-8.15.1
  • gdm-systemd >= 3.34.1-8.15.1
  • gdmflexiserver >= 3.34.1-8.15.1
  • libgdm1 >= 3.34.1-8.15.1
  • typelib-1_0-Gdm-1_0 >= 3.34.1-8.15.1
SUSE Linux Enterprise Module for Desktop Applications 15
  • gdm >= 3.26.2.1-13.19.2
  • gdm-devel >= 3.26.2.1-13.19.2
  • gdm-lang >= 3.26.2.1-13.19.2
  • gdmflexiserver >= 3.26.2.1-13.19.2
  • libgdm1 >= 3.26.2.1-13.19.2
  • typelib-1_0-Gdm-1_0 >= 3.26.2.1-13.19.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-527
openSUSE Leap 15.0
  • gdm >= 3.26.2.1-lp150.11.9.1
  • gdm-branding-upstream >= 3.26.2.1-lp150.11.9.1
  • gdm-devel >= 3.26.2.1-lp150.11.9.1
  • gdm-lang >= 3.26.2.1-lp150.11.9.1
  • gdmflexiserver >= 3.26.2.1-lp150.11.9.1
  • libgdm1 >= 3.26.2.1-lp150.11.9.1
  • typelib-1_0-Gdm-1_0 >= 3.26.2.1-lp150.11.9.1
Patchnames:
openSUSE-2019-310
openSUSE Tumbleweed
  • gdm >= 3.38.2-2.7
  • gdm-branding-upstream >= 3.38.2-2.7
  • gdm-devel >= 3.38.2-2.7
  • gdm-lang >= 3.38.2-2.7
  • gdm-systemd >= 3.38.2-2.7
  • gdmflexiserver >= 3.38.2-2.7
  • libgdm1 >= 3.38.2-2.7
  • typelib-1_0-Gdm-1_0 >= 3.38.2-2.7
Patchnames:
openSUSE Tumbleweed GA gdm-3.38.2-2.7


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications gdm Ignore
SUSE CaaS Platform 4.0 gdm Released
SUSE Enterprise Storage 6 gdm Released
SUSE Linux Enterprise Desktop 12 SP3 gdm Not affected
SUSE Linux Enterprise Desktop 12 SP4 gdm Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 gdm Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS gdm Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS gdm Released
SUSE Linux Enterprise Module for Desktop Applications 15 gdm Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 gdm Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 gdm Already fixed
SUSE Linux Enterprise Server 11 SP3 LTSS gdm Ignore
SUSE Linux Enterprise Server 11 SP4 gdm Ignore
SUSE Linux Enterprise Server 12 LTSS gdm Unsupported
SUSE Linux Enterprise Server 12 SP1 LTSS gdm Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS gdm Not affected
SUSE Linux Enterprise Server 12 SP3 gdm Not affected
SUSE Linux Enterprise Server 12 SP4 gdm Not affected
SUSE Linux Enterprise Server 15 ESPOS gdm Released
SUSE Linux Enterprise Server 15 LTSS gdm Released
SUSE Linux Enterprise Server 15 SP1 LTSS gdm Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 gdm Released
SUSE Linux Enterprise Server for SAP Applications 12 gdm Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gdm Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gdm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gdm Not affected
SUSE Linux Enterprise Server for SAP Applications 15 gdm Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 gdm Released
SUSE Linux Enterprise Software Development Kit 12 SP3 gdm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 gdm Not affected
SUSE Manager Proxy 4.0 gdm Released
SUSE Manager Retail Branch Server 4.0 gdm Released
SUSE Manager Server 4.0 gdm Released