Upstream information

CVE-2019-3813 at MITRE

Description

Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.4
Vector AV:A/AC:M/Au:N/C:P/I:P/A:P
Access Vector Adjacent Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 8
Vector CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Attack Vector Adjacent Network Adjacent Network
Attack Complexity High High
Privileges Required None Low
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1122706 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • libspice-server1 >= 0.12.7-10.6.1
Patchnames:
SUSE-Storage-4-2019-230
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Server Applications 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libspice-server-devel >= 0.14.1-2.21
  • libspice-server1 >= 0.14.1-2.21
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA libspice-server-devel-0.14.1-2.21
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Server Applications 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libspice-server-devel >= 0.14.3-1.48
  • libspice-server1 >= 0.14.3-1.48
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA libspice-server-devel-0.14.3-1.48
SUSE Enterprise Storage 7
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Server Applications 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libspice-server-devel >= 0.14.2-1.58
  • libspice-server1 >= 0.14.2-1.58
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP2 GA libspice-server-devel-0.14.2-1.58
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libspice-server-devel >= 0.12.4-18.1
Patchnames:
sdksp4-spice-13943
SUSE Linux Enterprise Desktop 12 SP3
  • libspice-server-devel >= 0.12.8-12.1
  • libspice-server1 >= 0.12.8-12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-241
SUSE-SLE-SDK-12-SP3-2019-241
SUSE Linux Enterprise Desktop 12 SP4
  • libspice-server-devel >= 0.12.8-12.1
  • libspice-server1 >= 0.12.8-12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-241
SUSE-SLE-SDK-12-SP4-2019-241
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libspice-server1 >= 0.12.8-12.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libspice-server1-0.12.8-12.1
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Server Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libspice-server-devel >= 0.15.0-150400.2.8
  • libspice-server1 >= 0.15.0-150400.2.8
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA libspice-server-devel-0.15.0-150400.2.8
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libspice-server-devel >= 0.14.0-4.6.2
  • libspice-server1 >= 0.14.0-4.6.2
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-242
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libspice-server1 >= 0.12.7-10.6.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-230
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libspice-server-devel >= 0.12.4-18.1
  • libspice-server1 >= 0.12.4-18.1
Patchnames:
sdksp4-spice-13943
slessp4-spice-13943
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libspice-server1 >= 0.12.5-10.2.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-231
SUSE Linux Enterprise Server 12 SP2-BCL
  • libspice-server1 >= 0.12.7-10.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-230
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libspice-server1 >= 0.12.7-10.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-230
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libspice-server1 >= 0.12.7-10.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-230
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libspice-server-devel >= 0.12.8-12.1
  • libspice-server1 >= 0.12.8-12.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-241
SUSE-SLE-SERVER-12-SP3-2019-241
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libspice-server-devel >= 0.12.8-12.1
  • libspice-server1 >= 0.12.8-12.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-241
SUSE-SLE-SERVER-12-SP4-2019-241
SUSE Linux Enterprise Server 12 SP5
  • libspice-server-devel >= 0.12.8-12.1
  • libspice-server1 >= 0.12.8-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libspice-server1-0.12.8-12.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libspice-server-devel-0.12.8-12.1
SUSE Linux Enterprise Server 12-LTSS
  • libspice-server1 >= 0.12.4-8.21.1
Patchnames:
SUSE-SLE-SERVER-12-2019-229
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libspice-server1 >= 0.12.5-10.2.3.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-231
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libspice-server1 >= 0.12.7-10.6.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-230
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libspice-server-devel >= 0.12.8-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libspice-server-devel-0.12.8-12.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libspice-server-devel >= 0.12.8-12.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-241
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libspice-server-devel >= 0.12.8-12.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-241
SUSE OpenStack Cloud 7
  • libspice-server1 >= 0.12.7-10.6.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-230
openSUSE Leap 15.0
  • libspice-server-devel >= 0.14.0-lp150.3.6.1
  • libspice-server1 >= 0.14.0-lp150.3.6.1
Patchnames:
openSUSE-2019-167
openSUSE Leap 15.2
  • libspice-server1 >= 0.14.2-lp152.1.4
Patchnames:
openSUSE Leap 15.2 GA libspice-server1-0.14.2-lp152.1.1
openSUSE Leap 15.3
  • libspice-server1 >= 0.14.3-1.48
Patchnames:
openSUSE Leap 15.3 GA libspice-server1-0.14.3-1.48
openSUSE Leap 15.4
  • libspice-server1 >= 0.15.0-150400.2.8
Patchnames:
openSUSE Leap 15.4 GA libspice-server1-0.15.0-150400.2.8
openSUSE Tumbleweed
  • libspice-server-devel >= 0.15.0-1.3
  • libspice-server1 >= 0.15.0-1.3
Patchnames:
openSUSE Tumbleweed GA libspice-server-devel-0.15.0-1.3


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 spice Affected
HPE Helion OpenStack 8 spice-gtk Not affected
SUSE CaaS Platform 4.0 spice Already fixed
SUSE Enterprise Storage 4 spice Released
SUSE Enterprise Storage 6 spice Already fixed
SUSE Linux Enterprise Desktop 11 SP4 spice Released
SUSE Linux Enterprise Desktop 12 spice Affected
SUSE Linux Enterprise Desktop 12 spice-gtk Not affected
SUSE Linux Enterprise Desktop 12 SP1 spice Affected
SUSE Linux Enterprise Desktop 12 SP1 spice-gtk Not affected
SUSE Linux Enterprise Desktop 12 SP2 spice Affected
SUSE Linux Enterprise Desktop 12 SP2 spice-gtk Not affected
SUSE Linux Enterprise Desktop 12 SP3 spice Released
SUSE Linux Enterprise Desktop 12 SP3 spice-gtk Not affected
SUSE Linux Enterprise Desktop 12 SP4 spice Released
SUSE Linux Enterprise Desktop 12 SP4 spice-gtk Not affected
SUSE Linux Enterprise Desktop 15 spice-gtk Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 spice Released
SUSE Linux Enterprise High Performance Computing 12 SP4 spice-gtk Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 spice Affected
SUSE Linux Enterprise High Performance Computing 15 spice Released
SUSE Linux Enterprise High Performance Computing 15 spice-gtk Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 spice Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS spice Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS spice Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS spice Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS spice-gtk Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS spice Released
SUSE Linux Enterprise High Performance Computing 15-LTSS spice-gtk Not affected
SUSE Linux Enterprise Module for Basesystem 15 spice-gtk Not affected
SUSE Linux Enterprise Module for Server Applications 15 spice Released
SUSE Linux Enterprise Module for Server Applications 15 spice-gtk Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 spice Already fixed
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT spice Released
SUSE Linux Enterprise Server 11 SP4 spice Released
SUSE Linux Enterprise Server 11 SP4 LTSS spice Released
SUSE Linux Enterprise Server 11 SP4-LTSS spice Released
SUSE Linux Enterprise Server 12 spice Affected
SUSE Linux Enterprise Server 12 spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP1 spice Affected
SUSE Linux Enterprise Server 12 SP1 spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS spice Released
SUSE Linux Enterprise Server 12 SP1-LTSS spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP2 spice Affected
SUSE Linux Enterprise Server 12 SP2 spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP2-BCL spice Released
SUSE Linux Enterprise Server 12 SP2-BCL spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS spice Released
SUSE Linux Enterprise Server 12 SP2-ESPOS spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS spice Released
SUSE Linux Enterprise Server 12 SP2-LTSS spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP3 spice Released
SUSE Linux Enterprise Server 12 SP3 spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP3-BCL spice Affected
SUSE Linux Enterprise Server 12 SP3-BCL spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS spice Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS spice Affected
SUSE Linux Enterprise Server 12 SP3-LTSS spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP4 spice Released
SUSE Linux Enterprise Server 12 SP4 spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS spice Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS spice Affected
SUSE Linux Enterprise Server 12 SP4-LTSS spice-gtk Not affected
SUSE Linux Enterprise Server 12 SP5 spice Affected
SUSE Linux Enterprise Server 12 SP5 spice-gtk Not affected
SUSE Linux Enterprise Server 12-LTSS spice Released
SUSE Linux Enterprise Server 12-LTSS spice-gtk Not affected
SUSE Linux Enterprise Server 15 spice Released
SUSE Linux Enterprise Server 15 spice-gtk Not affected
SUSE Linux Enterprise Server 15 SP1 spice Already fixed
SUSE Linux Enterprise Server 15 SP1-BCL spice Already fixed
SUSE Linux Enterprise Server 15 SP1-LTSS spice Already fixed
SUSE Linux Enterprise Server 15-ESPOS spice Released
SUSE Linux Enterprise Server 15-LTSS spice Released
SUSE Linux Enterprise Server 15-LTSS spice-gtk Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 spice Already fixed
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 spice-gtk Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 spice Released
SUSE Linux Enterprise Server for SAP Applications 12 spice Affected
SUSE Linux Enterprise Server for SAP Applications 12 spice-gtk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 spice Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 spice-gtk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 spice Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 spice-gtk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 spice Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 spice-gtk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 spice Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 spice-gtk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 spice Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 spice-gtk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 spice Released
SUSE Linux Enterprise Server for SAP Applications 15 spice-gtk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 spice Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP4 spice Released
SUSE Linux Enterprise Software Development Kit 12 spice Affected
SUSE Linux Enterprise Software Development Kit 12 spice-gtk Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 spice Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 spice-gtk Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 spice Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 spice-gtk Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 spice Released
SUSE Linux Enterprise Software Development Kit 12 SP3 spice-gtk Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 spice Released
SUSE Linux Enterprise Software Development Kit 12 SP4 spice-gtk Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 spice Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 spice-gtk Not affected
SUSE Manager Proxy 4.0 spice Already fixed
SUSE Manager Retail Branch Server 4.0 spice Already fixed
SUSE Manager Server 4.0 spice Already fixed
SUSE OpenStack Cloud 7 spice Released
SUSE OpenStack Cloud 7 spice-gtk Not affected
SUSE OpenStack Cloud 8 spice Affected
SUSE OpenStack Cloud 8 spice-gtk Not affected
SUSE OpenStack Cloud 9 spice Affected
SUSE OpenStack Cloud 9 spice-gtk Not affected
SUSE OpenStack Cloud Crowbar 8 spice Affected
SUSE OpenStack Cloud Crowbar 8 spice-gtk Not affected
SUSE OpenStack Cloud Crowbar 9 spice Affected
SUSE OpenStack Cloud Crowbar 9 spice-gtk Not affected


SUSE Timeline for this CVE

CVE page created: Tue Jan 22 07:07:41 2019
CVE page last modified: Tue Nov 29 14:24:48 2022