Upstream information

CVE-2019-3700 at MITRE

Description

yast2-security didn't use secure defaults to protect passwords. This became a problem on 2019-10-07 when configuration files that set secure settings were moved to a different location. As of the 20191022 snapshot the insecure default settings were used until yast2-security switched to stronger defaults in 4.2.6 and used the new configuration file locations. Password created during this time used DES password encryption and are not properly protected against attackers that are able to access the password hashes.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 3.3 5.1
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None Low
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1157465 [RESOLVED / FIXED], 1157541 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • yast2-security >= 4.2.12-1.27
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA yast2-security-4.2.12-1.27
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • yast2-security >= 4.3.16-1.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA yast2-security-4.3.16-1.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • yast2-security >= 4.4.13-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA yast2-security-4.4.13-150400.1.7
openSUSE Leap 15.2
  • yast2-security >= 4.2.12-lp152.1.2
Patchnames:
openSUSE Leap 15.2 GA yast2-security-4.2.12-lp152.1.1
openSUSE Leap 15.3
  • yast2-security >= 4.3.16-1.1
Patchnames:
openSUSE Leap 15.3 GA yast2-security-4.3.16-1.1
openSUSE Leap 15.4
  • yast2-security >= 4.4.13-150400.1.7
Patchnames:
openSUSE Leap 15.4 GA yast2-security-4.4.13-150400.1.7
openSUSE Tumbleweed
  • yast2-security >= 4.4.1-1.2
Patchnames:
openSUSE Tumbleweed GA yast2-security-4.4.1-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 15 SP2 yast2 Already fixed
SUSE Linux Enterprise Desktop 15 SP2 yast2-security Already fixed
SUSE Linux Enterprise Desktop 15 SP2 yast2-users Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 yast2 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 yast2-security Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 yast2-users Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 yast2 Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 yast2-security Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 yast2-users Already fixed
SUSE Linux Enterprise Server 15 SP2 yast2 Already fixed
SUSE Linux Enterprise Server 15 SP2 yast2-security Already fixed
SUSE Linux Enterprise Server 15 SP2 yast2-users Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 yast2 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 yast2-security Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 yast2-users Already fixed
SUSE Linux Enterprise Storage 7 yast2 Already fixed
SUSE Linux Enterprise Storage 7 yast2-security Already fixed
SUSE Linux Enterprise Storage 7 yast2-users Already fixed
SUSE Manager Proxy 4.1 yast2 Already fixed
SUSE Manager Proxy 4.1 yast2-security Already fixed
SUSE Manager Proxy 4.1 yast2-users Already fixed
SUSE Manager Retail Branch Server 4.1 yast2 Already fixed
SUSE Manager Retail Branch Server 4.1 yast2-security Already fixed
SUSE Manager Retail Branch Server 4.1 yast2-users Already fixed
SUSE Manager Server 4.1 yast2 Already fixed
SUSE Manager Server 4.1 yast2-security Already fixed
SUSE Manager Server 4.1 yast2-users Already fixed