Upstream information

CVE-2019-25051 at MITRE

Description

objstack in GNU Aspell 0.60.8 has a heap-based buffer overflow in acommon::ObjStack::dup_top (called from acommon::StringMap::add and acommon::Config::lookup_list).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1188576 [NEW], 1189485 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
HPE-Helion-OpenStack-8-2021-2848
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • aspell >= 0.60.8-3.3.1
  • aspell-devel >= 0.60.8-3.3.1
  • libaspell15 >= 0.60.8-3.3.1
  • libpspell15 >= 0.60.8-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-2794
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • aspell >= 0.60.8-3.3.1
  • aspell-devel >= 0.60.8-3.3.1
  • libaspell15 >= 0.60.8-3.3.1
  • libpspell15 >= 0.60.8-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-2794
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • aspell-ispell >= 0.60.8-3.3.1
  • aspell-spell >= 0.60.8-3.3.1
  • libaspell15-32bit >= 0.60.8-3.3.1
  • libpspell15-32bit >= 0.60.8-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-2794
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • aspell-ispell >= 0.60.8-3.3.1
  • aspell-spell >= 0.60.8-3.3.1
  • libaspell15-32bit >= 0.60.8-3.3.1
  • libpspell15-32bit >= 0.60.8-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-2794
SUSE Linux Enterprise Point of Sale 11 SP3
  • aspell >= 0.60.6-26.36.1
  • aspell-ispell >= 0.60.6-26.36.1
Patchnames:
sleposp3-aspell-14783
SUSE Linux Enterprise Server 11 SP4-LTSS
  • aspell >= 0.60.6-26.36.1
  • aspell-32bit >= 0.60.6-26.36.1
  • aspell-ispell >= 0.60.6-26.36.1
Patchnames:
slessp4-aspell-14783
SUSE Linux Enterprise Server 12 SP2-BCL
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2021-2848
SUSE Linux Enterprise Server 12 SP3-BCL
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2021-2848
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2021-2848
SUSE Linux Enterprise Server 12 SP3-LTSS
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2021-2848
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-2848
SUSE Linux Enterprise Server 12 SP4-LTSS
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-2848
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-2848
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2021-2848
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-2848
SUSE Linux Enterprise Software Development Kit 12 SP5
  • aspell-devel >= 0.60.6.1-18.11.1
  • libpspell15 >= 0.60.6.1-18.11.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-2848
SUSE OpenStack Cloud 8
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-OpenStack-Cloud-8-2021-2848
SUSE OpenStack Cloud 9
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-2848
SUSE OpenStack Cloud Crowbar 8
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-2848
SUSE OpenStack Cloud Crowbar 9
  • aspell >= 0.60.6.1-18.11.1
  • aspell-ispell >= 0.60.6.1-18.11.1
  • libaspell15 >= 0.60.6.1-18.11.1
  • libaspell15-32bit >= 0.60.6.1-18.11.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-2848
openSUSE Leap 15.2
  • aspell >= 0.60.8-lp152.2.3.1
  • aspell-devel >= 0.60.8-lp152.2.3.1
  • aspell-ispell >= 0.60.8-lp152.2.3.1
  • aspell-spell >= 0.60.8-lp152.2.3.1
  • libaspell15 >= 0.60.8-lp152.2.3.1
  • libaspell15-32bit >= 0.60.8-lp152.2.3.1
  • libpspell15 >= 0.60.8-lp152.2.3.1
  • libpspell15-32bit >= 0.60.8-lp152.2.3.1
Patchnames:
openSUSE-2021-1181
openSUSE Leap 15.3
  • aspell >= 0.60.8-3.3.1
  • aspell-devel >= 0.60.8-3.3.1
  • aspell-ispell >= 0.60.8-3.3.1
  • aspell-spell >= 0.60.8-3.3.1
  • libaspell15 >= 0.60.8-3.3.1
  • libaspell15-32bit >= 0.60.8-3.3.1
  • libpspell15 >= 0.60.8-3.3.1
  • libpspell15-32bit >= 0.60.8-3.3.1
Patchnames:
openSUSE-SLE-15.3-2021-2794
openSUSE Tumbleweed
  • aspell >= 0.60.8-4.2
  • aspell-devel >= 0.60.8-4.2
  • aspell-ispell >= 0.60.8-4.2
  • aspell-spell >= 0.60.8-4.2
  • libaspell15 >= 0.60.8-4.2
  • libaspell15-32bit >= 0.60.8-4.2
  • libpspell15 >= 0.60.8-4.2
  • libpspell15-32bit >= 0.60.8-4.2
Patchnames:
openSUSE Tumbleweed GA aspell-0.60.8-4.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 aspell Released
SUSE Linux Enterprise High Performance Computing 12 SP5 aspell Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 aspell Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 aspell Released
SUSE Linux Enterprise Point of Service 11 SP3 aspell Released
SUSE Linux Enterprise Server 11 SP4 LTSS aspell Released
SUSE Linux Enterprise Server 12 SP2 BCL aspell Released
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON aspell Released
SUSE Linux Enterprise Server 12 SP2 LTSS SAP aspell Released
SUSE Linux Enterprise Server 12 SP3 BCL aspell Released
SUSE Linux Enterprise Server 12 SP3 ESPOS aspell Released
SUSE Linux Enterprise Server 12 SP3 LTSS aspell Released
SUSE Linux Enterprise Server 12 SP4 ESPOS aspell Released
SUSE Linux Enterprise Server 12 SP4 LTSS aspell Released
SUSE Linux Enterprise Server 12 SP5 aspell Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 aspell Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 aspell Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 aspell In progress
SUSE Linux Enterprise Software Development Kit 12 SP5 aspell Released
SUSE OpenStack Cloud 8 aspell Released
SUSE OpenStack Cloud 9 aspell Released
SUSE OpenStack Cloud Crowbar 8 aspell Released
SUSE OpenStack Cloud Crowbar 9 aspell Released