Upstream information

CVE-2019-2126 at MITRE

Description

In ParseContentEncodingEntry of mkvparser.cc, there is a possible double free due to a missing reset of a freed pointer. This could lead to remote code execution with no additional execution privileges needed. User interaction is needed for exploitation. Product: Android. Versions: Android-7.0 Android-7.1.1 Android-7.1.2 Android-8.0 Android-8.1 Android-9. Android ID: A-127702368.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3.1
SUSE Bugzilla entry: 1160611 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libvpx4 >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-143
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libvpx4 >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-143
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libvpx4 >= 1.6.1-6.6.8
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libvpx-devel >= 1.6.1-6.6.8
  • libvpx4 >= 1.6.1-6.6.8
SUSE Linux Enterprise Module for Basesystem 15
  • libvpx4 >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2020-143
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libvpx-devel >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-143
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • libvpx-devel >= 1.6.1-6.6.8
SUSE Linux Enterprise Module for Desktop Applications 15
  • libvpx-devel >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2020-143
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libvpx4-32bit >= 1.6.1-6.3.1
  • vpx-tools >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-143
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • vpx-tools >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2020-143
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • vpx-tools >= 1.6.1-6.6.8
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • vpx-tools >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2020-143
SUSE Linux Enterprise Server 15-LTSS
  • libvpx4 >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-143
SUSE Linux Enterprise Server for SAP Applications 15
  • libvpx4 >= 1.6.1-6.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-143
openSUSE Leap 15.1
  • libvpx-devel >= 1.6.1-lp151.5.3.1
  • libvpx4 >= 1.6.1-lp151.5.3.1
  • libvpx4-32bit >= 1.6.1-lp151.5.3.1
  • vpx-tools >= 1.6.1-lp151.5.3.1
Patchnames:
openSUSE-2020-105
openSUSE Tumbleweed
  • libvpx-devel >= 1.10.0-1.3
  • libvpx6 >= 1.10.0-1.3
  • libvpx6-32bit >= 1.10.0-1.3
  • vpx-tools >= 1.10.0-1.3
Patchnames:
openSUSE Tumbleweed GA libvpx-devel-1.10.0-1.3


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 libvpx In progress
SUSE Enterprise Storage 6 libvpx In progress
SUSE Linux Enterprise Desktop 12 SP4 libvpx Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 libvpx Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libvpx Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS libvpx In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS libvpx In progress
SUSE Linux Enterprise Module for Basesystem 15 libvpx Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 libvpx Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 libvpx In progress
SUSE Linux Enterprise Module for Desktop Applications 15 libvpx Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 libvpx Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 libvpx In progress
SUSE Linux Enterprise Server 12 SP1 LTSS libvpx Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS libvpx Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS libvpx Not affected
SUSE Linux Enterprise Server 12 SP4 libvpx Not affected
SUSE Linux Enterprise Server 12 SP5 libvpx Not affected
SUSE Linux Enterprise Server 15 LTSS libvpx In progress
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux libvpx In progress
SUSE Linux Enterprise Server 15 SP1 LTSS libvpx In progress
SUSE Linux Enterprise Server ESPOS 15 libvpx In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libvpx Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libvpx Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libvpx Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libvpx Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libvpx In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libvpx In progress
SUSE Linux Enterprise Software Development Kit 12 SP4 libvpx Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 libvpx Not affected
SUSE Linux Enterprise Workstation Extension 12 libvpx Not affected
SUSE Manager Proxy 4.0 libvpx In progress
SUSE Manager Retail Branch Server 4.0 libvpx In progress
SUSE Manager Server 4.0 libvpx In progress