Upstream information

CVE-2019-19203 at MITRE

Description

An issue was discovered in Oniguruma 6.x before 6.9.4_rc2. In the function gb18030_mbc_enc_len in file gb18030.c, a UChar pointer is dereferenced without checking if it passed the end of the matched string. This leads to a heap-based buffer over-read.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1164550 [RESOLVED / FIXED], 1203568 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/sle-micro-rancher/5.2:latest
Container suse/sle-micro-rancher/5.3:latest
Image SLES15-SP3-CHOST-BYOS-Aliyun
Image SLES15-SP3-CHOST-BYOS-Azure
Image SLES15-SP3-CHOST-BYOS-EC2
Image SLES15-SP3-CHOST-BYOS-GCE
Image SLES15-SP4-CHOST-BYOS
Image SLES15-SP4-CHOST-BYOS-Aliyun
Image SLES15-SP4-CHOST-BYOS-Azure
Image SLES15-SP4-CHOST-BYOS-EC2
Image SLES15-SP4-CHOST-BYOS-GCE
  • libonig4 >= 6.7.0-150000.3.3.1
SUSE CaaS Platform 4.0
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2022-3327
SUSE Enterprise Storage 6
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-Storage-6-2022-3327
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-3327
SUSE Enterprise Storage 7
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-Storage-7-2022-3327
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-3327
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-3327
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-3327
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-3327
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-3327
SUSE Linux Enterprise Micro 5.1
  • libonig4 >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2022-3327
SUSE Linux Enterprise Micro 5.2
  • libonig4 >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2022-3327
SUSE Linux Enterprise Server 15 SP1-BCL
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2022-3327
SUSE Linux Enterprise Server 15 SP1-LTSS
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-3327
SUSE Linux Enterprise Server 15 SP2-BCL
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-BCL-2022-3327
SUSE Linux Enterprise Server 15 SP2-LTSS
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-3327
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2022-3327
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2022-3327
SUSE Manager Proxy 4.1
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-3327
SUSE Manager Retail Branch Server 4.1
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-3327
SUSE Manager Server 4.1
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-3327
openSUSE Leap 15.3
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
openSUSE-SLE-15.3-2022-3327
openSUSE Leap 15.4
  • libonig4 >= 6.7.0-150000.3.3.1
  • oniguruma-devel >= 6.7.0-150000.3.3.1
Patchnames:
openSUSE-SLE-15.4-2022-3327
openSUSE Leap Micro 5.2
  • libonig4 >= 6.7.0-150000.3.3.1
Patchnames:
openSUSE-Leap-Micro-5.2-2022-3327
openSUSE Tumbleweed
  • libonig5 >= 6.9.7.1-1.2
  • oniguruma-devel >= 6.9.7.1-1.2
Patchnames:
openSUSE Tumbleweed GA libonig5-6.9.7.1-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 oniguruma Released
SUSE Enterprise Storage 7.1 oniguruma Released
SUSE Linux Enterprise Desktop 15 SP4 oniguruma Released
SUSE Linux Enterprise High Performance Computing 12 SP5 oniguruma Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP4 oniguruma Released
SUSE Linux Enterprise Micro 5.1 oniguruma Released
SUSE Linux Enterprise Micro 5.2 oniguruma Released
SUSE Linux Enterprise Micro 5.3 oniguruma Affected
SUSE Linux Enterprise Micro for Rancher 5.2 oniguruma Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 oniguruma Released
SUSE Linux Enterprise Real Time 15 SP3 oniguruma Affected
SUSE Linux Enterprise Server 12 SP5 oniguruma Won't fix
SUSE Linux Enterprise Server 12-LTSS oniguruma Won't fix
SUSE Linux Enterprise Server 15 SP4 oniguruma Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 oniguruma Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP4 oniguruma Released
SUSE Linux Enterprise Software Development Kit 12 SP5 oniguruma Won't fix
SUSE Manager Proxy 4.2 oniguruma Released
SUSE Manager Proxy 4.3 oniguruma Released
SUSE Manager Retail Branch Server 4.2 oniguruma Released
SUSE Manager Retail Branch Server 4.3 oniguruma Released
SUSE Manager Server 4.2 oniguruma Released
SUSE Manager Server 4.3 oniguruma Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP4 oniguruma Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 oniguruma Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS oniguruma Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS oniguruma Released
SUSE Linux Enterprise High Performance Computing 15 SP2 oniguruma Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS oniguruma Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS oniguruma Released
SUSE Linux Enterprise High Performance Computing 15 SP3 oniguruma Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS oniguruma Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS oniguruma Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 oniguruma Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 oniguruma Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 oniguruma Released
SUSE Linux Enterprise Server 12 SP2-BCL oniguruma Won't fix
SUSE Linux Enterprise Server 12 SP4 oniguruma Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS oniguruma Won't fix
SUSE Linux Enterprise Server 15 SP1 oniguruma Affected
SUSE Linux Enterprise Server 15 SP1-LTSS oniguruma Released
SUSE Linux Enterprise Server 15 SP2 oniguruma Affected
SUSE Linux Enterprise Server 15 SP2-LTSS oniguruma Released
SUSE Linux Enterprise Server 15 SP3 oniguruma Released
SUSE Linux Enterprise Server 15 SP3-LTSS oniguruma Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 oniguruma Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 oniguruma Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 oniguruma Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP1 oniguruma Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 oniguruma Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 oniguruma Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 oniguruma Won't fix
SUSE CaaS Platform 4.0 oniguruma Released
SUSE CaaS Platform 4.5 oniguruma Affected
SUSE Enterprise Storage 6 oniguruma Released
SUSE Linux Enterprise Desktop 12 oniguruma Won't fix
SUSE Linux Enterprise Desktop 12 SP1 oniguruma Won't fix
SUSE Linux Enterprise Desktop 12 SP2 oniguruma Won't fix
SUSE Linux Enterprise Desktop 12 SP3 oniguruma Won't fix
SUSE Linux Enterprise Desktop 12 SP4 oniguruma Won't fix
SUSE Linux Enterprise Desktop 15 SP1 oniguruma Affected
SUSE Linux Enterprise Desktop 15 SP2 oniguruma Affected
SUSE Linux Enterprise Desktop 15 SP3 oniguruma Released
SUSE Linux Enterprise Real Time 15 SP2 oniguruma Affected
SUSE Linux Enterprise Server 12 oniguruma Won't fix
SUSE Linux Enterprise Server 12 SP1 oniguruma Won't fix
SUSE Linux Enterprise Server 12 SP1-LTSS oniguruma Unsupported
SUSE Linux Enterprise Server 12 SP2 oniguruma Won't fix
SUSE Linux Enterprise Server 12 SP2-ESPOS oniguruma Won't fix
SUSE Linux Enterprise Server 12 SP2-LTSS oniguruma Unsupported
SUSE Linux Enterprise Server 12 SP3 oniguruma Won't fix
SUSE Linux Enterprise Server 12 SP3-BCL oniguruma Won't fix
SUSE Linux Enterprise Server 12 SP3-ESPOS oniguruma Won't fix
SUSE Linux Enterprise Server 12 SP3-LTSS oniguruma Unsupported
SUSE Linux Enterprise Server 12 SP4-ESPOS oniguruma Won't fix
SUSE Linux Enterprise Server 15 SP1-BCL oniguruma Released
SUSE Linux Enterprise Server 15 SP2-BCL oniguruma Released
SUSE Linux Enterprise Server 15 SP3-BCL oniguruma Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 oniguruma Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 oniguruma Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP1 oniguruma Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP2 oniguruma Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 oniguruma Unsupported
SUSE Linux Enterprise Software Development Kit 12 oniguruma Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP1 oniguruma Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP2 oniguruma Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP3 oniguruma Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP4 oniguruma Won't fix
SUSE Manager Proxy 4.0 oniguruma Affected
SUSE Manager Proxy 4.1 oniguruma Released
SUSE Manager Retail Branch Server 4.0 oniguruma Affected
SUSE Manager Retail Branch Server 4.1 oniguruma Released
SUSE Manager Server 4.0 oniguruma Affected
SUSE Manager Server 4.1 oniguruma Released
SUSE OpenStack Cloud 7 oniguruma Won't fix
SUSE OpenStack Cloud 8 oniguruma Won't fix
SUSE OpenStack Cloud 9 oniguruma Won't fix
SUSE OpenStack Cloud Crowbar 8 oniguruma Won't fix
SUSE OpenStack Cloud Crowbar 9 oniguruma Won't fix


SUSE Timeline for this CVE

CVE page created: Fri Nov 22 01:56:11 2019
CVE page last modified: Wed Jan 25 01:15:53 2023