Upstream information

CVE-2019-18281 at MITRE

Description

An out-of-bounds memory access in the generateDirectionalRuns() function in qtextengine.cpp in Qt qtbase 5.11.x and 5.12.x before 5.12.5 allows attackers to cause a denial of service by crashing an application via a text file containing many directional characters.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 4.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1155020 [RESOLVED / UPSTREAM]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Server 12 SP5 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libqt5-qtbase Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 libqt5-qtbase Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP4 libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 15 libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP2-BCL libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP4 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libqt5-qtbase Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 libqt5-qtbase Not affected
SUSE CaaS Platform 4.0 libqt5-qtbase Not affected
SUSE Enterprise Storage 6 libqt5-qtbase Not affected
SUSE Linux Enterprise Desktop 12 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Desktop 12 SP2 libqt5-qtbase Not affected
SUSE Linux Enterprise Desktop 12 SP3 libqt5-qtbase Not affected
SUSE Linux Enterprise Desktop 12 SP4 libqt5-qtbase Not affected
SUSE Linux Enterprise Desktop 15 libqt5-qtbase Not affected
SUSE Linux Enterprise Desktop 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Module for Basesystem 15 libqt5-qtbase Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP2 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP3 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP3-BCL libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 15 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 15 SP1-BCL libqt5-qtbase Not affected
SUSE Linux Enterprise Server 15-LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libqt5-qtbase Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libqt5-qtbase Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libqt5-qtbase Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libqt5-qtbase Not affected
SUSE Manager Proxy 4.0 libqt5-qtbase Not affected
SUSE Manager Retail Branch Server 4.0 libqt5-qtbase Not affected
SUSE Manager Server 4.0 libqt5-qtbase Not affected
SUSE OpenStack Cloud 7 libqt5-qtbase Not affected
SUSE OpenStack Cloud 8 libqt5-qtbase Not affected
SUSE OpenStack Cloud 9 libqt5-qtbase Not affected
SUSE OpenStack Cloud Crowbar 8 libqt5-qtbase Not affected
SUSE OpenStack Cloud Crowbar 9 libqt5-qtbase Not affected


SUSE Timeline for this CVE

CVE page created: Wed Oct 23 20:15:32 2019
CVE page last modified: Fri Jan 20 15:04:43 2023