Upstream information

CVE-2019-17596 at MITRE


Go before 1.12.11 and 1.3.x before 1.13.2 can panic upon an attempt to process network traffic containing an invalid DSA public key. There are several attack scenarios, such as traffic from a client to a server that verifies client certificates.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.5
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1154402 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • go1.12 >= 1.12.12-lp150.11.1
  • go1.12-doc >= 1.12.12-lp150.11.1
  • go1.12-race >= 1.12.12-lp150.11.1
openSUSE Leap 15.1
  • go1.12 >= 1.12.12-lp151.2.25.1
  • go1.12-doc >= 1.12.12-lp151.2.25.1
  • go1.12-race >= 1.12.12-lp151.2.25.1
openSUSE Tumbleweed
  • go1.12 >= 1.12.17-4.8
  • go1.12-doc >= 1.12.17-4.8
  • go1.12-race >= 1.12.17-4.8
  • go1.13 >= 1.13.15-2.6
  • go1.13-doc >= 1.13.15-2.6
  • go1.13-race >= 1.13.15-2.6
  • notary >= 0.7.0-1.2
openSUSE Tumbleweed GA go1.12-1.12.17-4.8
openSUSE Tumbleweed GA go1.13-1.13.15-2.6
openSUSE Tumbleweed GA notary-0.7.0-1.2