Upstream information

CVE-2019-17582 at MITRE

Description

A use-after-free in the _zip_dirent_read function of zip_dirent.c in libzip 1.2.0 allows attackers to have an unspecified impact by attempting to unzip a malformed ZIP archive. NOTE: the discoverer states "This use-after-free is triggered prior to the double free reported in CVE-2017-12858."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1184178 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libzip Not affected
SUSE CaaS Platform 4.0 libzip Not affected
SUSE Enterprise Storage 5 libzip Not affected
SUSE Enterprise Storage 6 libzip Not affected
SUSE Linux Enterprise Desktop 15 SP1 libzip Not affected
SUSE Linux Enterprise Desktop 15 SP2 libzip Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libzip Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS libzip Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libzip Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS libzip Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 libzip Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 libzip Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 libzip Not affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 libzip Not affected
SUSE Linux Enterprise Server 12 SP2 BCL libzip Not affected
SUSE Linux Enterprise Server 12 SP2 ESPOS libzip Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS libzip Not affected
SUSE Linux Enterprise Server 12 SP3 BCL libzip Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS libzip Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS libzip Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS libzip Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS libzip Not affected
SUSE Linux Enterprise Server 12 SP5 libzip Not affected
SUSE Linux Enterprise Server 15 ESPOS libzip Not affected
SUSE Linux Enterprise Server 15 LTSS libzip Not affected
SUSE Linux Enterprise Server 15 SP1 libzip Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS libzip Not affected
SUSE Linux Enterprise Server 15 SP2 libzip Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libzip Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libzip Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libzip Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libzip Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libzip Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libzip Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libzip Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libzip Not affected
SUSE Linux Enterprise Storage 6 libzip Not affected
SUSE Linux Enterprise Storage 7 libzip Not affected
SUSE Manager Proxy 4.0 libzip Not affected
SUSE Manager Proxy 4.1 libzip Not affected
SUSE Manager Retail Branch Server 4.0 libzip Not affected
SUSE Manager Retail Branch Server 4.1 libzip Not affected
SUSE Manager Server 4.0 libzip Not affected
SUSE Manager Server 4.1 libzip Not affected
SUSE OpenStack Cloud 7 libzip Not affected
SUSE OpenStack Cloud 8 libzip Not affected
SUSE OpenStack Cloud 9 libzip Not affected
SUSE OpenStack Cloud Crowbar 8 libzip Not affected
SUSE OpenStack Cloud Crowbar 9 libzip Not affected