Upstream information

CVE-2019-17054 at MITRE

Description

atalk_create in net/appletalk/ddp.c in the AF_APPLETALK network module in the Linux kernel through 5.3.2 does not enforce CAP_NET_RAW, which means that unprivileged users can create a raw socket, aka CID-6cc03e8aa36c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  SUSE
Base Score 3.3
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Attack Vector Local
Attack Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entry: 1152786 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability Extension 11 SP4
SUSE Linux Enterprise Server 11 SP4
  • ocfs2-kmp-bigmem >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-default >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-pae >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-ppc64 >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-trace >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-xen >= 1.6_3.0.101_108.108-0.28.11.2
Patchnames:
slehasp4-kernel-source-14218
SUSE Linux Enterprise Server 11 SP4-LTSS
  • kernel-bigmem >= 3.0.101-108.108.1
  • kernel-bigmem-base >= 3.0.101-108.108.1
  • kernel-bigmem-devel >= 3.0.101-108.108.1
  • kernel-default >= 3.0.101-108.108.1
  • kernel-default-base >= 3.0.101-108.108.1
  • kernel-default-devel >= 3.0.101-108.108.1
  • kernel-default-man >= 3.0.101-108.108.1
  • kernel-ec2 >= 3.0.101-108.108.1
  • kernel-ec2-base >= 3.0.101-108.108.1
  • kernel-ec2-devel >= 3.0.101-108.108.1
  • kernel-pae >= 3.0.101-108.108.1
  • kernel-pae-base >= 3.0.101-108.108.1
  • kernel-pae-devel >= 3.0.101-108.108.1
  • kernel-ppc64 >= 3.0.101-108.108.1
  • kernel-ppc64-base >= 3.0.101-108.108.1
  • kernel-ppc64-devel >= 3.0.101-108.108.1
  • kernel-source >= 3.0.101-108.108.1
  • kernel-syms >= 3.0.101-108.108.1
  • kernel-trace >= 3.0.101-108.108.1
  • kernel-trace-base >= 3.0.101-108.108.1
  • kernel-trace-devel >= 3.0.101-108.108.1
  • kernel-xen >= 3.0.101-108.108.1
  • kernel-xen-base >= 3.0.101-108.108.1
  • kernel-xen-devel >= 3.0.101-108.108.1
Patchnames:
slessp4-kernel-source-14218


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP4 kernel-default Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 kernel-source Not affected
SUSE Linux Enterprise High Performance Computing 15 kernel-default Not affected
SUSE Linux Enterprise High Performance Computing 15 kernel-source Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 kernel-default Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 kernel-source Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS kernel-source Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS kernel-source Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS kernel-source Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS kernel-source Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 kernel-default Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 kernel-source Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 kernel-default Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 kernel-source Not affected
SUSE Linux Enterprise Server 12 SP2-BCL kernel-source Not affected
SUSE Linux Enterprise Server 12 SP4 kernel-default Not affected
SUSE Linux Enterprise Server 12 SP4 kernel-source Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS kernel-source Not affected
SUSE Linux Enterprise Server 15 SP1 kernel-default Not affected
SUSE Linux Enterprise Server 15 SP1 kernel-source Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS kernel-source Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 kernel-default Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 kernel-source Not affected
SUSE Linux Enterprise Server for SAP Applications 15 kernel-default Not affected
SUSE Linux Enterprise Server for SAP Applications 15 kernel-source Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 kernel-default Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 kernel-source Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 kernel-source Not affected
SUSE CaaS Platform 4.0 kernel-source Not affected
SUSE Enterprise Storage 6 kernel-default Not affected
SUSE Enterprise Storage 6 kernel-source Not affected
SUSE Linux Enterprise Desktop 12 SP1 kernel-source Not affected
SUSE Linux Enterprise Desktop 12 SP2 kernel-source Not affected
SUSE Linux Enterprise Desktop 12 SP3 kernel-source Not affected
SUSE Linux Enterprise Desktop 12 SP4 kernel-default Not affected
SUSE Linux Enterprise Desktop 12 SP4 kernel-source Not affected
SUSE Linux Enterprise Desktop 15 kernel-default Not affected
SUSE Linux Enterprise Desktop 15 kernel-source Not affected
SUSE Linux Enterprise Desktop 15 SP1 kernel-default Not affected
SUSE Linux Enterprise Desktop 15 SP1 kernel-source Not affected
SUSE Linux Enterprise High Availability Extension 11 SP4 ocfs2 Released
SUSE Linux Enterprise Micro 5.0 kernel-default Not affected
SUSE Linux Enterprise Module for Basesystem 15 kernel-default Not affected
SUSE Linux Enterprise Module for Basesystem 15 kernel-source Not affected
SUSE Linux Enterprise Module for Development Tools 15 kernel-default Not affected
SUSE Linux Enterprise Module for Development Tools 15 kernel-source Not affected
SUSE Linux Enterprise Server 11 SP4 kernel-source Affected
SUSE Linux Enterprise Server 11 SP4 ocfs2 Released
SUSE Linux Enterprise Server 11 SP4 LTSS kernel-default Released
SUSE Linux Enterprise Server 11 SP4 LTSS kernel-source Released
SUSE Linux Enterprise Server 11 SP4-LTSS kernel-bigmem Released
SUSE Linux Enterprise Server 11 SP4-LTSS kernel-default Released
SUSE Linux Enterprise Server 11 SP4-LTSS kernel-ec2 Released
SUSE Linux Enterprise Server 11 SP4-LTSS kernel-pae Released
SUSE Linux Enterprise Server 11 SP4-LTSS kernel-ppc64 Released
SUSE Linux Enterprise Server 11 SP4-LTSS kernel-source Released
SUSE Linux Enterprise Server 11 SP4-LTSS kernel-syms Released
SUSE Linux Enterprise Server 11 SP4-LTSS kernel-trace Released
SUSE Linux Enterprise Server 11 SP4-LTSS kernel-xen Released
SUSE Linux Enterprise Server 12 SP1 kernel-source Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS kernel-default Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP2 kernel-default Not affected
SUSE Linux Enterprise Server 12 SP2 kernel-source Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS kernel-default Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP3 kernel-source Not affected
SUSE Linux Enterprise Server 12 SP3-BCL kernel-source Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS kernel-default Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS kernel-source Not affected
SUSE Linux Enterprise Server 15 kernel-default Not affected
SUSE Linux Enterprise Server 15 kernel-source Not affected
SUSE Linux Enterprise Server 15 SP1-BCL kernel-source Not affected
SUSE Linux Enterprise Server 15-LTSS kernel-source Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 kernel-source Not affected
SUSE Linux Enterprise Server for SAP All-in-One 11 SP4 ocfs2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 kernel-source Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 kernel-default Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 kernel-source Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 kernel-default Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 kernel-source Not affected
SUSE Manager Proxy 4.0 kernel-default Not affected
SUSE Manager Proxy 4.0 kernel-source Not affected
SUSE Manager Retail Branch Server 4.0 kernel-default Not affected
SUSE Manager Retail Branch Server 4.0 kernel-source Not affected
SUSE Manager Server 4.0 kernel-default Not affected
SUSE Manager Server 4.0 kernel-source Not affected
SUSE OpenStack Cloud 7 kernel-source Not affected
SUSE OpenStack Cloud 8 kernel-source Not affected
SUSE OpenStack Cloud 9 kernel-source Not affected
SUSE OpenStack Cloud Crowbar 8 kernel-source Not affected
SUSE OpenStack Cloud Crowbar 9 kernel-source Not affected


SUSE Timeline for this CVE

CVE page created: Tue Oct 1 19:11:14 2019
CVE page last modified: Fri Jan 20 15:03:34 2023