Upstream information

CVE-2019-16276 at MITRE

Description

Go before 1.12.10 and 1.13.x before 1.13.1 allow HTTP Request Smuggling.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1152082 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • go1.12 >= 1.12.12-lp150.11.1
  • go1.12-doc >= 1.12.12-lp150.11.1
  • go1.12-race >= 1.12.12-lp150.11.1
Patchnames:
openSUSE-2019-2521
openSUSE Leap 15.1
  • go1.12 >= 1.12.12-lp151.2.25.1
  • go1.12-doc >= 1.12.12-lp151.2.25.1
  • go1.12-race >= 1.12.12-lp151.2.25.1
Patchnames:
openSUSE-2019-2522
openSUSE Tumbleweed
  • go1.12 >= 1.12.17-4.8
  • go1.12-doc >= 1.12.17-4.8
  • go1.12-race >= 1.12.17-4.8
  • go1.13 >= 1.13.15-2.6
  • go1.13-doc >= 1.13.15-2.6
  • go1.13-race >= 1.13.15-2.6
Patchnames:
openSUSE Tumbleweed GA go1.12-1.12.17-4.8
openSUSE Tumbleweed GA go1.13-1.13.15-2.6


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration docker Unsupported
Magnum Orchestration kubernetes Unsupported
SLES15-EC2-CHOST-HVM-BYOS docker Already fixed
SLES15-SP1-CHOST-BYOS-Azure docker Already fixed
SLES15-SP1-CHOST-BYOS-EC2 docker Already fixed
SLES15-SP1-CHOST-BYOS-GCE docker Already fixed
SLES15-SP2-CHOST-BYOS-Aliyun docker Already fixed
SLES15-SP2-CHOST-BYOS-Azure docker Already fixed
SLES15-SP2-CHOST-BYOS-EC2 docker Already fixed
SLES15-SP2-CHOST-BYOS-GCE docker Already fixed
SLES15-SP3-CHOST-BYOS-Aliyun docker Already fixed
SLES15-SP3-CHOST-BYOS-Azure docker Already fixed
SLES15-SP3-CHOST-BYOS-EC2 docker Already fixed
SLES15-SP3-CHOST-BYOS-GCE docker Already fixed
SLES15-SP4-CHOST-BYOS docker Already fixed
SLES15-SP4-CHOST-BYOS-Aliyun docker Already fixed
SLES15-SP4-CHOST-BYOS-Azure docker Already fixed
SLES15-SP4-CHOST-BYOS-EC2 docker Already fixed
SLES15-SP4-CHOST-BYOS-GCE docker Already fixed
SUSE CaaS Platform 3.0 docker Unsupported
SUSE CaaS Platform 3.0 kubernetes Unsupported
SUSE CaaS Platform 4.0 kubernetes Already fixed
SUSE Container as a Service Platform 1.0 docker Affected
SUSE Container as a Service Platform 1.0 kubernetes Affected
SUSE Container as a Service Platform 2.0 docker Unsupported
SUSE Container as a Service Platform 2.0 kubernetes Unsupported
SUSE Linux Enterprise Desktop 15 SP1 go1.14 Not affected
SUSE Linux Enterprise Desktop 15 SP2 go1.14 Not affected
SUSE Linux Enterprise High Performance Computing 12 docker Already fixed
SUSE Linux Enterprise High Performance Computing 12 kubernetes Not affected
SUSE Linux Enterprise High Performance Computing 15 docker Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 docker Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 go1.14 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 kubernetes Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 docker Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 go1.14 Not affected
SUSE Linux Enterprise Module for Containers 12 docker Already fixed
SUSE Linux Enterprise Module for Containers 15 docker Already fixed
SUSE Linux Enterprise Module for Containers 15 SP1 docker Already fixed
SUSE Linux Enterprise Module for Containers 15 SP1 kubernetes Already fixed
SUSE Linux Enterprise Module for Containers 15 SP2 docker Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP1 go1.14 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.14 Not affected
SUSE Linux Enterprise Module for Public Cloud 12 kubernetes Not affected
SUSE Linux Enterprise Server 12 docker Already fixed
SUSE Linux Enterprise Server 12 kubernetes Not affected
SUSE Linux Enterprise Server 12 SP3 docker Already fixed
SUSE Linux Enterprise Server 12 SP3 kubernetes Not affected
SUSE Linux Enterprise Server 12 SP4 docker Already fixed
SUSE Linux Enterprise Server 12 SP4 kubernetes Not affected
SUSE Linux Enterprise Server 12 SP5 docker Already fixed
SUSE Linux Enterprise Server 12 SP5 kubernetes Not affected
SUSE Linux Enterprise Server 15 docker Already fixed
SUSE Linux Enterprise Server 15 SP1 docker Already fixed
SUSE Linux Enterprise Server 15 SP1 go1.14 Not affected
SUSE Linux Enterprise Server 15 SP1 kubernetes Already fixed
SUSE Linux Enterprise Server 15 SP2 docker Already fixed
SUSE Linux Enterprise Server 15 SP2 go1.14 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 docker Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 docker Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 docker Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 docker Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 15 docker Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 docker Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 go1.14 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 kubernetes Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 docker Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 go1.14 Not affected
SUSE Linux Enterprise Software Bootstrap Kit 12 go1.4 Not affected
SUSE Linux Enterprise Software Bootstrap Kit 12 go1.5 Not affected
SUSE Linux Enterprise Storage 6 docker Already fixed
SUSE Linux Enterprise Storage 6 go1.14 Not affected
SUSE Linux Enterprise Storage 6 kubernetes Already fixed
SUSE Linux Enterprise Storage 7 docker Already fixed
SUSE Linux Enterprise Storage 7 go1.14 Not affected
SUSE Manager Proxy 4.0 docker Already fixed
SUSE Manager Proxy 4.0 go1.14 Not affected
SUSE Manager Proxy 4.0 kubernetes Already fixed
SUSE Manager Proxy 4.1 docker Already fixed
SUSE Manager Proxy 4.1 go1.14 Not affected
SUSE Manager Retail Branch Server 4.0 docker Already fixed
SUSE Manager Retail Branch Server 4.0 go1.14 Not affected
SUSE Manager Retail Branch Server 4.0 kubernetes Already fixed
SUSE Manager Retail Branch Server 4.1 docker Already fixed
SUSE Manager Retail Branch Server 4.1 go1.14 Not affected
SUSE Manager Server 4.0 docker Already fixed
SUSE Manager Server 4.0 go1.14 Not affected
SUSE Manager Server 4.0 kubernetes Already fixed
SUSE Manager Server 4.1 docker Already fixed
SUSE Manager Server 4.1 go1.14 Not affected
SUSE OpenStack Cloud 6 docker Unsupported
SUSE OpenStack Cloud 6 LTSS docker Unsupported