Upstream information

CVE-2019-15522 at MITRE

Description

An issue was discovered in LINBIT csync2 through 2.0. csync_daemon_session in daemon.c neglects to force a failure of a hello command when the configuration requires use of SSL.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Adjacent Network
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1147137 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 12 SP3
  • csync2 >= 2.0+git.1368794815.cf835a7-3.9.5
Patchnames:
SUSE-SLE-HA-12-SP3-2021-1952
SUSE Linux Enterprise High Availability 12 SP4
  • csync2 >= 2.0+git.1368794815.cf835a7-3.9.5
Patchnames:
SUSE-SLE-HA-12-SP4-2021-1952
SUSE Linux Enterprise High Availability 12 SP5
  • csync2 >= 2.0+git.1368794815.cf835a7-3.9.5
Patchnames:
SUSE-SLE-HA-12-SP5-2021-1952
SUSE Linux Enterprise High Availability 15 SP1
  • csync2 >= 2.0+git.1461714863.10636a4-4.6.1
Patchnames:
SUSE-SLE-Product-HA-15-SP1-2021-1858
SUSE Linux Enterprise High Availability 15 SP2
  • csync2 >= 2.0+git.1461714863.10636a4-4.6.1
Patchnames:
SUSE-SLE-Product-HA-15-SP2-2021-1858
SUSE Linux Enterprise High Availability 15
  • csync2 >= 2.0+git.1461714863.10636a4-4.6.1
Patchnames:
SUSE-SLE-Product-HA-15-2021-1858
SUSE Linux Enterprise High Availability Extension 11 SP4
  • csync2 >= 1.34-0.13.7.1
Patchnames:
slehasp4-csync2-14763
openSUSE Leap 15.2
  • csync2 >= 2.0+git.1461714863.10636a4-lp152.5.3.1
Patchnames:
openSUSE-2021-853
openSUSE Tumbleweed
  • csync2 >= 2.0+git.1600444747.83b3644-1.3
Patchnames:
openSUSE Tumbleweed GA csync2-2.0+git.1600444747.83b3644-1.3


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications csync2 In progress
SUSE Linux Enterprise High Availability Extension 11 SP4 csync2 In progress
SUSE Linux Enterprise High Availability Extension 12 SP1 csync2 Affected
SUSE Linux Enterprise High Availability Extension 12 SP2 csync2 Unsupported
SUSE Linux Enterprise High Availability Extension 12 SP3 csync2 Released
SUSE Linux Enterprise High Availability Extension 12 SP4 csync2 Released
SUSE Linux Enterprise High Availability Extension 12 SP5 csync2 Released
SUSE Linux Enterprise High Availability Extension 15 csync2 Released
SUSE Linux Enterprise High Availability Extension 15 SP1 csync2 Released
SUSE Linux Enterprise High Availability Extension 15 SP2 csync2 Released
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON csync2 In progress
SUSE Linux Enterprise Server 12 SP2 LTSS SAP csync2 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP1 csync2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 csync2 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 csync2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 csync2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 csync2 Released