Upstream information

CVE-2019-14899 at MITRE

Description

A vulnerability was discovered in Linux, FreeBSD, OpenBSD, MacOS, iOS, and Android that allows a malicious access point, or an adjacent user, to determine if a connected user is using a VPN, make positive inferences about the websites they are visiting, and determine the correct sequence and acknowledgement numbers in use, allowing the bad actor to inject data into the TCP stream. This provides everything that is needed for an attacker to hijack active connections inside the VPN tunnel.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.9
Vector AV:A/AC:M/Au:S/C:P/I:P/A:P
Access Vector Adjacent Network
Access Complexity Medium
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.4 7.4
Vector CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Adjacent Network Adjacent Network
Access Complexity Low Low
Privileges Required Low Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1158670 [NEW], 1174814 [RESOLVED / WONTFIX]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 15 openvpn Not affected
SUSE Linux Enterprise Desktop 15 SP1 openvpn Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 openvpn Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openvpn Not affected
SUSE Linux Enterprise High Performance Computing 15 openvpn Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 openvpn Not affected
SUSE Linux Enterprise Module for Basesystem 15 openvpn Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 openvpn Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP4 openvpn Not affected
SUSE Linux Enterprise Server 12 SP5 openvpn Not affected
SUSE Linux Enterprise Server 15 openvpn Not affected
SUSE Linux Enterprise Server 15 SP1 openvpn Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openvpn Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openvpn Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openvpn Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openvpn Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openvpn Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openvpn Not affected
SUSE Linux Enterprise Storage 6 openvpn Not affected
SUSE Manager Proxy 4.0 openvpn Not affected
SUSE Manager Retail Branch Server 4.0 openvpn Not affected
SUSE Manager Server 4.0 openvpn Not affected