Upstream information

CVE-2019-14584 at MITRE

Description

Null pointer dereference in Tianocore EDK2 may allow an authenticated user to potentially enable escalation of privilege via local access.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 4
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1177789 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • qemu-ovmf-x86_64-debug >= 201911-7.8.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-3884
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • ovmf >= 2017+git1510945757.b2662641d5-5.38.1
  • ovmf-tools >= 2017+git1510945757.b2662641d5-5.38.1
  • qemu-ovmf-x86_64 >= 2017+git1510945757.b2662641d5-5.38.1
  • qemu-uefi-aarch64 >= 2017+git1510945757.b2662641d5-5.38.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2020-3885
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • ovmf >= 201911-7.8.1
  • ovmf-tools >= 201911-7.8.1
  • qemu-ovmf-x86_64 >= 201911-7.8.1
  • qemu-uefi-aarch64 >= 201911-7.8.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2020-3884
SUSE Linux Enterprise Server 12 SP2-BCL
  • ovmf >= 2015+git1462940744.321151f-19.23.1
  • ovmf-tools >= 2015+git1462940744.321151f-19.23.1
  • qemu-ovmf-x86_64 >= 2015+git1462940744.321151f-19.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2021-2117
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • ovmf >= 2017+git1510945757.b2662641d5-3.32.1
  • ovmf-tools >= 2017+git1510945757.b2662641d5-3.32.1
  • qemu-ovmf-x86_64 >= 2017+git1510945757.b2662641d5-3.32.1
  • qemu-uefi-aarch64 >= 2017+git1510945757.b2662641d5-3.32.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-3883
openSUSE Leap 15.1
  • ovmf >= 2017+git1510945757.b2662641d5-lp151.11.12.1
  • ovmf-tools >= 2017+git1510945757.b2662641d5-lp151.11.12.1
  • qemu-ovmf-ia32 >= 2017+git1510945757.b2662641d5-lp151.11.12.1
  • qemu-ovmf-x86_64 >= 2017+git1510945757.b2662641d5-lp151.11.12.1
  • qemu-ovmf-x86_64-debug >= 2017+git1510945757.b2662641d5-lp151.11.12.1
Patchnames:
openSUSE-2020-2336
openSUSE Leap 15.2
  • ovmf >= 201911-lp152.6.8.1
  • ovmf-tools >= 201911-lp152.6.8.1
  • qemu-ovmf-ia32 >= 201911-lp152.6.8.1
  • qemu-ovmf-x86_64 >= 201911-lp152.6.8.1
  • qemu-ovmf-x86_64-debug >= 201911-lp152.6.8.1
  • shim >= 15.4-lp152.4.8.1
  • shim-debuginfo >= 15.4-lp152.4.8.1
  • shim-debugsource >= 15.4-lp152.4.8.1
Patchnames:
openSUSE-2020-2314
openSUSE-2021-598


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 ovmf Released
HPE Helion OpenStack 8 shim Affected
SUSE CaaS Platform 4.0 shim In progress
SUSE Enterprise Storage 5 ovmf Released
SUSE Enterprise Storage 5 shim Unsupported
SUSE Enterprise Storage 6 shim In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 ovmf Released
SUSE Linux Enterprise High Performance Computing 12 SP5 shim Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS ovmf Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS shim Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS shim In progress
SUSE Linux Enterprise Module for Basesystem 15 SP1 shim Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 shim In progress
SUSE Linux Enterprise Module for Server Applications 15 SP1 ovmf Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 ovmf Released
SUSE Linux Enterprise Point of Service Image Server 12 ovmf Unsupported
SUSE Linux Enterprise Point of Service Image Server 12 shim Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS shim Affected
SUSE Linux Enterprise Server 12 SP2 BCL ovmf In progress
SUSE Linux Enterprise Server 12 SP2 BCL shim Affected
SUSE Linux Enterprise Server 12 SP2 ESPOS ovmf Unsupported
SUSE Linux Enterprise Server 12 SP2 ESPOS shim Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS ovmf In progress
SUSE Linux Enterprise Server 12 SP2 LTSS shim Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON ovmf In progress
SUSE Linux Enterprise Server 12 SP2 LTSS SAP ovmf In progress
SUSE Linux Enterprise Server 12 SP3 BCL ovmf Released
SUSE Linux Enterprise Server 12 SP3 BCL shim Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS ovmf Released
SUSE Linux Enterprise Server 12 SP3 ESPOS shim Affected
SUSE Linux Enterprise Server 12 SP3 LTSS ovmf Released
SUSE Linux Enterprise Server 12 SP3 LTSS shim Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS ovmf Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS shim Affected
SUSE Linux Enterprise Server 12 SP4 LTSS ovmf Affected
SUSE Linux Enterprise Server 12 SP4 LTSS shim Affected
SUSE Linux Enterprise Server 12 SP5 ovmf Released
SUSE Linux Enterprise Server 12 SP5 shim Affected
SUSE Linux Enterprise Server 15 LTSS ovmf Affected
SUSE Linux Enterprise Server 15 LTSS shim Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux shim In progress
SUSE Linux Enterprise Server 15 SP1 LTSS shim In progress
SUSE Linux Enterprise Server ESPOS 15 ovmf Affected
SUSE Linux Enterprise Server ESPOS 15 shim Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ovmf Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 shim Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ovmf Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 shim Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ovmf Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 shim Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ovmf Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 shim Affected
SUSE Linux Enterprise Server for SAP Applications 15 ovmf Affected
SUSE Linux Enterprise Server for SAP Applications 15 shim Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 shim In progress
SUSE Manager Proxy 4.0 shim In progress
SUSE Manager Retail Branch Server 4.0 shim In progress
SUSE Manager Server 4.0 shim In progress
SUSE OpenStack Cloud 7 ovmf In progress
SUSE OpenStack Cloud 7 shim Affected
SUSE OpenStack Cloud 8 ovmf Released
SUSE OpenStack Cloud 8 shim Affected
SUSE OpenStack Cloud 9 ovmf Affected
SUSE OpenStack Cloud 9 shim Affected
SUSE OpenStack Cloud Crowbar 8 ovmf Released
SUSE OpenStack Cloud Crowbar 8 shim Affected
SUSE OpenStack Cloud Crowbar 9 ovmf Affected
SUSE OpenStack Cloud Crowbar 9 shim Affected