Upstream information

CVE-2019-14498 at MITRE

Description

A divide-by-zero error exists in the Control function of demux/caf.c in VideoLAN VLC media player 3.0.7.1. As a result, an FPE can be triggered via a crafted CAF file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1146428 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP1
  • libvlc5 >= 3.0.9.2-bp151.5.6.1
  • libvlccore9 >= 3.0.9.2-bp151.5.6.1
  • vlc >= 3.0.9.2-bp151.5.6.1
  • vlc-codec-gstreamer >= 3.0.9.2-bp151.5.6.1
  • vlc-devel >= 3.0.9.2-bp151.5.6.1
  • vlc-jack >= 3.0.9.2-bp151.5.6.1
  • vlc-lang >= 3.0.9.2-bp151.5.6.1
  • vlc-noX >= 3.0.9.2-bp151.5.6.1
  • vlc-opencv >= 3.0.9.2-bp151.5.6.1
  • vlc-qt >= 3.0.9.2-bp151.5.6.1
  • vlc-vdpau >= 3.0.9.2-bp151.5.6.1
Patchnames:
openSUSE-2020-562
openSUSE Leap 15.1
  • libvlc5 >= 3.0.9.2-lp151.6.6.1
  • libvlccore9 >= 3.0.9.2-lp151.6.6.1
  • vlc >= 3.0.9.2-lp151.6.6.1
  • vlc-codec-gstreamer >= 3.0.9.2-lp151.6.6.1
  • vlc-devel >= 3.0.9.2-lp151.6.6.1
  • vlc-jack >= 3.0.9.2-lp151.6.6.1
  • vlc-lang >= 3.0.9.2-lp151.6.6.1
  • vlc-noX >= 3.0.9.2-lp151.6.6.1
  • vlc-opencv >= 3.0.9.2-lp151.6.6.1
  • vlc-qt >= 3.0.9.2-lp151.6.6.1
  • vlc-vdpau >= 3.0.9.2-lp151.6.6.1
Patchnames:
openSUSE-2020-545
openSUSE Leap 15.2
  • libvlc5 >= 3.0.10-lp152.1.3
  • libvlccore9 >= 3.0.10-lp152.1.3
  • vlc >= 3.0.10-lp152.1.3
  • vlc-codec-gstreamer >= 3.0.10-lp152.1.3
  • vlc-lang >= 3.0.10-lp152.1.3
  • vlc-noX >= 3.0.10-lp152.1.3
  • vlc-qt >= 3.0.10-lp152.1.3
  • vlc-vdpau >= 3.0.10-lp152.1.3
Patchnames:
openSUSE Leap 15.2 GA libvlc5-3.0.10-lp152.1.1
openSUSE Leap 15.3
  • libvlc5 >= 3.0.13-bp153.1.1
  • libvlccore9 >= 3.0.13-bp153.1.1
  • vlc >= 3.0.13-bp153.1.1
  • vlc-codec-gstreamer >= 3.0.13-bp153.1.1
  • vlc-lang >= 3.0.13-bp153.1.1
  • vlc-noX >= 3.0.13-bp153.1.1
  • vlc-qt >= 3.0.13-bp153.1.1
  • vlc-vdpau >= 3.0.13-bp153.1.1
Patchnames:
openSUSE Leap 15.3 GA libvlc5-3.0.13-bp153.1.1
openSUSE Leap 15.4
  • libvlc5 >= 3.0.17.3-bp154.1.49
  • libvlccore9 >= 3.0.17.3-bp154.1.49
  • vlc >= 3.0.17.3-bp154.1.49
  • vlc-codec-gstreamer >= 3.0.17.3-bp154.1.49
  • vlc-lang >= 3.0.17.3-bp154.1.49
  • vlc-noX >= 3.0.17.3-bp154.1.49
  • vlc-qt >= 3.0.17.3-bp154.1.49
  • vlc-vdpau >= 3.0.17.3-bp154.1.49
Patchnames:
openSUSE Leap 15.4 GA libvlc5-3.0.17.3-bp154.1.49
openSUSE Tumbleweed
  • libvlc5 >= 3.0.16-1.5
  • libvlccore9 >= 3.0.16-1.5
  • vlc >= 3.0.16-1.5
  • vlc-codec-gstreamer >= 3.0.16-1.5
  • vlc-devel >= 3.0.16-1.5
  • vlc-jack >= 3.0.16-1.5
  • vlc-lang >= 3.0.16-1.5
  • vlc-noX >= 3.0.16-1.5
  • vlc-opencv >= 3.0.16-1.5
  • vlc-qt >= 3.0.16-1.5
  • vlc-vdpau >= 3.0.16-1.5
Patchnames:
openSUSE Tumbleweed GA libvlc5-3.0.16-1.5


SUSE Timeline for this CVE

CVE page created: Tue Aug 20 07:34:22 2019
CVE page last modified: Wed Oct 26 22:03:17 2022