Upstream information

CVE-2019-14491 at MITRE

Description

An issue was discovered in OpenCV before 3.4.7 and 4.x before 4.1.1. There is an out of bounds read in the function cv::predictOrdered<cv::HaarEvaluator> in modules/objdetect/src/cascadedetect.hpp, which leads to denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.2 5.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact Low None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1144348 [RESOLVED / FIXED], 1144352 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Package Hub 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • python2-opencv >= 3.3.1-6.6.1
  • python3-opencv >= 3.3.1-6.6.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-1875
SUSE Enterprise Storage 7
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Package Hub 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • python2-opencv >= 3.3.1-6.6.1
  • python3-opencv >= 3.3.1-6.6.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2020-1875
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libopencv3_3 >= 3.3.1-6.6.1
  • opencv >= 3.3.1-6.6.1
  • opencv-devel >= 3.3.1-6.6.1
  • python2-opencv >= 3.3.1-6.6.1
  • python3-opencv >= 3.3.1-6.6.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-1875
SUSE-SLE-Product-WE-15-SP1-2019-3192
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • libopencv3_3 >= 3.3.1-6.6.1
  • opencv >= 3.3.1-6.6.1
  • opencv-devel >= 3.3.1-6.6.1
  • python2-opencv >= 3.3.1-6.6.1
  • python3-opencv >= 3.3.1-6.6.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP2 GA libopencv3_3-3.3.1-6.6.1
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2020-1875
SUSE-SLE-Product-WE-15-SP2-2020-1875
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Workstation Extension 15 SP3
  • libopencv3_3 >= 3.3.1-6.6.1
  • opencv >= 3.3.1-6.6.1
  • opencv-devel >= 3.3.1-6.6.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP3 GA libopencv3_3-3.3.1-6.6.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Linux Enterprise Workstation Extension 15 SP4
  • libopencv3_4 >= 3.4.16-150400.1.9
  • libopencv405 >= 4.5.5-150400.1.28
  • libopencv_aruco405 >= 4.5.5-150400.1.28
  • libopencv_face405 >= 4.5.5-150400.1.28
  • libopencv_highgui405 >= 4.5.5-150400.1.28
  • libopencv_imgcodecs405 >= 4.5.5-150400.1.28
  • libopencv_objdetect405 >= 4.5.5-150400.1.28
  • libopencv_superres405 >= 4.5.5-150400.1.28
  • libopencv_videoio405 >= 4.5.5-150400.1.28
  • libopencv_videostab405 >= 4.5.5-150400.1.28
  • libopencv_ximgproc405 >= 4.5.5-150400.1.28
  • opencv >= 4.5.5-150400.1.28
  • opencv-devel >= 4.5.5-150400.1.28
  • opencv3 >= 3.4.16-150400.1.9
  • opencv3-devel >= 3.4.16-150400.1.9
  • opencv4-cascades-data >= 4.5.5-150400.1.28
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP4 GA libopencv3_4-3.4.16-150400.1.9
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libopencv3_3 >= 3.3.1-6.6.1
  • opencv >= 3.3.1-6.6.1
  • opencv-devel >= 3.3.1-6.6.1
  • python2-opencv >= 3.3.1-6.6.1
  • python3-opencv >= 3.3.1-6.6.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-3192
SUSE-SLE-Product-WE-15-2019-3192
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Package Hub 15
  • python2-opencv >= 3.3.1-6.6.1
  • python3-opencv >= 3.3.1-6.6.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-3192
SUSE Linux Enterprise Workstation Extension 15 SP1
  • libopencv3_3 >= 3.3.1-6.6.1
  • opencv >= 3.3.1-6.6.1
  • opencv-devel >= 3.3.1-6.6.1
Patchnames:
SUSE-SLE-Product-WE-15-SP1-2019-3192
SUSE Linux Enterprise Workstation Extension 15 SP2
  • libopencv3_3 >= 3.3.1-6.6.1
  • opencv >= 3.3.1-6.6.1
  • opencv-devel >= 3.3.1-6.6.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP2 GA libopencv3_3-3.3.1-6.6.1
SUSE-SLE-Product-WE-15-SP2-2020-1875
SUSE Linux Enterprise Workstation Extension 15
  • libopencv3_3 >= 3.3.1-6.6.1
  • opencv >= 3.3.1-6.6.1
  • opencv-devel >= 3.3.1-6.6.1
Patchnames:
SUSE-SLE-Product-WE-15-2019-3192
openSUSE Leap 15.1
  • libopencv3_3 >= 3.3.1-lp151.6.3.1
  • opencv >= 3.3.1-lp151.6.3.1
  • opencv-devel >= 3.3.1-lp151.6.3.1
  • opencv-doc >= 3.3.1-lp151.6.3.1
  • python2-opencv >= 3.3.1-lp151.6.3.1
  • python3-opencv >= 3.3.1-lp151.6.3.1
Patchnames:
openSUSE-2019-2671
openSUSE Leap 15.2
  • libopencv3_3 >= 3.3.1-lp152.7.9
  • opencv >= 3.3.1-lp152.7.9
  • python3-opencv >= 3.3.1-lp152.7.9
Patchnames:
openSUSE Leap 15.2 GA libopencv3_3-3.3.1-lp152.7.10
openSUSE Leap 15.3
  • libopencv3_3 >= 3.3.1-6.6.1
Patchnames:
openSUSE Leap 15.3 GA libopencv3_3-3.3.1-6.6.1
openSUSE Leap 15.4
  • libopencv405 >= 4.5.5-150400.1.28
  • libopencv_imgcodecs405 >= 4.5.5-150400.1.28
  • libopencv_ximgproc405 >= 4.5.5-150400.1.28
Patchnames:
openSUSE Leap 15.4 GA libopencv405-4.5.5-150400.1.28
openSUSE Tumbleweed
  • libopencv3_4 >= 3.4.10-3.3
  • libopencv4_5 >= 4.5.2-2.2
  • libopencv_aruco4_5 >= 4.5.2-2.2
  • libopencv_face4_5 >= 4.5.2-2.2
  • libopencv_highgui4_5 >= 4.5.2-2.2
  • libopencv_imgcodecs4_5 >= 4.5.2-2.2
  • libopencv_objdetect4_5 >= 4.5.2-2.2
  • libopencv_superres4_5 >= 4.5.2-2.2
  • libopencv_videoio4_5 >= 4.5.2-2.2
  • libopencv_videostab4_5 >= 4.5.2-2.2
  • libopencv_ximgproc4_5 >= 4.5.2-2.2
  • opencv >= 4.5.2-2.2
  • opencv-devel >= 4.5.2-2.2
  • opencv-doc >= 4.5.2-2.2
  • opencv3 >= 3.4.10-3.3
  • opencv3-devel >= 3.4.10-3.3
  • opencv3-doc >= 3.4.10-3.3
  • opencv4-cascades-data >= 4.5.2-2.2
  • python3-opencv >= 4.5.2-2.2
  • python3-opencv3 >= 3.4.10-3.3
Patchnames:
openSUSE Tumbleweed GA libopencv3_4-3.4.10-3.3
openSUSE Tumbleweed GA libopencv4_5-4.5.2-2.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Enterprise Storage 6 opencv Released
SUSE Enterprise Storage 7 opencv Released
SUSE Enterprise Storage 7.1 opencv Affected
SUSE Linux Enterprise Desktop 15 opencv Released
SUSE Linux Enterprise Desktop 15 SP1 opencv Released
SUSE Linux Enterprise Desktop 15 SP2 opencv Released
SUSE Linux Enterprise Desktop 15 SP3 opencv Affected
SUSE Linux Enterprise Desktop 15 SP4 opencv Already fixed
SUSE Linux Enterprise Desktop 15 SP4 opencv3 Already fixed
SUSE Linux Enterprise High Performance Computing 15 opencv Released
SUSE Linux Enterprise High Performance Computing 15 SP1 opencv Released
SUSE Linux Enterprise High Performance Computing 15 SP2 opencv Released
SUSE Linux Enterprise High Performance Computing 15 SP3 opencv Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 opencv Already fixed
SUSE Linux Enterprise Module for Package Hub 15 opencv Released
SUSE Linux Enterprise Module for Package Hub 15 SP1 opencv Released
SUSE Linux Enterprise Module for Package Hub 15 SP2 opencv Released
SUSE Linux Enterprise Module for Package Hub 15 SP3 opencv Affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 opencv Already fixed
SUSE Linux Enterprise Server 15 opencv Released
SUSE Linux Enterprise Server 15 SP1 opencv Released
SUSE Linux Enterprise Server 15 SP2 opencv Released
SUSE Linux Enterprise Server 15 SP3 opencv Affected
SUSE Linux Enterprise Server 15 SP4 opencv Already fixed
SUSE Linux Enterprise Server 15 SP4 opencv3 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 opencv Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 opencv Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 opencv Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 opencv Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 opencv Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 opencv3 Already fixed
SUSE Linux Enterprise Workstation Extension 15 opencv Released
SUSE Linux Enterprise Workstation Extension 15 SP1 opencv Released
SUSE Linux Enterprise Workstation Extension 15 SP2 opencv Released
SUSE Linux Enterprise Workstation Extension 15 SP3 opencv Affected
SUSE Linux Enterprise Workstation Extension 15 SP4 opencv Already fixed
SUSE Linux Enterprise Workstation Extension 15 SP4 opencv3 Already fixed
SUSE Manager Proxy 4.0 opencv Released
SUSE Manager Proxy 4.1 opencv Released
SUSE Manager Proxy 4.2 opencv Affected
SUSE Manager Proxy 4.3 opencv Already fixed
SUSE Manager Retail Branch Server 4.0 opencv Released
SUSE Manager Retail Branch Server 4.1 opencv Released
SUSE Manager Retail Branch Server 4.2 opencv Affected
SUSE Manager Retail Branch Server 4.3 opencv Already fixed
SUSE Manager Server 4.0 opencv Released
SUSE Manager Server 4.1 opencv Released
SUSE Manager Server 4.2 opencv Affected
SUSE Manager Server 4.3 opencv Already fixed
SUSE Package Hub 15 SP1 opencv Released
SUSE Package Hub 15 SP2 opencv Released


SUSE Timeline for this CVE

CVE page created: Thu Aug 1 20:36:26 2019
CVE page last modified: Tue Nov 29 14:43:31 2022