Upstream information

CVE-2019-13917 at MITRE

Description

Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1142207 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP1
  • exim >= 4.94.2-bp151.2.4.1
  • eximon >= 4.94.2-bp151.2.4.1
  • eximstats-html >= 4.94.2-bp151.2.4.1
  • libspf2-2 >= 1.2.10-bp151.4.1
  • libspf2-devel >= 1.2.10-bp151.4.1
  • libspf2-tools >= 1.2.10-bp151.4.1
Patchnames:
openSUSE-2021-753
openSUSE Leap 15.0
  • exim >= 4.88-lp150.3.6.1
  • eximon >= 4.88-lp150.3.6.1
  • eximstats-html >= 4.88-lp150.3.6.1
Patchnames:
openSUSE-2019-1812
openSUSE Leap 15.1
  • exim >= 4.88-lp151.4.6.1
  • eximon >= 4.88-lp151.4.6.1
  • eximstats-html >= 4.88-lp151.4.6.1
Patchnames:
openSUSE-2019-1812
openSUSE Tumbleweed
  • exim >= 4.94.2-4.2
  • eximon >= 4.94.2-4.2
  • eximstats-html >= 4.94.2-4.2
Patchnames:
openSUSE Tumbleweed GA exim-4.94.2-4.2