Upstream information

CVE-2019-13638 at MITRE

Description

GNU patch through 2.7.6 is vulnerable to OS shell command injection that can be exploited by opening a crafted patch file that contains an ed style diff payload with shell metacharacters. The ed editor does not need to be present on the vulnerable system. This is different from CVE-2018-1000156.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.3
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1088420 [RESOLVED / FIXED], 1142513 [RESOLVED / DUPLICATE], 1146398 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 7
SUSE Liberty Linux 7 LTSS
  • patch >= 2.7.1-12.el7_7
Patchnames:
RHSA-2019:2964
SUSE Liberty Linux 8
  • patch >= 2.7.6-9.el8_0
Patchnames:
RHSA-2019:2798


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 patch Already fixed
SUSE Linux Enterprise Desktop 15 SP5 patch Already fixed
SUSE Linux Enterprise Desktop 15 SP6 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP5 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP6 patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP5 patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP6 patch Already fixed
SUSE Linux Enterprise Server 12 SP5 patch Already fixed
SUSE Linux Enterprise Server 15 SP5 patch Already fixed
SUSE Linux Enterprise Server 15 SP6 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP6 patch Already fixed
SUSE Manager Proxy 4.3 patch Already fixed
SUSE Manager Retail Branch Server 4.3 patch Already fixed
SUSE Manager Server 4.3 patch Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-SP1-CHOST-BYOS-GCE patch Already fixed
SUSE Linux Enterprise Desktop 15 SP4 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 patch Already fixed
SUSE Linux Enterprise Server 15 SP2 patch Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS patch Already fixed
SUSE Linux Enterprise Server 15 SP3 patch Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS patch Already fixed
SUSE Linux Enterprise Server 15 SP4 patch Already fixed
SUSE Linux Enterprise Server 15 SP4-LTSS patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 patch Already fixed
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 patch Already fixed
SLES for SAP Applications 11 SP3 patch Already fixed
SUSE CaaS Platform 4.0 patch Already fixed
SUSE Enterprise Storage 6 patch Already fixed
SUSE Enterprise Storage 7 patch Already fixed
SUSE Linux Enterprise Desktop 12 patch Already fixed
SUSE Linux Enterprise Desktop 12 SP1 patch Already fixed
SUSE Linux Enterprise Desktop 12 SP2 patch Already fixed
SUSE Linux Enterprise Desktop 12 SP3 patch Already fixed
SUSE Linux Enterprise Desktop 12 SP4 patch Already fixed
SUSE Linux Enterprise Desktop 15 patch Already fixed
SUSE Linux Enterprise Desktop 15 SP1 patch Already fixed
SUSE Linux Enterprise Desktop 15 SP2 patch Already fixed
SUSE Linux Enterprise Desktop 15 SP3 patch Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP4 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15-LTSS patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP1 patch Already fixed
SUSE Linux Enterprise Module for Development Tools 15 patch Already fixed
SUSE Linux Enterprise Real Time 15 SP2 patch Already fixed
SUSE Linux Enterprise Real Time 15 SP3 patch Already fixed
SUSE Linux Enterprise Real Time 15 SP4 patch Already fixed
SUSE Linux Enterprise Server 11 SP3 patch Already fixed
SUSE Linux Enterprise Server 11 SP3 LTSS patch Already fixed
SUSE Linux Enterprise Server 11 SP3-LTSS patch Already fixed
SUSE Linux Enterprise Server 11 SP4 patch Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS patch Already fixed
SUSE Linux Enterprise Server 11 SP4-LTSS patch Already fixed
SUSE Linux Enterprise Server 12 patch Already fixed
SUSE Linux Enterprise Server 12 SP1 patch Already fixed
SUSE Linux Enterprise Server 12 SP1-LTSS patch Already fixed
SUSE Linux Enterprise Server 12 SP2 patch Already fixed
SUSE Linux Enterprise Server 12 SP2-BCL patch Already fixed
SUSE Linux Enterprise Server 12 SP2-ESPOS patch Already fixed
SUSE Linux Enterprise Server 12 SP2-LTSS patch Already fixed
SUSE Linux Enterprise Server 12 SP3 patch Already fixed
SUSE Linux Enterprise Server 12 SP3-BCL patch Already fixed
SUSE Linux Enterprise Server 12 SP3-ESPOS patch Already fixed
SUSE Linux Enterprise Server 12 SP3-LTSS patch Already fixed
SUSE Linux Enterprise Server 12 SP4 patch Already fixed
SUSE Linux Enterprise Server 12 SP4-ESPOS patch Already fixed
SUSE Linux Enterprise Server 12 SP4-LTSS patch Already fixed
SUSE Linux Enterprise Server 12-LTSS patch Already fixed
SUSE Linux Enterprise Server 15 patch Already fixed
SUSE Linux Enterprise Server 15 SP1 patch Already fixed
SUSE Linux Enterprise Server 15 SP1-BCL patch Already fixed
SUSE Linux Enterprise Server 15 SP1-LTSS patch Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL patch Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL patch Already fixed
SUSE Linux Enterprise Server 15-LTSS patch Already fixed
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP1 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 patch Already fixed
SUSE Manager Proxy 4.0 patch Already fixed
SUSE Manager Proxy 4.1 patch Already fixed
SUSE Manager Proxy 4.2 patch Already fixed
SUSE Manager Retail Branch Server 4.0 patch Already fixed
SUSE Manager Retail Branch Server 4.1 patch Already fixed
SUSE Manager Retail Branch Server 4.2 patch Already fixed
SUSE Manager Server 4.0 patch Already fixed
SUSE Manager Server 4.1 patch Already fixed
SUSE Manager Server 4.2 patch Already fixed
SUSE OpenStack Cloud 7 patch Already fixed
SUSE OpenStack Cloud 8 patch Already fixed
SUSE OpenStack Cloud 9 patch Already fixed
SUSE OpenStack Cloud Crowbar 8 patch Already fixed
SUSE OpenStack Cloud Crowbar 9 patch Already fixed
Container Status
bci/bci-sle15-kernel-module-devel
bci/bci-sle15-kernel-module-devel:15.6
suse/manager/5.0/x86_64/server
patchAlready fixed


SUSE Timeline for this CVE

CVE page created: Tue Jul 23 14:15:44 2019
CVE page last modified: Wed Jun 12 15:30:30 2024