Upstream information

CVE-2019-13313 at MITRE

Description

libosinfo 1.5.0 allows local users to discover credentials by listing a process, because credentials are passed to osinfo-install-script via the command line.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 2.8
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1140749 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libosinfo >= 1.7.1-1.52
  • libosinfo-1_0-0 >= 1.7.1-1.52
  • libosinfo-lang >= 1.7.1-1.52
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libosinfo-1.7.1-1.52
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libosinfo >= 1.7.1-1.52
  • libosinfo-1_0-0 >= 1.7.1-1.52
  • libosinfo-lang >= 1.7.1-1.52
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libosinfo-1.7.1-1.52
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libosinfo >= 1.7.1-150400.8.6
  • libosinfo-1_0-0 >= 1.7.1-150400.8.6
  • libosinfo-lang >= 1.7.1-150400.8.6
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libosinfo-1.7.1-150400.8.6
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libosinfo >= 1.7.1-1.52
  • libosinfo-1_0-0 >= 1.7.1-1.52
  • libosinfo-devel >= 1.7.1-1.52
  • libosinfo-lang >= 1.7.1-1.52
  • typelib-1_0-Libosinfo-1_0 >= 1.7.1-1.52
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libosinfo-1.7.1-1.52
SUSE Linux Enterprise Module for Server Applications 15 SP2 GA libosinfo-devel-1.7.1-1.52
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libosinfo >= 1.7.1-1.52
  • libosinfo-1_0-0 >= 1.7.1-1.52
  • libosinfo-devel >= 1.7.1-1.52
  • libosinfo-lang >= 1.7.1-1.52
  • typelib-1_0-Libosinfo-1_0 >= 1.7.1-1.52
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libosinfo-1.7.1-1.52
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA libosinfo-devel-1.7.1-1.52
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libosinfo >= 1.7.1-150400.8.6
  • libosinfo-1_0-0 >= 1.7.1-150400.8.6
  • libosinfo-devel >= 1.7.1-150400.8.6
  • libosinfo-lang >= 1.7.1-150400.8.6
  • typelib-1_0-Libosinfo-1_0 >= 1.7.1-150400.8.6
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libosinfo-1.7.1-150400.8.6
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA libosinfo-devel-1.7.1-150400.8.6
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • libosinfo-devel >= 1.7.1-1.52
  • typelib-1_0-Libosinfo-1_0 >= 1.7.1-1.52
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP2 GA libosinfo-devel-1.7.1-1.52
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • libosinfo-devel >= 1.7.1-1.52
  • typelib-1_0-Libosinfo-1_0 >= 1.7.1-1.52
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA libosinfo-devel-1.7.1-1.52
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • libosinfo-devel >= 1.7.1-150400.8.6
  • typelib-1_0-Libosinfo-1_0 >= 1.7.1-150400.8.6
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA libosinfo-devel-1.7.1-150400.8.6
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libosinfo >= 0.2.12-13.3.1
  • libosinfo-1_0-0 >= 0.2.12-13.3.1
  • libosinfo-lang >= 0.2.12-13.3.1
  • typelib-1_0-Libosinfo-1_0 >= 0.2.12-13.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2273
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libosinfo >= 0.2.12-13.3.1
  • libosinfo-1_0-0 >= 0.2.12-13.3.1
  • libosinfo-lang >= 0.2.12-13.3.1
  • typelib-1_0-Libosinfo-1_0 >= 0.2.12-13.3.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2273
openSUSE Leap 15.2
  • libosinfo >= 1.7.1-lp152.1.6
  • libosinfo-1_0-0 >= 1.7.1-lp152.1.6
  • libosinfo-lang >= 1.7.1-lp152.1.6
  • typelib-1_0-Libosinfo-1_0 >= 1.7.1-lp152.1.6
Patchnames:
openSUSE Leap 15.2 GA libosinfo-1.7.1-lp152.1.1
openSUSE Leap 15.3
  • libosinfo >= 1.7.1-1.52
  • libosinfo-1_0-0 >= 1.7.1-1.52
  • libosinfo-lang >= 1.7.1-1.52
  • typelib-1_0-Libosinfo-1_0 >= 1.7.1-1.52
Patchnames:
openSUSE Leap 15.3 GA libosinfo-1.7.1-1.52
openSUSE Leap 15.4
  • libosinfo >= 1.7.1-150400.8.6
  • libosinfo-1_0-0 >= 1.7.1-150400.8.6
  • libosinfo-lang >= 1.7.1-150400.8.6
  • typelib-1_0-Libosinfo-1_0 >= 1.7.1-150400.8.6
Patchnames:
openSUSE Leap 15.4 GA libosinfo-1.7.1-150400.8.6
openSUSE Tumbleweed
  • libosinfo >= 1.9.0-1.5
  • libosinfo-1_0-0 >= 1.9.0-1.5
  • libosinfo-devel >= 1.9.0-1.5
  • libosinfo-lang >= 1.9.0-1.5
  • typelib-1_0-Libosinfo-1_0 >= 1.9.0-1.5
Patchnames:
openSUSE Tumbleweed GA libosinfo-1.9.0-1.5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.5 libosinfo Already fixed
SUSE Enterprise Storage 7 libosinfo Already fixed
SUSE Linux Enterprise Desktop 12 libosinfo Affected
SUSE Linux Enterprise Desktop 12 SP3 libosinfo Affected
SUSE Linux Enterprise Desktop 12 SP4 libosinfo Affected
SUSE Linux Enterprise Desktop 15 libosinfo Affected
SUSE Linux Enterprise Desktop 15 SP1 libosinfo Unsupported
SUSE Linux Enterprise Desktop 15 SP2 libosinfo Already fixed
SUSE Linux Enterprise Desktop 15 SP3 libosinfo Already fixed
SUSE Linux Enterprise Desktop 15 SP4 libosinfo Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP4 libosinfo Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libosinfo Affected
SUSE Linux Enterprise High Performance Computing 15 libosinfo Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libosinfo Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS libosinfo Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 libosinfo Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS libosinfo Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS libosinfo Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 libosinfo Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 libosinfo Already fixed
SUSE Linux Enterprise Micro 5.2 libosinfo Already fixed
SUSE Linux Enterprise Module for Basesystem 15 libosinfo Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 libosinfo Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 libosinfo Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 libosinfo Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 libosinfo Already fixed
SUSE Linux Enterprise Module for Server Applications 15 libosinfo Affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 libosinfo Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP2 libosinfo Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP3 libosinfo Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP4 libosinfo Already fixed
SUSE Linux Enterprise Real Time 15 SP2 libosinfo Already fixed
SUSE Linux Enterprise Server 12 libosinfo Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libosinfo Released
SUSE Linux Enterprise Server 12 SP2 BCL libosinfo Analysis
SUSE Linux Enterprise Server 12 SP2 LTSS libosinfo Unsupported
SUSE Linux Enterprise Server 12 SP3 libosinfo Affected
SUSE Linux Enterprise Server 12 SP3 BCL libosinfo Analysis
SUSE Linux Enterprise Server 12 SP4 libosinfo Affected
SUSE Linux Enterprise Server 12 SP4 LTSS libosinfo Affected
SUSE Linux Enterprise Server 12 SP5 libosinfo Affected
SUSE Linux Enterprise Server 15 libosinfo Affected
SUSE Linux Enterprise Server 15 SP1 libosinfo Unsupported
SUSE Linux Enterprise Server 15 SP2 libosinfo Already fixed
SUSE Linux Enterprise Server 15 SP2 LTSS libosinfo Already fixed
SUSE Linux Enterprise Server 15 SP3 libosinfo Already fixed
SUSE Linux Enterprise Server 15 SP4 libosinfo Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libosinfo Analysis
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libosinfo Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 libosinfo Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libosinfo Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libosinfo Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libosinfo Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libosinfo Affected
SUSE Linux Enterprise Server for SAP Applications 15 libosinfo Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libosinfo Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libosinfo Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libosinfo Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libosinfo Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP3 libosinfo Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libosinfo Affected
SUSE Linux Enterprise Storage 6 libosinfo Unsupported
SUSE Linux Enterprise Storage 7 libosinfo Already fixed
SUSE Linux Enterprise Storage 7.1 libosinfo Already fixed
SUSE Linux Enterprise Workstation Extension 12 libosinfo Affected
SUSE Manager Proxy 4.0 libosinfo Unsupported
SUSE Manager Proxy 4.1 libosinfo Already fixed
SUSE Manager Proxy 4.2 libosinfo Already fixed
SUSE Manager Proxy 4.3 libosinfo Already fixed
SUSE Manager Retail Branch Server 4.0 libosinfo Unsupported
SUSE Manager Retail Branch Server 4.1 libosinfo Already fixed
SUSE Manager Retail Branch Server 4.2 libosinfo Already fixed
SUSE Manager Retail Branch Server 4.3 libosinfo Already fixed
SUSE Manager Server 4.0 libosinfo Unsupported
SUSE Manager Server 4.1 libosinfo Already fixed
SUSE Manager Server 4.2 libosinfo Already fixed
SUSE Manager Server 4.3 libosinfo Already fixed