Upstream information

CVE-2019-12973 at MITRE

Description

In OpenJPEG 2.3.1, there is excessive iteration in the opj_t1_encode_cblks function of openjp2/t1.c. Remote attackers could leverage this vulnerability to cause a denial of service via a crafted bmp file. This issue is similar to CVE-2018-6616.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 3.3
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1140359 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2478
SUSE Enterprise Storage 4
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-Storage-4-2019-2478
SUSE Enterprise Storage 5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-Storage-5-2019-2478
SUSE Linux Enterprise Build System Kit 12 SP4
  • ghostscript-mini >= 9.27-23.28.1
  • ghostscript-mini-devel >= 9.27-23.28.1
Patchnames:
SUSE-SLE-BSK-12-SP4-2019-2478
SUSE Linux Enterprise Desktop 12 SP4
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2478
SUSE Linux Enterprise High Performance Computing 12 SP5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • ghostscript >= 9.27-3.21.1
  • ghostscript-devel >= 9.27-3.21.1
  • ghostscript-x11 >= 9.27-3.21.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2460
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • ghostscript >= 9.52-3.27.2
  • ghostscript-devel >= 9.52-3.27.2
  • ghostscript-x11 >= 9.52-3.27.2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • ghostscript >= 9.52-3.32.1
  • ghostscript-devel >= 9.52-3.32.1
  • ghostscript-x11 >= 9.52-3.32.1
SUSE Linux Enterprise Module for Basesystem 15
  • ghostscript >= 9.27-3.21.1
  • ghostscript-devel >= 9.27-3.21.1
  • ghostscript-x11 >= 9.27-3.21.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2460
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ghostscript-mini >= 9.27-3.21.1
  • ghostscript-mini-devel >= 9.27-3.21.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2460
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • ghostscript-mini >= 9.27-3.21.1
  • ghostscript-mini-devel >= 9.27-3.21.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2460
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2478
SUSE Linux Enterprise Server 12 SP1-LTSS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2478
SUSE Linux Enterprise Server 12 SP2-BCL
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2478
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2478
SUSE Linux Enterprise Server 12 SP2-LTSS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2478
SUSE Linux Enterprise Server 12 SP3-BCL
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2478
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2478
SUSE Linux Enterprise Server 12 SP3-LTSS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2478
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2478
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2478
SUSE Linux Enterprise Software Development Kit 12 SP4
  • ghostscript-devel >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2478
SUSE Linux Enterprise Software Development Kit 12 SP5
  • ghostscript-devel >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-2478
SUSE OpenStack Cloud 7
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2478
SUSE OpenStack Cloud 8
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2478
SUSE OpenStack Cloud Crowbar 8
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2478
openSUSE Leap 15.0
  • ghostscript >= 9.27-lp150.2.23.1
  • ghostscript-devel >= 9.27-lp150.2.23.1
  • ghostscript-mini >= 9.27-lp150.2.23.1
  • ghostscript-mini-devel >= 9.27-lp150.2.23.1
  • ghostscript-x11 >= 9.27-lp150.2.23.1
Patchnames:
openSUSE-2019-2222
openSUSE Leap 15.1
  • ghostscript >= 9.27-lp151.3.6.1
  • ghostscript-devel >= 9.27-lp151.3.6.1
  • ghostscript-mini >= 9.27-lp151.3.6.1
  • ghostscript-mini-devel >= 9.27-lp151.3.6.1
  • ghostscript-x11 >= 9.27-lp151.3.6.1
Patchnames:
openSUSE-2019-2223
openSUSE Tumbleweed
  • ghostscript >= 9.54.0-2.2
  • ghostscript-devel >= 9.54.0-2.2
  • ghostscript-x11 >= 9.54.0-2.2
  • libopenjp2-7 >= 2.4.0-1.4
  • libopenjp2-7-32bit >= 2.4.0-1.4
  • openjpeg2 >= 2.4.0-1.4
  • openjpeg2-devel >= 2.4.0-1.4
  • openjpeg2-devel-doc >= 2.4.0-1.4
Patchnames:
openSUSE Tumbleweed GA ghostscript-9.54.0-2.2
openSUSE Tumbleweed GA libopenjp2-7-2.4.0-1.4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 ghostscript In progress
SLED-10-SP3 ghostscript-library Not affected
SLED-10-SP4 ghostscript-library Not affected
SLES for SAP Applications ghostscript-library Not affected
SLES-10-SP3 ghostscript-library Not affected
SLES-10-SP4 ghostscript-library Not affected
SLES_LTSS-10-SP4 ghostscript-library Not affected
SUSE CaaS Platform 4.0 ghostscript Released
SUSE Enterprise Storage 6 ghostscript Released
SUSE Linux Enterprise Desktop 11 ghostscript-library Not affected
SUSE Linux Enterprise Desktop 11 SP1 ghostscript-library Not affected
SUSE Linux Enterprise Desktop 11 SP2 ghostscript-library Not affected
SUSE Linux Enterprise Desktop 11 SP3 ghostscript-library Not affected
SUSE Linux Enterprise Desktop 11 SP4 ghostscript-library Not affected
SUSE Linux Enterprise Desktop 12 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP1 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP2 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP2 openjpeg2 Affected
SUSE Linux Enterprise Desktop 12 SP3 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP3 openjpeg2 Affected
SUSE Linux Enterprise Desktop 12 SP4 ghostscript Released
SUSE Linux Enterprise Desktop 12 SP4 openjpeg2 Affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search ghostscript-library Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 ghostscript Affected
SUSE Linux Enterprise High Performance Computing 12 SP3 ghostscript Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 ghostscript Released
SUSE Linux Enterprise High Performance Computing 12 SP4 openjpeg2 Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 ghostscript In progress
SUSE Linux Enterprise High Performance Computing 15 LTSS ghostscript Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS ghostscript Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS openjpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS openjpeg2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 openjpeg2 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 openjpeg2 Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 openjpeg2 Affected
SUSE Linux Enterprise Module for Desktop Applications 15 openjpeg Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 openjpeg Unsupported
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 openjpeg Affected
SUSE Linux Enterprise Server 11 ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP1 ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP1 LTSS ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP2 ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP2 for VMware ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP3 ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP3 for VMware ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS ghostscript-library Not affected
SUSE Linux Enterprise Server 12 ghostscript Affected
SUSE Linux Enterprise Server 12 LTSS ghostscript Unsupported
SUSE Linux Enterprise Server 12 SP1 ghostscript Affected
SUSE Linux Enterprise Server 12 SP1 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP2 ghostscript Affected
SUSE Linux Enterprise Server 12 SP2 openjpeg2 Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP2 LTSS openjpeg2 Unsupported
SUSE Linux Enterprise Server 12 SP3 ghostscript Affected
SUSE Linux Enterprise Server 12 SP3 openjpeg2 Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS ghostscript In progress
SUSE Linux Enterprise Server 12 SP3 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP4 ghostscript Released
SUSE Linux Enterprise Server 12 SP4 openjpeg2 Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS ghostscript In progress
SUSE Linux Enterprise Server 12 SP4 LTSS ghostscript In progress
SUSE Linux Enterprise Server 12 SP5 ghostscript In progress
SUSE Linux Enterprise Server 15 ESPOS ghostscript Released
SUSE Linux Enterprise Server 15 LTSS ghostscript Released
SUSE Linux Enterprise Server 15 SP1 LTSS ghostscript Released
SUSE Linux Enterprise Server BCL 12 SP2 ghostscript Released
SUSE Linux Enterprise Server BCL 12 SP2 openjpeg2 Analysis
SUSE Linux Enterprise Server BCL 12 SP3 ghostscript In progress
SUSE Linux Enterprise Server BCL 12 SP3 openjpeg2 Analysis
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ghostscript Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openjpeg Analysis
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openjpeg2 Analysis
SUSE Linux Enterprise Server for SAP Applications 12 ghostscript Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openjpeg2 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openjpeg2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openjpeg2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ghostscript In progress
SUSE Linux Enterprise Server for SAP Applications 15 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ghostscript Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 ghostscript-library Not affected
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 11 ghostscript-library Not affected
SUSE Linux Enterprise Software Development Kit 11 SP1 ghostscript-library Not affected
SUSE Linux Enterprise Software Development Kit 11 SP2 ghostscript-library Not affected
SUSE Linux Enterprise Software Development Kit 11 SP3 ghostscript-library Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 ghostscript-library Not affected
SUSE Linux Enterprise Software Development Kit 12 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 ghostscript Released
SUSE Manager Proxy 4.0 ghostscript Released
SUSE Manager Retail Branch Server 4.0 ghostscript Released
SUSE Manager Server 4.0 ghostscript Released
SUSE OpenStack Cloud 8 ghostscript In progress
SUSE OpenStack Cloud 9 ghostscript In progress
SUSE OpenStack Cloud Crowbar 8 ghostscript In progress
SUSE OpenStack Cloud Crowbar 9 ghostscript In progress