Upstream information

CVE-2019-12874 at MITRE

Description

An issue was discovered in zlib_decompress_extra in modules/demux/mkv/util.cpp in VideoLAN VLC media player 3.x through 3.0.7. The Matroska demuxer, while parsing a malformed MKV file type, has a double free.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1138933 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • aom-tools >= 1.0.0-lp150.2.1
  • aom-tools-debuginfo >= 1.0.0-lp150.2.1
  • libaom >= 1.0.0-lp150.2.1
  • libaom-debugsource >= 1.0.0-lp150.2.1
  • libaom-devel >= 1.0.0-lp150.2.1
  • libaom-devel-doc >= 1.0.0-lp150.2.1
  • libaom0 >= 1.0.0-lp150.2.1
  • libaom0-debuginfo >= 1.0.0-lp150.2.1
  • libvlc5 >= 3.0.7.1-lp150.8.1
  • libvlc5-debuginfo >= 3.0.7.1-lp150.8.1
  • libvlccore9 >= 3.0.7.1-lp150.8.1
  • libvlccore9-debuginfo >= 3.0.7.1-lp150.8.1
  • vlc >= 3.0.7.1-lp150.8.1
  • vlc-codec-gstreamer >= 3.0.7.1-lp150.8.1
  • vlc-codec-gstreamer-debuginfo >= 3.0.7.1-lp150.8.1
  • vlc-debuginfo >= 3.0.7.1-lp150.8.1
  • vlc-debugsource >= 3.0.7.1-lp150.8.1
  • vlc-devel >= 3.0.7.1-lp150.8.1
  • vlc-jack >= 3.0.7.1-lp150.8.1
  • vlc-jack-debuginfo >= 3.0.7.1-lp150.8.1
  • vlc-lang >= 3.0.7.1-lp150.8.1
  • vlc-noX >= 3.0.7.1-lp150.8.1
  • vlc-noX-debuginfo >= 3.0.7.1-lp150.8.1
  • vlc-qt >= 3.0.7.1-lp150.8.1
  • vlc-qt-debuginfo >= 3.0.7.1-lp150.8.1
  • vlc-vdpau >= 3.0.7.1-lp150.8.1
  • vlc-vdpau-debuginfo >= 3.0.7.1-lp150.8.1
Patchnames:
openSUSE-2019-1909
openSUSE Leap 15.1
  • libvlc5 >= 3.0.7.1-lp151.6.3.1
  • libvlc5-debuginfo >= 3.0.7.1-lp151.6.3.1
  • libvlccore9 >= 3.0.7.1-lp151.6.3.1
  • libvlccore9-debuginfo >= 3.0.7.1-lp151.6.3.1
  • vlc >= 3.0.7.1-lp151.6.3.1
  • vlc-codec-gstreamer >= 3.0.7.1-lp151.6.3.1
  • vlc-codec-gstreamer-debuginfo >= 3.0.7.1-lp151.6.3.1
  • vlc-debuginfo >= 3.0.7.1-lp151.6.3.1
  • vlc-debugsource >= 3.0.7.1-lp151.6.3.1
  • vlc-devel >= 3.0.7.1-lp151.6.3.1
  • vlc-jack >= 3.0.7.1-lp151.6.3.1
  • vlc-jack-debuginfo >= 3.0.7.1-lp151.6.3.1
  • vlc-lang >= 3.0.7.1-lp151.6.3.1
  • vlc-noX >= 3.0.7.1-lp151.6.3.1
  • vlc-noX-debuginfo >= 3.0.7.1-lp151.6.3.1
  • vlc-qt >= 3.0.7.1-lp151.6.3.1
  • vlc-qt-debuginfo >= 3.0.7.1-lp151.6.3.1
  • vlc-vdpau >= 3.0.7.1-lp151.6.3.1
  • vlc-vdpau-debuginfo >= 3.0.7.1-lp151.6.3.1
Patchnames:
openSUSE-2019-1840