Upstream information

CVE-2019-12874 at MITRE

Description

An issue was discovered in zlib_decompress_extra in modules/demux/mkv/util.cpp in VideoLAN VLC media player 3.x through 3.0.7. The Matroska demuxer, while parsing a malformed MKV file type, has a double free.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1138933 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP1
  • libvlc5 >= 3.0.7.1-bp151.5.3.3
  • libvlccore9 >= 3.0.7.1-bp151.5.3.3
  • vlc >= 3.0.7.1-bp151.5.3.3
  • vlc-codec-gstreamer >= 3.0.7.1-bp151.5.3.3
  • vlc-devel >= 3.0.7.1-bp151.5.3.3
  • vlc-jack >= 3.0.7.1-bp151.5.3.3
  • vlc-lang >= 3.0.7.1-bp151.5.3.3
  • vlc-noX >= 3.0.7.1-bp151.5.3.3
  • vlc-qt >= 3.0.7.1-bp151.5.3.3
  • vlc-vdpau >= 3.0.7.1-bp151.5.3.3
Patchnames:
openSUSE-2019-1897
SUSE Package Hub 15
  • aom-tools >= 1.0.0-bp150.2.1
  • libaom-devel >= 1.0.0-bp150.2.1
  • libaom-devel-doc >= 1.0.0-bp150.2.1
  • libaom0 >= 1.0.0-bp150.2.1
  • libaom0-64bit >= 1.0.0-bp150.2.1
  • libvlc5 >= 3.0.7.1-bp150.2.6.1
  • libvlccore9 >= 3.0.7.1-bp150.2.6.1
  • vlc >= 3.0.7.1-bp150.2.6.1
  • vlc-codec-gstreamer >= 3.0.7.1-bp150.2.6.1
  • vlc-devel >= 3.0.7.1-bp150.2.6.1
  • vlc-jack >= 3.0.7.1-bp150.2.6.1
  • vlc-lang >= 3.0.7.1-bp150.2.6.1
  • vlc-noX >= 3.0.7.1-bp150.2.6.1
  • vlc-qt >= 3.0.7.1-bp150.2.6.1
  • vlc-vdpau >= 3.0.7.1-bp150.2.6.1
Patchnames:
openSUSE-2019-2015
openSUSE Leap 15.0
  • aom-tools >= 1.0.0-lp150.2.1
  • libaom-devel >= 1.0.0-lp150.2.1
  • libaom-devel-doc >= 1.0.0-lp150.2.1
  • libaom0 >= 1.0.0-lp150.2.1
  • libvlc5 >= 3.0.7.1-lp150.8.1
  • libvlccore9 >= 3.0.7.1-lp150.8.1
  • vlc >= 3.0.7.1-lp150.8.1
  • vlc-codec-gstreamer >= 3.0.7.1-lp150.8.1
  • vlc-devel >= 3.0.7.1-lp150.8.1
  • vlc-jack >= 3.0.7.1-lp150.8.1
  • vlc-lang >= 3.0.7.1-lp150.8.1
  • vlc-noX >= 3.0.7.1-lp150.8.1
  • vlc-qt >= 3.0.7.1-lp150.8.1
  • vlc-vdpau >= 3.0.7.1-lp150.8.1
Patchnames:
openSUSE-2019-1909
openSUSE Leap 15.1
  • libvlc5 >= 3.0.7.1-lp151.6.3.1
  • libvlccore9 >= 3.0.7.1-lp151.6.3.1
  • vlc >= 3.0.7.1-lp151.6.3.1
  • vlc-codec-gstreamer >= 3.0.7.1-lp151.6.3.1
  • vlc-devel >= 3.0.7.1-lp151.6.3.1
  • vlc-jack >= 3.0.7.1-lp151.6.3.1
  • vlc-lang >= 3.0.7.1-lp151.6.3.1
  • vlc-noX >= 3.0.7.1-lp151.6.3.1
  • vlc-qt >= 3.0.7.1-lp151.6.3.1
  • vlc-vdpau >= 3.0.7.1-lp151.6.3.1
Patchnames:
openSUSE-2019-1840
openSUSE Leap 15.2
  • libvlc5 >= 3.0.10-lp152.1.3
  • libvlccore9 >= 3.0.10-lp152.1.3
  • vlc >= 3.0.10-lp152.1.3
  • vlc-codec-gstreamer >= 3.0.10-lp152.1.3
  • vlc-lang >= 3.0.10-lp152.1.3
  • vlc-noX >= 3.0.10-lp152.1.3
  • vlc-qt >= 3.0.10-lp152.1.3
  • vlc-vdpau >= 3.0.10-lp152.1.3
Patchnames:
openSUSE Leap 15.2 GA libvlc5-3.0.10-lp152.1.1
openSUSE Leap 15.3
  • libvlc5 >= 3.0.13-bp153.1.1
  • libvlccore9 >= 3.0.13-bp153.1.1
  • vlc >= 3.0.13-bp153.1.1
  • vlc-codec-gstreamer >= 3.0.13-bp153.1.1
  • vlc-lang >= 3.0.13-bp153.1.1
  • vlc-noX >= 3.0.13-bp153.1.1
  • vlc-qt >= 3.0.13-bp153.1.1
  • vlc-vdpau >= 3.0.13-bp153.1.1
Patchnames:
openSUSE Leap 15.3 GA libvlc5-3.0.13-bp153.1.1
openSUSE Leap 15.4
  • libvlc5 >= 3.0.17.3-bp154.1.49
  • libvlccore9 >= 3.0.17.3-bp154.1.49
  • vlc >= 3.0.17.3-bp154.1.49
  • vlc-codec-gstreamer >= 3.0.17.3-bp154.1.49
  • vlc-lang >= 3.0.17.3-bp154.1.49
  • vlc-noX >= 3.0.17.3-bp154.1.49
  • vlc-qt >= 3.0.17.3-bp154.1.49
  • vlc-vdpau >= 3.0.17.3-bp154.1.49
Patchnames:
openSUSE Leap 15.4 GA libvlc5-3.0.17.3-bp154.1.49


SUSE Timeline for this CVE

CVE page created: Tue Jun 18 22:40:32 2019
CVE page last modified: Wed Oct 26 21:59:29 2022