Upstream information

CVE-2019-12779 at MITRE

Description

libqb before 1.0.5 allows local users to overwrite arbitrary files via a symlink attack, because it uses predictable filenames (under /dev/shm and /tmp) without O_EXCL.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.6
Vector AV:L/AC:L/Au:N/C:N/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.1 6.5
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact None None
Integrity Impact High High
Availability Impact High None
SUSE Bugzilla entry: 1137835 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 12 SP3
  • libdlm >= 4.0.7-3.3.2
  • libdlm3 >= 4.0.7-3.3.2
  • libqb >= 1.0.3+20171226.6d62b64-4.3.1
  • libqb0 >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE-SLE-HA-12-SP3-2019-1806
SUSE Linux Enterprise High Availability 12 SP4
  • libdlm >= 4.0.7-3.3.2
  • libdlm3 >= 4.0.7-3.3.2
  • libqb >= 1.0.3+20171226.6d62b64-4.3.1
  • libqb0 >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE-SLE-HA-12-SP4-2019-1806
SUSE Linux Enterprise High Availability 15
  • libqb >= 1.0.3+20171226.6d62b64-3.3.1
  • libqb-devel >= 1.0.3+20171226.6d62b64-3.3.1
  • libqb0 >= 1.0.3+20171226.6d62b64-3.3.1
Patchnames:
SUSE-SLE-Product-HA-15-2019-1812
SUSE Linux Enterprise High Availability 15 SP1
  • libqb >= 1.0.3+20190326.a521604-3.3.1
  • libqb-devel >= 1.0.3+20190326.a521604-3.3.1
  • libqb-tests >= 1.0.3+20190326.a521604-3.3.1
  • libqb-tools >= 1.0.3+20190326.a521604-3.3.1
  • libqb20 >= 1.0.3+20190326.a521604-3.3.1
Patchnames:
SUSE-SLE-Product-HA-15-SP1-2019-1791
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libqb >= 1.0.3+20171226.6d62b64-3.3.1
  • libqb-devel-32bit >= 1.0.3+20190326.a521604-3.3.1
  • libqb0 >= 1.0.3+20171226.6d62b64-3.3.1
  • libqb0-32bit >= 1.0.3+20171226.6d62b64-3.3.1
  • libqb20-32bit >= 1.0.3+20190326.a521604-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1791
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1812
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libdlm >= 4.0.7-3.3.2
  • libdlm-devel >= 4.0.7-3.3.2
  • libqb >= 1.0.3+20171226.6d62b64-4.3.1
  • libqb-devel >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1806
openSUSE Leap 15.0
  • libqb >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb-debugsource >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb-devel >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb-devel-32bit >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb0 >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb0-32bit >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb0-32bit-debuginfo >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb0-debuginfo >= 1.0.3+20171226.6d62b64-lp150.2.3.1
Patchnames:
openSUSE-2019-1718
openSUSE Leap 15.1
  • libqb >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-debugsource >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-devel >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-devel-32bit >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-tests >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-tests-debuginfo >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-tools >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-tools-debuginfo >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb20 >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb20-32bit >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb20-32bit-debuginfo >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb20-debuginfo >= 1.0.3+20190326.a521604-lp151.2.3.1
Patchnames:
openSUSE-2019-1752


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability 12 GA libqb Affected
SUSE Linux Enterprise High Availability 12 SP2 libqb Affected
SUSE Linux Enterprise High Availability 12 SP3 libqb Released
SUSE Linux Enterprise High Availability 12 SP4 libqb Released
SUSE Linux Enterprise High Availability 15 GA libqb Released
SUSE Linux Enterprise High Availability 15 SP1 libqb Released
SUSE Linux Enterprise SDK 12 SP3 libqb Affected
SUSE Linux Enterprise SDK 12 SP4 libqb Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 libqb Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA libqb Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libqb Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libqb Released