Upstream information

CVE-2019-12293 at MITRE

Description

In Poppler through 0.76.1, there is a heap-based buffer over-read in JPXStream::init in JPEG2000Stream.cc via data with inconsistent heights or widths.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 5.1
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1136105 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications poppler Not affected
SUSE CaaS Platform 4.5 poppler Not affected
SUSE Enterprise Storage 7 poppler Not affected
SUSE Linux Enterprise Desktop 12 SP3 poppler Affected
SUSE Linux Enterprise Desktop 12 SP4 poppler Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 poppler Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS poppler Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS poppler Not affected
SUSE Linux Enterprise Module for Basesystem 15 poppler Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 poppler Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 poppler Not affected
SUSE Linux Enterprise Server 11 SP1 poppler Not affected
SUSE Linux Enterprise Server 11 SP3 poppler Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS poppler Not affected
SUSE Linux Enterprise Server 11 SP4 poppler Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS poppler Not affected
SUSE Linux Enterprise Server 12 LTSS poppler Unsupported
SUSE Linux Enterprise Server 12 SP1 LTSS poppler Unsupported
SUSE Linux Enterprise Server 12 SP2 BCL poppler Affected
SUSE Linux Enterprise Server 12 SP2 LTSS poppler Unsupported
SUSE Linux Enterprise Server 12 SP3 poppler Affected
SUSE Linux Enterprise Server 12 SP3 BCL poppler Affected
SUSE Linux Enterprise Server 12 SP4 poppler Affected
SUSE Linux Enterprise Server 12 SP4 LTSS poppler Affected
SUSE Linux Enterprise Server 15 SP2 LTSS poppler Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 poppler Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 poppler Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 poppler Not affected
SUSE Linux Enterprise Software Bootstrap Kit 12 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 poppler Affected
SUSE Manager Proxy 4.1 poppler Not affected
SUSE Manager Retail Branch Server 4.1 poppler Not affected
SUSE Manager Server 4.1 poppler Not affected