Upstream information

CVE-2019-11247 at MITRE

Description

The Kubernetes kube-apiserver mistakenly allows access to a cluster-scoped custom resource if the request is made as if the resource were namespaced. Authorizations for the resource accessed in this manner are enforced using roles and role bindings within the namespace, meaning that a user with access only to a resource in one namespace could create, view update or delete the cluster-scoped resource (according to their namespace role privileges). Kubernetes affected versions include versions prior to 1.13.9, versions prior to 1.14.5, versions prior to 1.15.2, and versions 1.7, 1.8, 1.9, 1.10, 1.11, 1.12.

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 5
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low High
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact None Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entries: 1142423 [REOPENED], 1142434 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • kubernetes-apiserver >= 1.22.2-21.2
  • kubernetes-apiserver-minus1 >= 1.21.5-21.2
  • kubernetes-client >= 1.22.2-21.2
  • kubernetes-controller-manager >= 1.22.2-21.2
  • kubernetes-controller-manager-minus1 >= 1.21.5-21.2
  • kubernetes-coredns >= 1.8.4-21.2
  • kubernetes-coredns-minus1 >= 1.8.0-21.2
  • kubernetes-etcd >= 3.5.0-21.2
  • kubernetes-etcd-minus1 >= 3.4.13-21.2
  • kubernetes-kubeadm >= 1.22.2-21.2
  • kubernetes-kubelet >= 1.22.2-21.2
  • kubernetes-proxy >= 1.22.2-21.2
  • kubernetes-proxy-minus1 >= 1.21.5-21.2
  • kubernetes-scheduler >= 1.22.2-21.2
  • kubernetes-scheduler-minus1 >= 1.21.5-21.2
Patchnames:
openSUSE Tumbleweed GA kubernetes-apiserver-1.22.2-21.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration kubernetes Not affected
SUSE CaaS Platform 3.0 kubernetes Affected
SUSE CaaS Platform 4.0 kubernetes In progress
SUSE CaaS Platform 4.5 kubernetes-1.18 In progress
SUSE Container as a Service Platform 1.0 kubernetes Affected
SUSE Container as a Service Platform 2.0 kubernetes Analysis
SUSE Enterprise Storage 6 kubernetes In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS kubernetes In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS kubernetes In progress
SUSE Linux Enterprise Module for Containers 15 SP1 kubernetes Unsupported
SUSE Linux Enterprise Module for Public Cloud 12 kubernetes Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS kubernetes In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 kubernetes In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 kubernetes In progress
SUSE Manager Proxy 4.0 kubernetes In progress
SUSE Manager Retail Branch Server 4.0 kubernetes In progress
SUSE Manager Server 4.0 kubernetes In progress