Upstream information

CVE-2019-11038 at MITRE

Description

When using the gdImageCreateFromXbm() function in the GD Graphics Library (aka LibGD) 2.2.5, as used in the PHP GD extension in PHP versions 7.1.x below 7.1.30, 7.2.x below 7.2.19 and 7.3.x below 7.3.6, it is possible to supply data that will cause the function to use the value of uninitialized variable. This may lead to disclosing contents of the stack that has been left there by previous code.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 4
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1140118 [RESOLVED / FIXED], 1140120 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/nginx-ingress-controller:beta1
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-OCI-BYOS-SAP-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • gd >= 2.1.0-24.17.1
Image SLES15-SAP-Azure
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SAP-EC2-HVM
Image SLES15-SAP-EC2-HVM-BYOS
Image SLES15-SAP-GCE
Image SLES15-SAP-GCE-BYOS
Image SLES15-SAP-OCI-BYOS
Image SLES15-SP1-CAP-Deployment-BYOS-Azure
Image SLES15-SP1-CAP-Deployment-BYOS-EC2-HVM
Image SLES15-SP1-CAP-Deployment-BYOS-GCE
Image SLES15-SP1-SAP-Azure
Image SLES15-SP1-SAP-Azure-BYOS
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP1-SAP-EC2-HVM
Image SLES15-SP1-SAP-EC2-HVM-BYOS
Image SLES15-SP1-SAP-GCE
Image SLES15-SP1-SAP-GCE-BYOS
Image SLES15-SP1-SAP-OCI-BYOS
  • libgd3 >= 2.2.5-4.14.1
SUSE Linux Enterprise Desktop 12 SP4
  • gd >= 2.1.0-24.17.1
  • gd-32bit >= 2.1.0-24.17.1
  • gd-devel >= 2.1.0-24.17.1
  • php7-devel >= 7.0.7-50.85.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2020-623
SUSE-SLE-SDK-12-SP4-2019-2243
SUSE-SLE-SDK-12-SP4-2020-623
SUSE-SLE-WE-12-SP4-2020-623
SUSE Linux Enterprise Desktop 12 SP5
SUSE Linux Enterprise Workstation Extension 12 SP5
  • gd-32bit >= 2.1.0-24.17.1
Patchnames:
SUSE-SLE-WE-12-SP5-2020-623
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Storage 6
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • gd >= 2.2.5-4.14.1
  • gd-devel >= 2.2.5-4.14.1
  • libgd3 >= 2.2.5-4.14.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-594
SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-594
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • gd >= 2.2.5-9.1
  • gd-devel >= 2.2.5-9.1
  • libgd3 >= 2.2.5-9.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libgd3-2.2.5-9.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA gd-2.2.5-9.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • gd >= 2.2.5-9.1
  • gd-devel >= 2.2.5-9.1
  • libgd3 >= 2.2.5-9.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA gd-devel-2.2.5-9.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA gd-2.2.5-9.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • gd >= 2.2.5-11.3.1
  • gd-devel >= 2.2.5-11.3.1
  • libgd3 >= 2.2.5-11.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA gd-devel-2.2.5-11.3.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA gd-2.2.5-11.3.1
SUSE Linux Enterprise High Performance Computing 12
SUSE Linux Enterprise Module for Web Scripting 12
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • apache2-mod_php7 >= 7.0.7-50.85.1
  • php7 >= 7.0.7-50.85.1
  • php7-bcmath >= 7.0.7-50.85.1
  • php7-bz2 >= 7.0.7-50.85.1
  • php7-calendar >= 7.0.7-50.85.1
  • php7-ctype >= 7.0.7-50.85.1
  • php7-curl >= 7.0.7-50.85.1
  • php7-dba >= 7.0.7-50.85.1
  • php7-dom >= 7.0.7-50.85.1
  • php7-enchant >= 7.0.7-50.85.1
  • php7-exif >= 7.0.7-50.85.1
  • php7-fastcgi >= 7.0.7-50.85.1
  • php7-fileinfo >= 7.0.7-50.85.1
  • php7-fpm >= 7.0.7-50.85.1
  • php7-ftp >= 7.0.7-50.85.1
  • php7-gd >= 7.0.7-50.85.1
  • php7-gettext >= 7.0.7-50.85.1
  • php7-gmp >= 7.0.7-50.85.1
  • php7-iconv >= 7.0.7-50.85.1
  • php7-imap >= 7.0.7-50.85.1
  • php7-intl >= 7.0.7-50.85.1
  • php7-json >= 7.0.7-50.85.1
  • php7-ldap >= 7.0.7-50.85.1
  • php7-mbstring >= 7.0.7-50.85.1
  • php7-mcrypt >= 7.0.7-50.85.1
  • php7-mysql >= 7.0.7-50.85.1
  • php7-odbc >= 7.0.7-50.85.1
  • php7-opcache >= 7.0.7-50.85.1
  • php7-openssl >= 7.0.7-50.85.1
  • php7-pcntl >= 7.0.7-50.85.1
  • php7-pdo >= 7.0.7-50.85.1
  • php7-pear >= 7.0.7-50.85.1
  • php7-pear-Archive_Tar >= 7.0.7-50.85.1
  • php7-pgsql >= 7.0.7-50.85.1
  • php7-phar >= 7.0.7-50.85.1
  • php7-posix >= 7.0.7-50.85.1
  • php7-pspell >= 7.0.7-50.85.1
  • php7-shmop >= 7.0.7-50.85.1
  • php7-snmp >= 7.0.7-50.85.1
  • php7-soap >= 7.0.7-50.85.1
  • php7-sockets >= 7.0.7-50.85.1
  • php7-sqlite >= 7.0.7-50.85.1
  • php7-sysvmsg >= 7.0.7-50.85.1
  • php7-sysvsem >= 7.0.7-50.85.1
  • php7-sysvshm >= 7.0.7-50.85.1
  • php7-tokenizer >= 7.0.7-50.85.1
  • php7-wddx >= 7.0.7-50.85.1
  • php7-xmlreader >= 7.0.7-50.85.1
  • php7-xmlrpc >= 7.0.7-50.85.1
  • php7-xmlwriter >= 7.0.7-50.85.1
  • php7-xsl >= 7.0.7-50.85.1
  • php7-zip >= 7.0.7-50.85.1
  • php7-zlib >= 7.0.7-50.85.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2019-2243
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libgd3 >= 2.2.5-4.14.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-594
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libgd3 >= 2.2.5-9.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libgd3-2.2.5-9.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • gd-devel >= 2.2.5-9.1
  • libgd3 >= 2.2.5-9.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA gd-devel-2.2.5-9.1
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • gd-devel >= 2.2.5-11.3.1
  • libgd3 >= 2.2.5-11.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA gd-devel-2.2.5-11.3.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • gd >= 2.2.5-4.14.1
  • gd-devel >= 2.2.5-4.14.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-594
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • gd >= 2.2.5-9.1
  • gd-devel >= 2.2.5-9.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA gd-2.2.5-9.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • gd >= 2.2.5-9.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA gd-2.2.5-9.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • gd >= 2.2.5-11.3.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA gd-2.2.5-11.3.1
SUSE Linux Enterprise Module for Package Hub 15 SP1
  • libgd3-32bit >= 2.2.5-4.14.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-594
SUSE Linux Enterprise Point of Sale 11 SP3
  • apache2-mod_php53 >= 5.3.17-112.71.1
  • php53 >= 5.3.17-112.71.1
  • php53-bcmath >= 5.3.17-112.71.1
  • php53-bz2 >= 5.3.17-112.71.1
  • php53-calendar >= 5.3.17-112.71.1
  • php53-ctype >= 5.3.17-112.71.1
  • php53-curl >= 5.3.17-112.71.1
  • php53-dba >= 5.3.17-112.71.1
  • php53-dom >= 5.3.17-112.71.1
  • php53-exif >= 5.3.17-112.71.1
  • php53-fastcgi >= 5.3.17-112.71.1
  • php53-fileinfo >= 5.3.17-112.71.1
  • php53-ftp >= 5.3.17-112.71.1
  • php53-gd >= 5.3.17-112.71.1
  • php53-gettext >= 5.3.17-112.71.1
  • php53-gmp >= 5.3.17-112.71.1
  • php53-iconv >= 5.3.17-112.71.1
  • php53-intl >= 5.3.17-112.71.1
  • php53-json >= 5.3.17-112.71.1
  • php53-ldap >= 5.3.17-112.71.1
  • php53-mbstring >= 5.3.17-112.71.1
  • php53-mcrypt >= 5.3.17-112.71.1
  • php53-mysql >= 5.3.17-112.71.1
  • php53-odbc >= 5.3.17-112.71.1
  • php53-openssl >= 5.3.17-112.71.1
  • php53-pcntl >= 5.3.17-112.71.1
  • php53-pdo >= 5.3.17-112.71.1
  • php53-pear >= 5.3.17-112.71.1
  • php53-pgsql >= 5.3.17-112.71.1
  • php53-pspell >= 5.3.17-112.71.1
  • php53-shmop >= 5.3.17-112.71.1
  • php53-snmp >= 5.3.17-112.71.1
  • php53-soap >= 5.3.17-112.71.1
  • php53-suhosin >= 5.3.17-112.71.1
  • php53-sysvmsg >= 5.3.17-112.71.1
  • php53-sysvsem >= 5.3.17-112.71.1
  • php53-sysvshm >= 5.3.17-112.71.1
  • php53-tokenizer >= 5.3.17-112.71.1
  • php53-wddx >= 5.3.17-112.71.1
  • php53-xmlreader >= 5.3.17-112.71.1
  • php53-xmlrpc >= 5.3.17-112.71.1
  • php53-xmlwriter >= 5.3.17-112.71.1
  • php53-xsl >= 5.3.17-112.71.1
  • php53-zip >= 5.3.17-112.71.1
  • php53-zlib >= 5.3.17-112.71.1
Patchnames:
sleposp3-php53-14158
SUSE Linux Enterprise Server 11 SP4-LTSS
  • apache2-mod_php53 >= 5.3.17-112.71.1
  • php53 >= 5.3.17-112.71.1
  • php53-bcmath >= 5.3.17-112.71.1
  • php53-bz2 >= 5.3.17-112.71.1
  • php53-calendar >= 5.3.17-112.71.1
  • php53-ctype >= 5.3.17-112.71.1
  • php53-curl >= 5.3.17-112.71.1
  • php53-dba >= 5.3.17-112.71.1
  • php53-dom >= 5.3.17-112.71.1
  • php53-exif >= 5.3.17-112.71.1
  • php53-fastcgi >= 5.3.17-112.71.1
  • php53-fileinfo >= 5.3.17-112.71.1
  • php53-ftp >= 5.3.17-112.71.1
  • php53-gd >= 5.3.17-112.71.1
  • php53-gettext >= 5.3.17-112.71.1
  • php53-gmp >= 5.3.17-112.71.1
  • php53-iconv >= 5.3.17-112.71.1
  • php53-intl >= 5.3.17-112.71.1
  • php53-json >= 5.3.17-112.71.1
  • php53-ldap >= 5.3.17-112.71.1
  • php53-mbstring >= 5.3.17-112.71.1
  • php53-mcrypt >= 5.3.17-112.71.1
  • php53-mysql >= 5.3.17-112.71.1
  • php53-odbc >= 5.3.17-112.71.1
  • php53-openssl >= 5.3.17-112.71.1
  • php53-pcntl >= 5.3.17-112.71.1
  • php53-pdo >= 5.3.17-112.71.1
  • php53-pear >= 5.3.17-112.71.1
  • php53-pgsql >= 5.3.17-112.71.1
  • php53-pspell >= 5.3.17-112.71.1
  • php53-shmop >= 5.3.17-112.71.1
  • php53-snmp >= 5.3.17-112.71.1
  • php53-soap >= 5.3.17-112.71.1
  • php53-suhosin >= 5.3.17-112.71.1
  • php53-sysvmsg >= 5.3.17-112.71.1
  • php53-sysvsem >= 5.3.17-112.71.1
  • php53-sysvshm >= 5.3.17-112.71.1
  • php53-tokenizer >= 5.3.17-112.71.1
  • php53-wddx >= 5.3.17-112.71.1
  • php53-xmlreader >= 5.3.17-112.71.1
  • php53-xmlrpc >= 5.3.17-112.71.1
  • php53-xmlwriter >= 5.3.17-112.71.1
  • php53-xsl >= 5.3.17-112.71.1
  • php53-zip >= 5.3.17-112.71.1
  • php53-zlib >= 5.3.17-112.71.1
Patchnames:
slessp4-php53-14158
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • apache2-mod_php7 >= 7.0.7-50.85.1
  • gd >= 2.1.0-24.17.1
  • gd-32bit >= 2.1.0-24.17.1
  • gd-devel >= 2.1.0-24.17.1
  • php7 >= 7.0.7-50.85.1
  • php7-bcmath >= 7.0.7-50.85.1
  • php7-bz2 >= 7.0.7-50.85.1
  • php7-calendar >= 7.0.7-50.85.1
  • php7-ctype >= 7.0.7-50.85.1
  • php7-curl >= 7.0.7-50.85.1
  • php7-dba >= 7.0.7-50.85.1
  • php7-devel >= 7.0.7-50.85.1
  • php7-dom >= 7.0.7-50.85.1
  • php7-enchant >= 7.0.7-50.85.1
  • php7-exif >= 7.0.7-50.85.1
  • php7-fastcgi >= 7.0.7-50.85.1
  • php7-fileinfo >= 7.0.7-50.85.1
  • php7-fpm >= 7.0.7-50.85.1
  • php7-ftp >= 7.0.7-50.85.1
  • php7-gd >= 7.0.7-50.85.1
  • php7-gettext >= 7.0.7-50.85.1
  • php7-gmp >= 7.0.7-50.85.1
  • php7-iconv >= 7.0.7-50.85.1
  • php7-imap >= 7.0.7-50.85.1
  • php7-intl >= 7.0.7-50.85.1
  • php7-json >= 7.0.7-50.85.1
  • php7-ldap >= 7.0.7-50.85.1
  • php7-mbstring >= 7.0.7-50.85.1
  • php7-mcrypt >= 7.0.7-50.85.1
  • php7-mysql >= 7.0.7-50.85.1
  • php7-odbc >= 7.0.7-50.85.1
  • php7-opcache >= 7.0.7-50.85.1
  • php7-openssl >= 7.0.7-50.85.1
  • php7-pcntl >= 7.0.7-50.85.1
  • php7-pdo >= 7.0.7-50.85.1
  • php7-pear >= 7.0.7-50.85.1
  • php7-pear-Archive_Tar >= 7.0.7-50.85.1
  • php7-pgsql >= 7.0.7-50.85.1
  • php7-phar >= 7.0.7-50.85.1
  • php7-posix >= 7.0.7-50.85.1
  • php7-pspell >= 7.0.7-50.85.1
  • php7-shmop >= 7.0.7-50.85.1
  • php7-snmp >= 7.0.7-50.85.1
  • php7-soap >= 7.0.7-50.85.1
  • php7-sockets >= 7.0.7-50.85.1
  • php7-sqlite >= 7.0.7-50.85.1
  • php7-sysvmsg >= 7.0.7-50.85.1
  • php7-sysvsem >= 7.0.7-50.85.1
  • php7-sysvshm >= 7.0.7-50.85.1
  • php7-tokenizer >= 7.0.7-50.85.1
  • php7-wddx >= 7.0.7-50.85.1
  • php7-xmlreader >= 7.0.7-50.85.1
  • php7-xmlrpc >= 7.0.7-50.85.1
  • php7-xmlwriter >= 7.0.7-50.85.1
  • php7-xsl >= 7.0.7-50.85.1
  • php7-zip >= 7.0.7-50.85.1
  • php7-zlib >= 7.0.7-50.85.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2019-2243
SUSE-SLE-SDK-12-SP4-2019-2243
SUSE-SLE-SDK-12-SP4-2020-623
SUSE-SLE-SERVER-12-SP4-2020-623
SUSE-SLE-WE-12-SP4-2020-623
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • apache2-mod_php7 >= 7.0.7-50.85.1
  • gd >= 2.1.0-24.17.1
  • gd-32bit >= 2.1.0-24.17.1
  • gd-devel >= 2.1.0-24.17.1
  • php7 >= 7.0.7-50.85.1
  • php7-bcmath >= 7.0.7-50.85.1
  • php7-bz2 >= 7.0.7-50.85.1
  • php7-calendar >= 7.0.7-50.85.1
  • php7-ctype >= 7.0.7-50.85.1
  • php7-curl >= 7.0.7-50.85.1
  • php7-dba >= 7.0.7-50.85.1
  • php7-devel >= 7.0.7-50.85.1
  • php7-dom >= 7.0.7-50.85.1
  • php7-enchant >= 7.0.7-50.85.1
  • php7-exif >= 7.0.7-50.85.1
  • php7-fastcgi >= 7.0.7-50.85.1
  • php7-fileinfo >= 7.0.7-50.85.1
  • php7-fpm >= 7.0.7-50.85.1
  • php7-ftp >= 7.0.7-50.85.1
  • php7-gd >= 7.0.7-50.85.1
  • php7-gettext >= 7.0.7-50.85.1
  • php7-gmp >= 7.0.7-50.85.1
  • php7-iconv >= 7.0.7-50.85.1
  • php7-imap >= 7.0.7-50.85.1
  • php7-intl >= 7.0.7-50.85.1
  • php7-json >= 7.0.7-50.85.1
  • php7-ldap >= 7.0.7-50.85.1
  • php7-mbstring >= 7.0.7-50.85.1
  • php7-mcrypt >= 7.0.7-50.85.1
  • php7-mysql >= 7.0.7-50.85.1
  • php7-odbc >= 7.0.7-50.85.1
  • php7-opcache >= 7.0.7-50.85.1
  • php7-openssl >= 7.0.7-50.85.1
  • php7-pcntl >= 7.0.7-50.85.1
  • php7-pdo >= 7.0.7-50.85.1
  • php7-pear >= 7.0.7-50.85.1
  • php7-pear-Archive_Tar >= 7.0.7-50.85.1
  • php7-pgsql >= 7.0.7-50.85.1
  • php7-phar >= 7.0.7-50.85.1
  • php7-posix >= 7.0.7-50.85.1
  • php7-pspell >= 7.0.7-50.85.1
  • php7-shmop >= 7.0.7-50.85.1
  • php7-snmp >= 7.0.7-50.85.1
  • php7-soap >= 7.0.7-50.85.1
  • php7-sockets >= 7.0.7-50.85.1
  • php7-sqlite >= 7.0.7-50.85.1
  • php7-sysvmsg >= 7.0.7-50.85.1
  • php7-sysvsem >= 7.0.7-50.85.1
  • php7-sysvshm >= 7.0.7-50.85.1
  • php7-tokenizer >= 7.0.7-50.85.1
  • php7-wddx >= 7.0.7-50.85.1
  • php7-xmlreader >= 7.0.7-50.85.1
  • php7-xmlrpc >= 7.0.7-50.85.1
  • php7-xmlwriter >= 7.0.7-50.85.1
  • php7-xsl >= 7.0.7-50.85.1
  • php7-zip >= 7.0.7-50.85.1
  • php7-zlib >= 7.0.7-50.85.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA php7-devel-7.0.7-50.85.1
SUSE-SLE-Module-Web-Scripting-12-2019-2243
SUSE-SLE-SDK-12-SP5-2020-623
SUSE-SLE-SERVER-12-SP5-2020-623
SUSE-SLE-WE-12-SP5-2020-623
SUSE Linux Enterprise Software Development Kit 12 SP4
  • gd-devel >= 2.1.0-24.17.1
  • php7-devel >= 7.0.7-50.85.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2243
SUSE-SLE-SDK-12-SP4-2020-623
SUSE Linux Enterprise Software Development Kit 12 SP5
  • gd-devel >= 2.1.0-24.17.1
  • php7-devel >= 7.0.7-50.85.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA php7-devel-7.0.7-50.85.1
SUSE-SLE-SDK-12-SP5-2020-623
SUSE Linux Enterprise Workstation Extension 12 SP4
  • gd-32bit >= 2.1.0-24.17.1
Patchnames:
SUSE-SLE-WE-12-SP4-2020-623
openSUSE Leap 15.1
  • gd >= 2.2.5-lp151.6.6.1
  • gd-devel >= 2.2.5-lp151.6.6.1
  • libgd3 >= 2.2.5-lp151.6.6.1
  • libgd3-32bit >= 2.2.5-lp151.6.6.1
Patchnames:
openSUSE-2020-332
openSUSE Leap 15.2
  • libgd3 >= 2.2.5-lp152.8.3
Patchnames:
openSUSE Leap 15.2 GA libgd3-2.2.5-lp152.8.1
openSUSE Leap 15.3
  • libgd3 >= 2.2.5-9.1
Patchnames:
openSUSE Leap 15.3 GA libgd3-2.2.5-9.1
openSUSE Leap 15.4
  • libgd3 >= 2.2.5-11.3.1
Patchnames:
openSUSE Leap 15.4 GA libgd3-2.2.5-11.3.1
openSUSE Tumbleweed
  • gd >= 2.3.3-1.1
  • gd-devel >= 2.3.3-1.1
  • gd-devel-32bit >= 2.3.3-1.1
  • libgd3 >= 2.3.3-1.1
  • libgd3-32bit >= 2.3.3-1.1
Patchnames:
openSUSE Tumbleweed GA gd-2.3.3-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 gd Released
SLES for SAP Applications gd Unsupported
SLES for SAP Applications php5 Unsupported
SLES for SAP Applications php53 Unsupported
SUSE CaaS Platform 4.0 gd In progress
SUSE Enterprise Storage 5 gd Released
SUSE Enterprise Storage 6 gd In progress
SUSE Linux Enterprise Desktop 11 php5 Unsupported
SUSE Linux Enterprise Desktop 11 SP1 php5 Unsupported
SUSE Linux Enterprise Desktop 11 SP2 php5 Unsupported
SUSE Linux Enterprise Desktop 11 SP2 php53 Ignore
SUSE Linux Enterprise Desktop 11 SP3 php53 Unsupported
SUSE Linux Enterprise Desktop 11 SP4 php53 Unsupported
SUSE Linux Enterprise Desktop 12 php5 Unsupported
SUSE Linux Enterprise Desktop 12 php7 Unsupported
SUSE Linux Enterprise Desktop 12 SP1 php5 Unsupported
SUSE Linux Enterprise Desktop 12 SP1 php7 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 php5 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 php7 Unsupported
SUSE Linux Enterprise Desktop 12 SP3 gd Unsupported
SUSE Linux Enterprise Desktop 12 SP3 php5 Unsupported
SUSE Linux Enterprise Desktop 12 SP3 php7 Unsupported
SUSE Linux Enterprise Desktop 12 SP3 php72 Unsupported
SUSE Linux Enterprise Desktop 12 SP4 gd Released
SUSE Linux Enterprise Desktop 12 SP4 php5 Unsupported
SUSE Linux Enterprise Desktop 12 SP4 php7 Released
SUSE Linux Enterprise Desktop 12 SP5 gd Released
SUSE Linux Enterprise Desktop 15 gd Unsupported
SUSE Linux Enterprise Desktop 15 SP1 gd Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search php5 Unsupported
SUSE Linux Enterprise High Performance Computing 12 php5 In progress
SUSE Linux Enterprise High Performance Computing 12 php7 Released
SUSE Linux Enterprise High Performance Computing 12 php72 In progress
SUSE Linux Enterprise High Performance Computing 12 php74 In progress
SUSE Linux Enterprise High Performance Computing 12 SP4 gd Released
SUSE Linux Enterprise High Performance Computing 12 SP5 gd Released
SUSE Linux Enterprise High Performance Computing 15 gd Unsupported
SUSE Linux Enterprise High Performance Computing 15 php7 Unsupported
SUSE Linux Enterprise High Performance Computing 15 LTSS gd In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 gd Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS gd In progress
SUSE Linux Enterprise Module for Basesystem 15 gd Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP1 gd Released
SUSE Linux Enterprise Module for Desktop Applications 15 gd Unsupported
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 gd Released
SUSE Linux Enterprise Module for Web and Scripting 12 php5 In progress
SUSE Linux Enterprise Module for Web and Scripting 12 php7 Released
SUSE Linux Enterprise Module for Web and Scripting 12 php72 In progress
SUSE Linux Enterprise Module for Web and Scripting 12 php74 In progress
SUSE Linux Enterprise Module for Web and Scripting 15 php7 Unsupported
SUSE Linux Enterprise Point of Service 11 SP3 gd Released
SUSE Linux Enterprise Point of Service 11 SP3 php53 Released
SUSE Linux Enterprise Point of Service Image Server 12 SP2 gd Released
SUSE Linux Enterprise Server 11 php5 Unsupported
SUSE Linux Enterprise Server 11 SP1 php5 Unsupported
SUSE Linux Enterprise Server 11 SP1 LTSS php5 Unsupported
SUSE Linux Enterprise Server 11 SP2 php5 Unsupported
SUSE Linux Enterprise Server 11 SP2 php53 Ignore
SUSE Linux Enterprise Server 11 SP2 LTSS php5 Unsupported
SUSE Linux Enterprise Server 11 SP2 LTSS php53 Ignore
SUSE Linux Enterprise Server 11 SP2 for VMware php5 Unsupported
SUSE Linux Enterprise Server 11 SP2 for VMware php53 Ignore
SUSE Linux Enterprise Server 11 SP3 php53 Unsupported
SUSE Linux Enterprise Server 11 SP3 LTSS gd Unsupported
SUSE Linux Enterprise Server 11 SP3 LTSS php53 Unsupported
SUSE Linux Enterprise Server 11 SP3 for VMware php53 Unsupported
SUSE Linux Enterprise Server 11 SP4 php53 Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS gd Released
SUSE Linux Enterprise Server 11 SP4 LTSS php53 Released
SUSE Linux Enterprise Server 12 php5 Unsupported
SUSE Linux Enterprise Server 12 php7 Unsupported
SUSE Linux Enterprise Server 12 php72 In progress
SUSE Linux Enterprise Server 12 php74 In progress
SUSE Linux Enterprise Server 12 LTSS gd Unsupported
SUSE Linux Enterprise Server 12 SP1 php5 Unsupported
SUSE Linux Enterprise Server 12 SP1 php7 Unsupported
SUSE Linux Enterprise Server 12 SP1 LTSS gd Affected
SUSE Linux Enterprise Server 12 SP2 php5 Unsupported
SUSE Linux Enterprise Server 12 SP2 php7 Unsupported
SUSE Linux Enterprise Server 12 SP2 BCL gd Released
SUSE Linux Enterprise Server 12 SP2 ESPOS gd Released
SUSE Linux Enterprise Server 12 SP2 LTSS gd Released
SUSE Linux Enterprise Server 12 SP3 gd Unsupported
SUSE Linux Enterprise Server 12 SP3 php5 Unsupported
SUSE Linux Enterprise Server 12 SP3 php7 Unsupported
SUSE Linux Enterprise Server 12 SP3 php72 Unsupported
SUSE Linux Enterprise Server 12 SP3 php74 In progress
SUSE Linux Enterprise Server 12 SP3 BCL gd Released
SUSE Linux Enterprise Server 12 SP3 ESPOS gd Released
SUSE Linux Enterprise Server 12 SP3 LTSS gd Released
SUSE Linux Enterprise Server 12 SP4 gd Released
SUSE Linux Enterprise Server 12 SP4 php5 Unsupported
SUSE Linux Enterprise Server 12 SP4 php7 Released
SUSE Linux Enterprise Server 12 SP4 php72 In progress
SUSE Linux Enterprise Server 12 SP4 php74 In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS gd Released
SUSE Linux Enterprise Server 12 SP4 LTSS gd Released
SUSE Linux Enterprise Server 12 SP5 gd Released
SUSE Linux Enterprise Server 12 SP5 php5 In progress
SUSE Linux Enterprise Server 12 SP5 php7 Released
SUSE Linux Enterprise Server 12 SP5 php72 In progress
SUSE Linux Enterprise Server 12 SP5 php74 In progress
SUSE Linux Enterprise Server 15 gd Unsupported
SUSE Linux Enterprise Server 15 php7 Unsupported
SUSE Linux Enterprise Server 15 ESPOS gd In progress
SUSE Linux Enterprise Server 15 LTSS gd In progress
SUSE Linux Enterprise Server 15 SP1 gd Released
SUSE Linux Enterprise Server 15 SP1 LTSS gd In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 gd In progress
SUSE Linux Enterprise Server for SAP Applications 11 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP1 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP2 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP2 php53 Ignore
SUSE Linux Enterprise Server for SAP Applications 11 SP3 php53 Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP4 php53 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 gd Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 php7 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 php72 In progress
SUSE Linux Enterprise Server for SAP Applications 12 php74 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP1 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP1 php7 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gd Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 php7 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gd Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php7 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php72 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php74 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gd Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php72 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php74 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gd Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php5 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php72 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php74 In progress
SUSE Linux Enterprise Server for SAP Applications 15 gd Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 php7 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 gd Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 11 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP1 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP2 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP2 php53 Ignore
SUSE Linux Enterprise Software Development Kit 11 SP3 php53 Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP4 php53 Unsupported
SUSE Linux Enterprise Software Development Kit 12 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 php7 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP1 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP1 php7 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 php7 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 gd Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 php7 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 php72 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 gd Released
SUSE Linux Enterprise Software Development Kit 12 SP4 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 php7 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 gd Released
SUSE Linux Enterprise Software Development Kit 12 SP5 php7 Released
SUSE Linux Enterprise Storage 6 gd Released
SUSE Linux Enterprise Workstation Extension 12 SP3 gd Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP4 gd Released
SUSE Linux Enterprise Workstation Extension 12 SP5 gd Released
SUSE Manager Proxy 4.0 gd Released
SUSE Manager Retail Branch Server 4.0 gd Released
SUSE Manager Server 4.0 gd Released
SUSE OpenStack Cloud 7 gd Released
SUSE OpenStack Cloud 8 gd Released
SUSE OpenStack Cloud 9 gd Released
SUSE OpenStack Cloud Crowbar 8 gd Released
SUSE OpenStack Cloud Crowbar 9 gd Released