Upstream information

CVE-2019-11023 at MITRE

Description

The agroot() function in cgraph\obj.c in libcgraph.a in Graphviz 2.39.20160612.1140 has a NULL pointer dereference, as demonstrated by graphml2gv.

SUSE information

Overall state of this security issue: Analysis

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 3.3
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1132091 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 15 SP1
  • graphviz-gd >= 2.40.1-6.3.2
  • graphviz-python >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Product-HA-15-SP1-2019-1267
SUSE Linux Enterprise High Availability 15 SP2
  • graphviz-gd >= 2.40.1-6.3.2
  • graphviz-python >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Product-HA-15-SP2-2020-1892
SUSE Linux Enterprise High Availability 15
  • graphviz-gd >= 2.40.1-6.3.2
  • graphviz-python >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Product-HA-15-2019-1267
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • graphviz >= 2.40.1-6.3.2
  • graphviz-devel >= 2.40.1-6.3.2
  • graphviz-plugins-core >= 2.40.1-6.3.2
  • libgraphviz6 >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-1267
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • graphviz >= 2.40.1-6.3.2
  • graphviz-devel >= 2.40.1-6.3.2
  • graphviz-plugins-core >= 2.40.1-6.3.2
  • libgraphviz6 >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2020-1892
SUSE Linux Enterprise Module for Basesystem 15
  • graphviz >= 2.40.1-6.3.2
  • graphviz-devel >= 2.40.1-6.3.2
  • graphviz-plugins-core >= 2.40.1-6.3.2
  • libgraphviz6 >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1267
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • graphviz-perl >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2019-1267
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • graphviz-perl >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2020-1892
SUSE Linux Enterprise Module for Development Tools 15
  • graphviz-perl >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2019-1267
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • graphviz-doc >= 2.40.1-6.3.2
  • graphviz-gnome >= 2.40.1-6.3.2
  • graphviz-guile >= 2.40.1-6.3.2
  • graphviz-gvedit >= 2.40.1-6.3.2
  • graphviz-java >= 2.40.1-6.3.2
  • graphviz-lua >= 2.40.1-6.3.2
  • graphviz-php >= 2.40.1-6.3.2
  • graphviz-ruby >= 2.40.1-6.3.2
  • graphviz-smyrna >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1267
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • graphviz-doc >= 2.40.1-6.3.2
  • graphviz-gnome >= 2.40.1-6.3.2
  • graphviz-guile >= 2.40.1-6.3.2
  • graphviz-gvedit >= 2.40.1-6.3.2
  • graphviz-java >= 2.40.1-6.3.2
  • graphviz-lua >= 2.40.1-6.3.2
  • graphviz-php >= 2.40.1-6.3.2
  • graphviz-ruby >= 2.40.1-6.3.2
  • graphviz-smyrna >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-1892
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • graphviz-doc >= 2.40.1-6.3.2
  • graphviz-gnome >= 2.40.1-6.3.2
  • graphviz-guile >= 2.40.1-6.3.2
  • graphviz-gvedit >= 2.40.1-6.3.2
  • graphviz-java >= 2.40.1-6.3.2
  • graphviz-lua >= 2.40.1-6.3.2
  • graphviz-php >= 2.40.1-6.3.2
  • graphviz-ruby >= 2.40.1-6.3.2
  • graphviz-smyrna >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1267
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • graphviz-tcl >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2019-1267
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • graphviz-tcl >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2020-1892
SUSE Linux Enterprise Module for Server Applications 15
  • graphviz-tcl >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-1267
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP1
  • graphviz-gnome >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-1892
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • graphviz-gnome >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2020-1892
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • graphviz-gnome >= 2.40.1-6.3.2
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-1267
openSUSE Leap 15.0
  • graphviz >= 2.40.1-lp150.5.3.1
  • graphviz-addons-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-addons-debugsource >= 2.40.1-lp150.5.3.1
  • graphviz-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-debugsource >= 2.40.1-lp150.5.3.1
  • graphviz-devel >= 2.40.1-lp150.5.3.1
  • graphviz-doc >= 2.40.1-lp150.5.3.1
  • graphviz-gd >= 2.40.1-lp150.5.3.1
  • graphviz-gd-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-gnome >= 2.40.1-lp150.5.3.1
  • graphviz-gnome-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-guile >= 2.40.1-lp150.5.3.1
  • graphviz-guile-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-gvedit >= 2.40.1-lp150.5.3.1
  • graphviz-gvedit-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-java >= 2.40.1-lp150.5.3.1
  • graphviz-java-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-lua >= 2.40.1-lp150.5.3.1
  • graphviz-lua-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-perl >= 2.40.1-lp150.5.3.1
  • graphviz-perl-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-php >= 2.40.1-lp150.5.3.1
  • graphviz-php-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-plugins-core >= 2.40.1-lp150.5.3.1
  • graphviz-plugins-core-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-python >= 2.40.1-lp150.5.3.1
  • graphviz-python-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-ruby >= 2.40.1-lp150.5.3.1
  • graphviz-ruby-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-smyrna >= 2.40.1-lp150.5.3.1
  • graphviz-smyrna-debuginfo >= 2.40.1-lp150.5.3.1
  • graphviz-tcl >= 2.40.1-lp150.5.3.1
  • graphviz-tcl-debuginfo >= 2.40.1-lp150.5.3.1
  • libgraphviz6 >= 2.40.1-lp150.5.3.1
  • libgraphviz6-debuginfo >= 2.40.1-lp150.5.3.1
Patchnames:
openSUSE-2019-1459
openSUSE Leap 15.1
  • graphviz >= 2.40.1-lp151.6.3.1
  • graphviz-addons-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-addons-debugsource >= 2.40.1-lp151.6.3.1
  • graphviz-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-debugsource >= 2.40.1-lp151.6.3.1
  • graphviz-devel >= 2.40.1-lp151.6.3.1
  • graphviz-doc >= 2.40.1-lp151.6.3.1
  • graphviz-gd >= 2.40.1-lp151.6.3.1
  • graphviz-gd-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-gnome >= 2.40.1-lp151.6.3.1
  • graphviz-gnome-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-guile >= 2.40.1-lp151.6.3.1
  • graphviz-guile-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-gvedit >= 2.40.1-lp151.6.3.1
  • graphviz-gvedit-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-java >= 2.40.1-lp151.6.3.1
  • graphviz-java-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-lua >= 2.40.1-lp151.6.3.1
  • graphviz-lua-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-perl >= 2.40.1-lp151.6.3.1
  • graphviz-perl-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-php >= 2.40.1-lp151.6.3.1
  • graphviz-php-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-plugins-core >= 2.40.1-lp151.6.3.1
  • graphviz-plugins-core-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-python >= 2.40.1-lp151.6.3.1
  • graphviz-python-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-ruby >= 2.40.1-lp151.6.3.1
  • graphviz-ruby-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-smyrna >= 2.40.1-lp151.6.3.1
  • graphviz-smyrna-debuginfo >= 2.40.1-lp151.6.3.1
  • graphviz-tcl >= 2.40.1-lp151.6.3.1
  • graphviz-tcl-debuginfo >= 2.40.1-lp151.6.3.1
  • libgraphviz6 >= 2.40.1-lp151.6.3.1
  • libgraphviz6-debuginfo >= 2.40.1-lp151.6.3.1
Patchnames:
openSUSE-2019-1434
openSUSE Leap 15.2
  • graphviz >= 2.40.1-lp152.7.4.2
  • graphviz-addons-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-addons-debugsource >= 2.40.1-lp152.7.4.2
  • graphviz-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-debugsource >= 2.40.1-lp152.7.4.2
  • graphviz-devel >= 2.40.1-lp152.7.4.2
  • graphviz-doc >= 2.40.1-lp152.7.4.2
  • graphviz-gd >= 2.40.1-lp152.7.4.2
  • graphviz-gd-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-gnome >= 2.40.1-lp152.7.4.2
  • graphviz-gnome-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-guile >= 2.40.1-lp152.7.4.2
  • graphviz-guile-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-gvedit >= 2.40.1-lp152.7.4.2
  • graphviz-gvedit-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-java >= 2.40.1-lp152.7.4.2
  • graphviz-java-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-lua >= 2.40.1-lp152.7.4.2
  • graphviz-lua-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-perl >= 2.40.1-lp152.7.4.2
  • graphviz-perl-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-php >= 2.40.1-lp152.7.4.2
  • graphviz-php-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-plugins-core >= 2.40.1-lp152.7.4.2
  • graphviz-plugins-core-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-python >= 2.40.1-lp152.7.4.2
  • graphviz-python-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-ruby >= 2.40.1-lp152.7.4.2
  • graphviz-ruby-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-smyrna >= 2.40.1-lp152.7.4.2
  • graphviz-smyrna-debuginfo >= 2.40.1-lp152.7.4.2
  • graphviz-tcl >= 2.40.1-lp152.7.4.2
  • graphviz-tcl-debuginfo >= 2.40.1-lp152.7.4.2
  • libgraphviz6 >= 2.40.1-lp152.7.4.2
  • libgraphviz6-debuginfo >= 2.40.1-lp152.7.4.2
Patchnames:
openSUSE-2020-876
openSUSE-2020-906


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 graphviz Analysis
HPE Helion OpenStack 8 graphviz-plugins Not affected
SLES for SAP Applications graphviz Not affected
SLES for SAP Applications graphviz-plugins Not affected
SUSE CaaS Platform 4.0 graphviz Released
SUSE CaaS Platform 4.0 graphviz-addons Analysis
SUSE Enterprise Storage 6 graphviz Released
SUSE Enterprise Storage 6 graphviz-addons Analysis
SUSE Linux Enterprise Desktop 12 SP3 graphviz Affected
SUSE Linux Enterprise Desktop 12 SP4 graphviz Affected
SUSE Linux Enterprise High Availability Extension 11 SP4 graphviz-plugins Not affected
SUSE Linux Enterprise High Availability Extension 12 SP3 graphviz-plugins Not affected
SUSE Linux Enterprise High Availability Extension 12 SP4 graphviz-plugins Not affected
SUSE Linux Enterprise High Availability Extension 12 SP5 graphviz-plugins Not affected
SUSE Linux Enterprise High Availability Extension 15 graphviz-addons Released
SUSE Linux Enterprise High Availability Extension 15 SP1 graphviz-addons Released
SUSE Linux Enterprise High Availability Extension 15 SP2 graphviz-addons Released
SUSE Linux Enterprise High Performance Computing 12 SP4 graphviz Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 graphviz Analysis
SUSE Linux Enterprise High Performance Computing 12 SP5 graphviz-plugins Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS graphviz Released
SUSE Linux Enterprise High Performance Computing 15 LTSS graphviz-addons Analysis
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS graphviz Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS graphviz-addons Analysis
SUSE Linux Enterprise Module for Basesystem 15 graphviz Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 graphviz Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 graphviz Released
SUSE Linux Enterprise Module for Development Tools 15 SP1 graphviz-addons Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 graphviz-addons Released
SUSE Linux Enterprise Module for Server Applications 15 SP1 graphviz-addons Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 graphviz-addons Released
SUSE Linux Enterprise Point of Service 11 SP3 graphviz Analysis
SUSE Linux Enterprise Point of Service 11 SP3 graphviz-plugins Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS graphviz Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS graphviz Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS graphviz-plugins Not affected
SUSE Linux Enterprise Server 12 graphviz Not affected
SUSE Linux Enterprise Server 12 LTSS graphviz Not affected
SUSE Linux Enterprise Server 12 SP2 BCL graphviz Analysis
SUSE Linux Enterprise Server 12 SP2 BCL graphviz-plugins Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS graphviz Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON graphviz Analysis
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON graphviz-plugins Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP graphviz Analysis
SUSE Linux Enterprise Server 12 SP2 LTSS SAP graphviz-plugins Not affected
SUSE Linux Enterprise Server 12 SP3 graphviz Affected
SUSE Linux Enterprise Server 12 SP3 BCL graphviz Analysis
SUSE Linux Enterprise Server 12 SP3 BCL graphviz-plugins Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS graphviz Analysis
SUSE Linux Enterprise Server 12 SP3 ESPOS graphviz-plugins Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS graphviz Analysis
SUSE Linux Enterprise Server 12 SP3 LTSS graphviz-plugins Not affected
SUSE Linux Enterprise Server 12 SP4 graphviz Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS graphviz Analysis
SUSE Linux Enterprise Server 12 SP4 ESPOS graphviz-plugins Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS graphviz Analysis
SUSE Linux Enterprise Server 12 SP4 LTSS graphviz-plugins Not affected
SUSE Linux Enterprise Server 12 SP5 graphviz Analysis
SUSE Linux Enterprise Server 12 SP5 graphviz-plugins Not affected
SUSE Linux Enterprise Server 15 LTSS graphviz Released
SUSE Linux Enterprise Server 15 LTSS graphviz-addons Analysis
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux graphviz Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux graphviz-addons Analysis
SUSE Linux Enterprise Server 15 SP1 LTSS graphviz Released
SUSE Linux Enterprise Server 15 SP1 LTSS graphviz-addons Analysis
SUSE Linux Enterprise Server ESPOS 15 graphviz Released
SUSE Linux Enterprise Server ESPOS 15 graphviz-addons Analysis
SUSE Linux Enterprise Server for SAP Applications 12 graphviz Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 graphviz Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 graphviz Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 graphviz-plugins Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 graphviz Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 graphviz-plugins Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 graphviz Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP5 graphviz-plugins Not affected
SUSE Linux Enterprise Server for SAP Applications 15 graphviz Released
SUSE Linux Enterprise Server for SAP Applications 15 graphviz-addons Analysis
SUSE Linux Enterprise Server for SAP Applications 15 SP1 graphviz Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 graphviz-addons Analysis
SUSE Linux Enterprise Software Development Kit 12 SP3 graphviz Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 graphviz Affected
SUSE Manager Proxy 4.0 graphviz Released
SUSE Manager Proxy 4.0 graphviz-addons Analysis
SUSE Manager Retail Branch Server 4.0 graphviz Released
SUSE Manager Retail Branch Server 4.0 graphviz-addons Analysis
SUSE Manager Server 4.0 graphviz Released
SUSE Manager Server 4.0 graphviz-addons Analysis
SUSE OpenStack Cloud 8 graphviz Analysis
SUSE OpenStack Cloud 8 graphviz-plugins Not affected
SUSE OpenStack Cloud 9 graphviz Analysis
SUSE OpenStack Cloud 9 graphviz-plugins Not affected
SUSE OpenStack Cloud Crowbar 8 graphviz Analysis
SUSE OpenStack Cloud Crowbar 8 graphviz-plugins Not affected
SUSE OpenStack Cloud Crowbar 9 graphviz Analysis
SUSE OpenStack Cloud Crowbar 9 graphviz-plugins Not affected