Upstream information

CVE-2018-7738 at MITRE

Description

In util-linux before 2.32-rc1, bash-completion/umount allows local users to gain privileges by embedding shell commands in a mountpoint name, which is mishandled during a umount command (within Bash) by a different user, as demonstrated by logging in as root and entering umount followed by a tab character for autocompletion.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 8.2
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Changed
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1080740 [RESOLVED / FIXED], 1084300 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/default-http-backend:beta1
Container caasp/v4/dnsmasq-nanny:2.78
Container caasp/v4/flannel:0.9.1
Container caasp/v4/kubedns:beta1
Container caasp/v4/nginx-ingress-controller:beta1
Container caasp/v4/openldap:beta1
Container caasp/v4/pause:1.0.0
Container caasp/v4/pv-recycler-node:8.25
Container caasp/v4/salt-api:beta1
Container caasp/v4/salt-master:beta1
Container caasp/v4/salt-minion:beta1
Container caasp/v4/sidecar:beta1
Container caasp/v4/velum:4.0.0
Container suse/sles12sp3:12.16
  • libblkid1 >= 2.29.2-3.8.1
  • libfdisk1 >= 2.29.2-3.8.1
  • libmount1 >= 2.29.2-3.8.1
  • libsmartcols1 >= 2.29.2-3.8.1
  • libuuid1 >= 2.29.2-3.8.1
  • util-linux >= 2.29.2-3.8.1
Container caasp/v4/haproxy:beta1
  • libblkid1 >= 2.29.2-3.8.1
  • libfdisk1 >= 2.29.2-3.8.1
  • libmount1 >= 2.29.2-3.8.1
  • libsmartcols1 >= 2.29.2-3.8.1
  • libuuid1 >= 2.29.2-3.8.1
  • util-linux >= 2.29.2-3.8.1
  • util-linux-systemd >= 2.29.2-3.8.1
Container suse/sle15:15.0
  • libblkid1 >= 2.31.1-9.3.1
  • libfdisk1 >= 2.31.1-9.3.1
  • libmount1 >= 2.31.1-9.3.1
  • libsmartcols1 >= 2.31.1-9.3.1
  • libuuid1 >= 2.31.1-9.3.1
  • util-linux >= 2.31.1-9.3.1
Image SLES15-Azure-BYOS
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-EC2-HVM-BYOS
Image SLES15-GCE-BYOS
Image SLES15-OCI-BYOS
  • libblkid1 >= 2.31.1-9.3.1
  • libfdisk1 >= 2.31.1-9.3.1
  • libmount1 >= 2.31.1-9.3.1
  • libsmartcols1 >= 2.31.1-9.3.1
  • libuuid1 >= 2.31.1-9.3.1
  • util-linux >= 2.31.1-9.3.1
  • util-linux-systemd >= 2.31.1-9.3.1
Image SLES15-SAP-Azure
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SAP-EC2-HVM
Image SLES15-SAP-EC2-HVM-BYOS
Image SLES15-SAP-GCE
Image SLES15-SAP-GCE-BYOS
Image SLES15-SAP-OCI-BYOS
  • libblkid1 >= 2.31.1-9.3.1
  • libfdisk1 >= 2.31.1-9.3.1
  • libmount1 >= 2.31.1-9.3.1
  • libsmartcols1 >= 2.31.1-9.3.1
  • libuuid1 >= 2.31.1-9.3.1
  • util-linux >= 2.31.1-9.3.1
  • util-linux-systemd >= 2.31.1-9.3.1
  • uuidd >= 2.31.1-9.3.1
SUSE CaaS Platform 3.0
  • libblkid1 >= 2.29.2-3.12.1
  • libfdisk1 >= 2.29.2-3.12.1
  • libmount1 >= 2.29.2-3.12.1
  • libsmartcols1 >= 2.29.2-3.12.1
  • libuuid1 >= 2.29.2-3.12.1
  • util-linux >= 2.29.2-3.12.1
  • util-linux-systemd >= 2.29.2-3.12.1
Patchnames:
SUSE-CAASP-3.0-2018-1618
SUSE Enterprise Storage 4
  • libblkid1 >= 2.28-44.18.18
  • libblkid1-32bit >= 2.28-44.18.18
  • libfdisk1 >= 2.28-44.18.18
  • libmount1 >= 2.28-44.18.18
  • libmount1-32bit >= 2.28-44.18.18
  • libsmartcols1 >= 2.28-44.18.18
  • libuuid1 >= 2.28-44.18.18
  • libuuid1-32bit >= 2.28-44.18.18
  • python-libmount >= 2.28-44.18.38
  • util-linux >= 2.28-44.18.18
  • util-linux-lang >= 2.28-44.18.18
  • util-linux-systemd >= 2.28-44.18.25
  • uuidd >= 2.28-44.18.25
Patchnames:
SUSE-Storage-4-2019-390
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libblkid-devel >= 2.33.1-2.28
  • libblkid-devel-static >= 2.33.1-2.28
  • libblkid1 >= 2.33.1-2.28
  • libblkid1-32bit >= 2.33.1-2.28
  • libfdisk-devel >= 2.33.1-2.28
  • libfdisk1 >= 2.33.1-2.28
  • libmount-devel >= 2.33.1-2.28
  • libmount1 >= 2.33.1-2.28
  • libmount1-32bit >= 2.33.1-2.28
  • libsmartcols-devel >= 2.33.1-2.28
  • libsmartcols1 >= 2.33.1-2.28
  • libuuid-devel >= 2.33.1-2.28
  • libuuid-devel-static >= 2.33.1-2.28
  • libuuid1 >= 2.33.1-2.28
  • libuuid1-32bit >= 2.33.1-2.28
  • util-linux >= 2.33.1-2.28
  • util-linux-lang >= 2.33.1-2.28
  • util-linux-systemd >= 2.33.1-2.14
  • uuidd >= 2.33.1-2.14
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libblkid-devel-2.33.1-2.28
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA uuidd-2.33.1-2.14
SUSE Enterprise Storage 7
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libblkid-devel >= 2.33.1-4.5.1
  • libblkid-devel-static >= 2.33.1-4.5.1
  • libblkid1 >= 2.33.1-4.5.1
  • libblkid1-32bit >= 2.33.1-4.5.1
  • libfdisk-devel >= 2.33.1-4.5.1
  • libfdisk1 >= 2.33.1-4.5.1
  • libmount-devel >= 2.33.1-4.5.1
  • libmount1 >= 2.33.1-4.5.1
  • libmount1-32bit >= 2.33.1-4.5.1
  • libsmartcols-devel >= 2.33.1-4.5.1
  • libsmartcols1 >= 2.33.1-4.5.1
  • libuuid-devel >= 2.33.1-4.5.1
  • libuuid-devel-static >= 2.33.1-4.5.1
  • libuuid1 >= 2.33.1-4.5.1
  • libuuid1-32bit >= 2.33.1-4.5.1
  • util-linux >= 2.33.1-4.5.1
  • util-linux-lang >= 2.33.1-4.5.1
  • util-linux-systemd >= 2.33.1-4.5.1
  • uuidd >= 2.33.1-4.5.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libblkid-devel-2.33.1-4.5.1
SUSE Linux Enterprise Module for Server Applications 15 SP2 GA uuidd-2.33.1-4.5.1
SUSE Linux Enterprise Desktop 12 SP3
  • libblkid-devel >= 2.29.2-3.12.1
  • libblkid1 >= 2.29.2-3.12.1
  • libblkid1-32bit >= 2.29.2-3.12.1
  • libfdisk1 >= 2.29.2-3.12.1
  • libmount-devel >= 2.29.2-3.12.1
  • libmount1 >= 2.29.2-3.12.1
  • libmount1-32bit >= 2.29.2-3.12.1
  • libsmartcols-devel >= 2.29.2-3.12.1
  • libsmartcols1 >= 2.29.2-3.12.1
  • libuuid-devel >= 2.29.2-3.12.1
  • libuuid1 >= 2.29.2-3.12.1
  • libuuid1-32bit >= 2.29.2-3.12.1
  • python-libmount >= 2.29.2-3.12.1
  • util-linux >= 2.29.2-3.12.1
  • util-linux-lang >= 2.29.2-3.12.1
  • util-linux-systemd >= 2.29.2-3.12.1
  • uuidd >= 2.29.2-3.12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1400
SUSE-SLE-DESKTOP-12-SP3-2018-1618
SUSE-SLE-SDK-12-SP3-2018-1400
SUSE-SLE-SDK-12-SP3-2018-1618
SUSE-SLE-WE-12-SP3-2018-1400
SUSE-SLE-WE-12-SP3-2018-1618
SUSE Linux Enterprise Desktop 12 SP4
  • libblkid-devel >= 2.29.2-7.14
  • libblkid1 >= 2.29.2-7.14
  • libblkid1-32bit >= 2.29.2-7.14
  • libfdisk1 >= 2.29.2-7.14
  • libmount-devel >= 2.29.2-7.14
  • libmount1 >= 2.29.2-7.14
  • libmount1-32bit >= 2.29.2-7.14
  • libsmartcols-devel >= 2.29.2-7.14
  • libsmartcols1 >= 2.29.2-7.14
  • libuuid-devel >= 2.29.2-7.14
  • libuuid1 >= 2.29.2-7.14
  • libuuid1-32bit >= 2.29.2-7.14
  • python-libmount >= 2.29.2-7.7
  • util-linux >= 2.29.2-7.14
  • util-linux-lang >= 2.29.2-7.14
  • util-linux-systemd >= 2.29.2-7.7
  • uuidd >= 2.29.2-7.7
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libblkid1-2.29.2-7.14
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libblkid-devel-2.29.2-7.14
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libuuid-devel-2.29.2-7.14
SUSE Linux Enterprise Desktop 12 SP5
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libuuid-devel >= 2.33.2-2.13
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libuuid-devel-2.33.2-2.13
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libblkid-devel >= 2.33.1-2.28
  • libblkid-devel-static >= 2.33.1-2.28
  • libblkid1 >= 2.33.1-2.28
  • libblkid1-32bit >= 2.33.1-2.28
  • libfdisk-devel >= 2.33.1-2.28
  • libfdisk1 >= 2.33.1-2.28
  • libmount-devel >= 2.33.1-2.28
  • libmount1 >= 2.33.1-2.28
  • libmount1-32bit >= 2.33.1-2.28
  • libsmartcols-devel >= 2.33.1-2.28
  • libsmartcols1 >= 2.33.1-2.28
  • libuuid-devel >= 2.33.1-2.28
  • libuuid-devel-static >= 2.33.1-2.28
  • libuuid1 >= 2.33.1-2.28
  • libuuid1-32bit >= 2.33.1-2.28
  • util-linux >= 2.33.1-2.28
  • util-linux-lang >= 2.33.1-2.28
  • util-linux-systemd >= 2.33.1-2.14
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libblkid-devel-2.33.1-2.28
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libblkid-devel >= 2.33.1-4.5.1
  • libblkid-devel-static >= 2.33.1-4.5.1
  • libblkid1 >= 2.33.1-4.5.1
  • libblkid1-32bit >= 2.33.1-4.5.1
  • libfdisk-devel >= 2.33.1-4.5.1
  • libfdisk1 >= 2.33.1-4.5.1
  • libmount-devel >= 2.33.1-4.5.1
  • libmount1 >= 2.33.1-4.5.1
  • libmount1-32bit >= 2.33.1-4.5.1
  • libsmartcols-devel >= 2.33.1-4.5.1
  • libsmartcols1 >= 2.33.1-4.5.1
  • libuuid-devel >= 2.33.1-4.5.1
  • libuuid-devel-static >= 2.33.1-4.5.1
  • libuuid1 >= 2.33.1-4.5.1
  • libuuid1-32bit >= 2.33.1-4.5.1
  • util-linux >= 2.33.1-4.5.1
  • util-linux-lang >= 2.33.1-4.5.1
  • util-linux-systemd >= 2.33.1-4.5.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libblkid-devel-2.33.1-4.5.1
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise Module for Basesystem 15
  • libblkid-devel >= 2.31.1-9.3.1
  • libblkid-devel-static >= 2.31.1-9.3.1
  • libblkid1 >= 2.31.1-9.3.1
  • libblkid1-32bit >= 2.31.1-9.3.1
  • libfdisk-devel >= 2.31.1-9.3.1
  • libfdisk1 >= 2.31.1-9.3.1
  • libmount-devel >= 2.31.1-9.3.1
  • libmount1 >= 2.31.1-9.3.1
  • libmount1-32bit >= 2.31.1-9.3.1
  • libsmartcols-devel >= 2.31.1-9.3.1
  • libsmartcols1 >= 2.31.1-9.3.1
  • libuuid-devel >= 2.31.1-9.3.1
  • libuuid-devel-static >= 2.31.1-9.3.1
  • libuuid1 >= 2.31.1-9.3.1
  • libuuid1-32bit >= 2.31.1-9.3.1
  • util-linux >= 2.31.1-9.3.1
  • util-linux-lang >= 2.31.1-9.3.1
  • util-linux-systemd >= 2.31.1-9.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1397
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libblkid1 >= 2.33.2-2.13
  • libblkid1-32bit >= 2.33.2-2.13
  • libfdisk1 >= 2.33.2-2.13
  • libmount1 >= 2.33.2-2.13
  • libmount1-32bit >= 2.33.2-2.13
  • libsmartcols1 >= 2.33.2-2.13
  • libuuid1 >= 2.33.2-2.13
  • libuuid1-32bit >= 2.33.2-2.13
  • python-libmount >= 2.33.2-2.9
  • util-linux >= 2.33.2-2.13
  • util-linux-lang >= 2.33.2-2.13
  • util-linux-systemd >= 2.33.2-2.10
  • uuidd >= 2.33.2-2.10
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libblkid1-2.33.2-2.13
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libblkid-devel >= 2.31.1-9.3.1
  • libblkid-devel-static >= 2.31.1-9.3.1
  • libblkid1 >= 2.31.1-9.3.1
  • libblkid1-32bit >= 2.31.1-9.3.1
  • libfdisk-devel >= 2.31.1-9.3.1
  • libfdisk1 >= 2.31.1-9.3.1
  • libmount-devel >= 2.31.1-9.3.1
  • libmount1 >= 2.31.1-9.3.1
  • libmount1-32bit >= 2.31.1-9.3.1
  • libsmartcols-devel >= 2.31.1-9.3.1
  • libsmartcols1 >= 2.31.1-9.3.1
  • libuuid-devel >= 2.31.1-9.3.1
  • libuuid-devel-static >= 2.31.1-9.3.1
  • libuuid1 >= 2.31.1-9.3.1
  • libuuid1-32bit >= 2.31.1-9.3.1
  • util-linux >= 2.31.1-9.3.1
  • util-linux-lang >= 2.31.1-9.3.1
  • util-linux-systemd >= 2.31.1-9.3.1
  • uuidd >= 2.31.1-9.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1397
SUSE-SLE-Module-Server-Applications-15-2018-1397
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • uuidd >= 2.33.1-2.14
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA uuidd-2.33.1-2.14
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • uuidd >= 2.33.1-4.5.1
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP2 GA uuidd-2.33.1-4.5.1
SUSE Linux Enterprise Module for Server Applications 15
  • uuidd >= 2.31.1-9.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2018-1397
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libblkid1 >= 2.28-44.18.18
  • libblkid1-32bit >= 2.28-44.18.18
  • libfdisk1 >= 2.28-44.18.18
  • libmount1 >= 2.28-44.18.18
  • libmount1-32bit >= 2.28-44.18.18
  • libsmartcols1 >= 2.28-44.18.18
  • libuuid1 >= 2.28-44.18.18
  • libuuid1-32bit >= 2.28-44.18.18
  • python-libmount >= 2.28-44.18.38
  • util-linux >= 2.28-44.18.18
  • util-linux-lang >= 2.28-44.18.18
  • util-linux-systemd >= 2.28-44.18.25
  • uuidd >= 2.28-44.18.25
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-390
SUSE Linux Enterprise Server 12 SP2-BCL
  • libblkid1 >= 2.28-44.18.18
  • libblkid1-32bit >= 2.28-44.18.18
  • libfdisk1 >= 2.28-44.18.18
  • libmount1 >= 2.28-44.18.18
  • libmount1-32bit >= 2.28-44.18.18
  • libsmartcols1 >= 2.28-44.18.18
  • libuuid1 >= 2.28-44.18.18
  • libuuid1-32bit >= 2.28-44.18.18
  • python-libmount >= 2.28-44.18.38
  • util-linux >= 2.28-44.18.18
  • util-linux-lang >= 2.28-44.18.18
  • util-linux-systemd >= 2.28-44.18.25
  • uuidd >= 2.28-44.18.25
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-390
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libblkid1 >= 2.28-44.18.18
  • libblkid1-32bit >= 2.28-44.18.18
  • libfdisk1 >= 2.28-44.18.18
  • libmount1 >= 2.28-44.18.18
  • libmount1-32bit >= 2.28-44.18.18
  • libsmartcols1 >= 2.28-44.18.18
  • libuuid1 >= 2.28-44.18.18
  • libuuid1-32bit >= 2.28-44.18.18
  • python-libmount >= 2.28-44.18.38
  • util-linux >= 2.28-44.18.18
  • util-linux-lang >= 2.28-44.18.18
  • util-linux-systemd >= 2.28-44.18.25
  • uuidd >= 2.28-44.18.25
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-390
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libblkid-devel >= 2.29.2-3.12.1
  • libblkid1 >= 2.29.2-3.12.1
  • libblkid1-32bit >= 2.29.2-3.12.1
  • libfdisk1 >= 2.29.2-3.12.1
  • libmount-devel >= 2.29.2-3.12.1
  • libmount1 >= 2.29.2-3.12.1
  • libmount1-32bit >= 2.29.2-3.12.1
  • libsmartcols-devel >= 2.29.2-3.12.1
  • libsmartcols1 >= 2.29.2-3.12.1
  • libuuid-devel >= 2.29.2-3.12.1
  • libuuid1 >= 2.29.2-3.12.1
  • libuuid1-32bit >= 2.29.2-3.12.1
  • python-libmount >= 2.29.2-3.12.1
  • util-linux >= 2.29.2-3.12.1
  • util-linux-lang >= 2.29.2-3.12.1
  • util-linux-systemd >= 2.29.2-3.12.1
  • uuidd >= 2.29.2-3.12.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1400
SUSE-SLE-SDK-12-SP3-2018-1618
SUSE-SLE-SERVER-12-SP3-2018-1400
SUSE-SLE-SERVER-12-SP3-2018-1618
SUSE-SLE-WE-12-SP3-2018-1400
SUSE-SLE-WE-12-SP3-2018-1618
SUSE Linux Enterprise Server 12 SP4
  • libblkid-devel >= 2.29.2-7.14
  • libblkid1 >= 2.29.2-7.14
  • libblkid1-32bit >= 2.29.2-7.14
  • libfdisk1 >= 2.29.2-7.14
  • libmount-devel >= 2.29.2-7.14
  • libmount1 >= 2.29.2-7.14
  • libmount1-32bit >= 2.29.2-7.14
  • libsmartcols-devel >= 2.29.2-7.14
  • libsmartcols1 >= 2.29.2-7.14
  • libuuid-devel >= 2.29.2-7.14
  • libuuid1 >= 2.29.2-7.14
  • libuuid1-32bit >= 2.29.2-7.14
  • python-libmount >= 2.29.2-7.7
  • util-linux >= 2.29.2-7.14
  • util-linux-lang >= 2.29.2-7.14
  • util-linux-systemd >= 2.29.2-7.7
  • uuidd >= 2.29.2-7.7
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libblkid1-2.29.2-7.14
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libblkid-devel-2.29.2-7.14
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libuuid-devel-2.29.2-7.14
SUSE Linux Enterprise Server 12 SP5
  • libblkid-devel >= 2.33.2-2.13
  • libblkid1 >= 2.33.2-2.13
  • libblkid1-32bit >= 2.33.2-2.13
  • libfdisk1 >= 2.33.2-2.13
  • libmount-devel >= 2.33.2-2.13
  • libmount1 >= 2.33.2-2.13
  • libmount1-32bit >= 2.33.2-2.13
  • libsmartcols-devel >= 2.33.2-2.13
  • libsmartcols1 >= 2.33.2-2.13
  • libuuid-devel >= 2.33.2-2.13
  • libuuid1 >= 2.33.2-2.13
  • libuuid1-32bit >= 2.33.2-2.13
  • python-libmount >= 2.33.2-2.9
  • util-linux >= 2.33.2-2.13
  • util-linux-lang >= 2.33.2-2.13
  • util-linux-systemd >= 2.33.2-2.10
  • uuidd >= 2.33.2-2.10
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libblkid1-2.33.2-2.13
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libblkid-devel-2.33.2-2.13
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libuuid-devel-2.33.2-2.13
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libblkid1 >= 2.28-44.18.18
  • libblkid1-32bit >= 2.28-44.18.18
  • libfdisk1 >= 2.28-44.18.18
  • libmount1 >= 2.28-44.18.18
  • libmount1-32bit >= 2.28-44.18.18
  • libsmartcols1 >= 2.28-44.18.18
  • libuuid1 >= 2.28-44.18.18
  • libuuid1-32bit >= 2.28-44.18.18
  • python-libmount >= 2.28-44.18.38
  • util-linux >= 2.28-44.18.18
  • util-linux-lang >= 2.28-44.18.18
  • util-linux-systemd >= 2.28-44.18.25
  • uuidd >= 2.28-44.18.25
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-390
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libblkid-devel >= 2.29.2-7.14
  • libmount-devel >= 2.29.2-7.14
  • libsmartcols-devel >= 2.29.2-7.14
  • libuuid-devel >= 2.29.2-7.14
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libblkid-devel-2.29.2-7.14
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libuuid-devel-2.29.2-7.14
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libblkid-devel >= 2.33.2-2.13
  • libmount-devel >= 2.33.2-2.13
  • libsmartcols-devel >= 2.33.2-2.13
  • libuuid-devel >= 2.33.2-2.13
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libblkid-devel-2.33.2-2.13
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libuuid-devel-2.33.2-2.13
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libblkid-devel >= 2.29.2-3.12.1
  • libmount-devel >= 2.29.2-3.12.1
  • libsmartcols-devel >= 2.29.2-3.12.1
  • libuuid-devel >= 2.29.2-3.12.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1400
SUSE-SLE-SDK-12-SP3-2018-1618
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libblkid-devel >= 2.29.2-7.14
  • libmount-devel >= 2.29.2-7.14
  • libsmartcols-devel >= 2.29.2-7.14
  • libuuid-devel >= 2.29.2-7.14
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libblkid-devel-2.29.2-7.14
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libblkid-devel >= 2.33.2-2.13
  • libmount-devel >= 2.33.2-2.13
  • libsmartcols-devel >= 2.33.2-2.13
  • libuuid-devel >= 2.33.2-2.13
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libblkid-devel-2.33.2-2.13
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libuuid-devel >= 2.29.2-3.12.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-1400
SUSE-SLE-WE-12-SP3-2018-1618
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libuuid-devel >= 2.29.2-7.14
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libuuid-devel-2.29.2-7.14
SUSE OpenStack Cloud 7
  • libblkid1 >= 2.28-44.18.18
  • libblkid1-32bit >= 2.28-44.18.18
  • libfdisk1 >= 2.28-44.18.18
  • libmount1 >= 2.28-44.18.18
  • libmount1-32bit >= 2.28-44.18.18
  • libsmartcols1 >= 2.28-44.18.18
  • libuuid1 >= 2.28-44.18.18
  • libuuid1-32bit >= 2.28-44.18.18
  • python-libmount >= 2.28-44.18.38
  • util-linux >= 2.28-44.18.18
  • util-linux-lang >= 2.28-44.18.18
  • util-linux-systemd >= 2.28-44.18.25
  • uuidd >= 2.28-44.18.25
Patchnames:
SUSE-OpenStack-Cloud-7-2019-390
openSUSE Leap 15.0
  • libblkid-devel >= 2.31.1-lp150.7.6.1
  • libblkid-devel-32bit >= 2.31.1-lp150.7.6.1
  • libblkid-devel-static >= 2.31.1-lp150.7.6.1
  • libblkid1 >= 2.31.1-lp150.7.6.1
  • libblkid1-32bit >= 2.31.1-lp150.7.6.1
  • libfdisk-devel >= 2.31.1-lp150.7.6.1
  • libfdisk-devel-static >= 2.31.1-lp150.7.6.1
  • libfdisk1 >= 2.31.1-lp150.7.6.1
  • libmount-devel >= 2.31.1-lp150.7.6.1
  • libmount-devel-32bit >= 2.31.1-lp150.7.6.1
  • libmount-devel-static >= 2.31.1-lp150.7.6.1
  • libmount1 >= 2.31.1-lp150.7.6.1
  • libmount1-32bit >= 2.31.1-lp150.7.6.1
  • libsmartcols-devel >= 2.31.1-lp150.7.6.1
  • libsmartcols-devel-static >= 2.31.1-lp150.7.6.1
  • libsmartcols1 >= 2.31.1-lp150.7.6.1
  • libuuid-devel >= 2.31.1-lp150.7.6.1
  • libuuid-devel-32bit >= 2.31.1-lp150.7.6.1
  • libuuid-devel-static >= 2.31.1-lp150.7.6.1
  • libuuid1 >= 2.31.1-lp150.7.6.1
  • libuuid1-32bit >= 2.31.1-lp150.7.6.1
  • python-libmount >= 2.31.1-lp150.7.6.1
  • util-linux >= 2.31.1-lp150.7.6.1
  • util-linux-lang >= 2.31.1-lp150.7.6.1
  • util-linux-systemd >= 2.31.1-lp150.7.6.1
  • uuidd >= 2.31.1-lp150.7.6.1
Patchnames:
openSUSE-2019-565
openSUSE Leap 15.2
  • libblkid1 >= 2.33.1-lp152.4.78
  • libblkid1-32bit >= 2.33.1-lp152.4.78
  • libfdisk1 >= 2.33.1-lp152.4.78
  • libmount1 >= 2.33.1-lp152.4.78
  • libmount1-32bit >= 2.33.1-lp152.4.78
  • libsmartcols1 >= 2.33.1-lp152.4.78
  • libuuid1 >= 2.33.1-lp152.4.78
  • libuuid1-32bit >= 2.33.1-lp152.4.78
  • util-linux >= 2.33.1-lp152.4.78
  • util-linux-lang >= 2.33.1-lp152.4.78
  • util-linux-systemd >= 2.33.1-lp152.4.78
Patchnames:
openSUSE Leap 15.2 GA libblkid1-2.33.1-lp152.4.30


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 python-libmount Affected
HPE Helion OpenStack 8 util-linux In progress
HPE Helion OpenStack 8 util-linux-systemd Affected
Magnum Orchestration util-linux Released
SLES15-EC2-CHOST-HVM-BYOS util-linux Released
SLES15-SP1-CHOST-BYOS-Azure util-linux Already fixed
SLES15-SP1-CHOST-BYOS-EC2 util-linux Already fixed
SLES15-SP1-CHOST-BYOS-GCE util-linux Already fixed
SLES15-SP2-CHOST-BYOS-Aliyun util-linux Already fixed
SLES15-SP2-CHOST-BYOS-Azure util-linux Already fixed
SLES15-SP2-CHOST-BYOS-EC2 util-linux Already fixed
SLES15-SP2-CHOST-BYOS-GCE util-linux Already fixed
SUSE CaaS Platform 3.0 util-linux Released
SUSE CaaS Platform 3.0 util-linux-systemd Released
SUSE CaaS Platform 4.0 util-linux Already fixed
SUSE Container as a Service Platform 1.0 util-linux Released
SUSE Container as a Service Platform 2.0 util-linux Released
SUSE Enterprise Storage 4 python-libmount Released
SUSE Enterprise Storage 4 util-linux Released
SUSE Enterprise Storage 4 util-linux-systemd Released
SUSE Enterprise Storage 6 util-linux Already fixed
SUSE Enterprise Storage 7 util-linux Already fixed
SUSE Linux Enterprise Desktop 11 SP4 util-linux Not affected
SUSE Linux Enterprise Desktop 12 util-linux Unsupported
SUSE Linux Enterprise Desktop 12 SP1 util-linux Not affected
SUSE Linux Enterprise Desktop 12 SP2 util-linux Affected
SUSE Linux Enterprise Desktop 12 SP3 python-libmount Released
SUSE Linux Enterprise Desktop 12 SP3 util-linux Released
SUSE Linux Enterprise Desktop 12 SP3 util-linux-systemd Released
SUSE Linux Enterprise Desktop 12 SP5 util-linux Already fixed
SUSE Linux Enterprise Desktop 15 util-linux Released
SUSE Linux Enterprise Desktop 15 util-linux-systemd Released
SUSE Linux Enterprise Desktop 15 SP1 util-linux Already fixed
SUSE Linux Enterprise Desktop 15 SP2 util-linux Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 util-linux Already fixed
SUSE Linux Enterprise High Performance Computing 15 util-linux Released
SUSE Linux Enterprise High Performance Computing 15 util-linux-systemd Released
SUSE Linux Enterprise High Performance Computing 15 SP1 util-linux Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS util-linux Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS util-linux Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 util-linux Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS util-linux Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS util-linux Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS util-linux Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS util-linux In progress
SUSE Linux Enterprise Micro 5.0 util-linux Already fixed
SUSE Linux Enterprise Module for Basesystem 15 util-linux Released
SUSE Linux Enterprise Module for Basesystem 15 util-linux-systemd Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 util-linux Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 util-linux Already fixed
SUSE Linux Enterprise Module for Server Applications 15 util-linux-systemd Released
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT python-libmount Released
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT util-linux Released
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT util-linux-systemd Released
SUSE Linux Enterprise Real Time 15 SP2 util-linux Already fixed
SUSE Linux Enterprise Server 11 SP3 util-linux Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS util-linux Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS util-linux Not affected
SUSE Linux Enterprise Server 11 SP4 util-linux Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS util-linux Not affected
SUSE Linux Enterprise Server 12 util-linux Unsupported
SUSE Linux Enterprise Server 12 SP1 util-linux Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS util-linux Not affected
SUSE Linux Enterprise Server 12 SP2 util-linux Unsupported
SUSE Linux Enterprise Server 12 SP2-BCL python-libmount Released
SUSE Linux Enterprise Server 12 SP2-BCL util-linux Released
SUSE Linux Enterprise Server 12 SP2-BCL util-linux-systemd Released
SUSE Linux Enterprise Server 12 SP2-ESPOS util-linux Affected
SUSE Linux Enterprise Server 12 SP2-LTSS python-libmount Released
SUSE Linux Enterprise Server 12 SP2-LTSS util-linux Released
SUSE Linux Enterprise Server 12 SP2-LTSS util-linux-systemd Released
SUSE Linux Enterprise Server 12 SP3 python-libmount Released
SUSE Linux Enterprise Server 12 SP3 util-linux Released
SUSE Linux Enterprise Server 12 SP3 util-linux-systemd Released
SUSE Linux Enterprise Server 12 SP3-BCL python-libmount Affected
SUSE Linux Enterprise Server 12 SP3-BCL util-linux In progress
SUSE Linux Enterprise Server 12 SP3-BCL util-linux-systemd Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS python-libmount Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS util-linux In progress
SUSE Linux Enterprise Server 12 SP3-ESPOS util-linux-systemd Affected
SUSE Linux Enterprise Server 12 SP3-LTSS python-libmount Affected
SUSE Linux Enterprise Server 12 SP3-LTSS util-linux In progress
SUSE Linux Enterprise Server 12 SP3-LTSS util-linux-systemd Affected
SUSE Linux Enterprise Server 12 SP5 util-linux Already fixed
SUSE Linux Enterprise Server 12-LTSS util-linux Unsupported
SUSE Linux Enterprise Server 15 util-linux Released
SUSE Linux Enterprise Server 15 util-linux-systemd Released
SUSE Linux Enterprise Server 15 SP1 util-linux Already fixed
SUSE Linux Enterprise Server 15 SP1-BCL util-linux Already fixed
SUSE Linux Enterprise Server 15 SP1-LTSS util-linux Already fixed
SUSE Linux Enterprise Server 15 SP2 util-linux Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL util-linux Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS util-linux Already fixed
SUSE Linux Enterprise Server 15-ESPOS util-linux In progress
SUSE Linux Enterprise Server 15-LTSS util-linux In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 util-linux Already fixed
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 util-linux Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 util-linux Not affected
SUSE Linux Enterprise Server for SAP Applications 12 util-linux Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP1 util-linux Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 python-libmount Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 util-linux Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 util-linux-systemd Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python-libmount Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 util-linux Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 util-linux-systemd Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 util-linux Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 util-linux Released
SUSE Linux Enterprise Server for SAP Applications 15 util-linux-systemd Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 util-linux Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 util-linux Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP4 util-linux Not affected
SUSE Linux Enterprise Software Development Kit 12 util-linux Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP1 util-linux Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 util-linux Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 util-linux Released
SUSE Linux Enterprise Software Development Kit 12 SP5 util-linux Already fixed
SUSE Linux Enterprise Workstation Extension 12 util-linux Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP1 util-linux Not affected
SUSE Linux Enterprise Workstation Extension 12 SP2 util-linux Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP3 util-linux Released
SUSE Linux Enterprise Workstation Extension 12 SP5 util-linux Already fixed
SUSE Manager Proxy 4.0 util-linux Already fixed
SUSE Manager Proxy 4.1 util-linux Already fixed
SUSE Manager Retail Branch Server 4.0 util-linux Already fixed
SUSE Manager Retail Branch Server 4.1 util-linux Already fixed
SUSE Manager Server 4.0 util-linux Already fixed
SUSE Manager Server 4.1 util-linux Already fixed
SUSE OpenStack Cloud 7 python-libmount Released
SUSE OpenStack Cloud 7 util-linux Released
SUSE OpenStack Cloud 7 util-linux-systemd Released
SUSE OpenStack Cloud 8 python-libmount Affected
SUSE OpenStack Cloud 8 util-linux In progress
SUSE OpenStack Cloud 8 util-linux-systemd Affected
SUSE OpenStack Cloud Crowbar 8 python-libmount Affected
SUSE OpenStack Cloud Crowbar 8 util-linux In progress
SUSE OpenStack Cloud Crowbar 8 util-linux-systemd Affected
SUSE Studio Onsite 1.3 util-linux Not affected
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/ceph/prometheus-alertmanager
ses/7/ceph/prometheus-node-exporter
ses/7/ceph/prometheus-server
ses/7/cephcsi/cephcsi
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-attacher:v3.3.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-node-driver-registrar:v2.3.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-provisioner:v3.0.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-resizer:v1.3.0
ses/7/cephcsi/csi-snapshotter:v2.1.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/cephcsi/csi-snapshotter:v4.2.0
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
suse/sle-micro/5.0/toolbox
suse/sle15:15.1
suse/sle15:15.2
suse/sles/15.2/virt-api:0.38.1
suse/sles/15.2/virt-controller:0.38.1
suse/sles/15.2/virt-handler:0.38.1
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.2/virt-operator:0.38.1
suse/sles12sp5
util-linuxAlready fixed
suse/sle15:15.0
suse/sles12sp3
util-linuxReleased


SUSE Timeline for this CVE

CVE page created: Wed Mar 7 07:35:17 2018
CVE page last modified: Mon Nov 28 14:05:59 2022