Upstream information

CVE-2018-7548 at MITRE

Description

In subst.c in zsh through 5.4.2, there is a NULL pointer dereference when using ${(PA)...} on an empty array result.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1082981 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 zsh Not affected
SUSE CaaS Platform 4.0 zsh Not affected
SUSE Enterprise Storage 6 zsh Not affected
SUSE Linux Enterprise Desktop 12 SP2 zsh Affected
SUSE Linux Enterprise Desktop 12 SP3 zsh Not affected
SUSE Linux Enterprise Desktop 15 SP2 zsh Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 zsh Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 zsh Not affected
SUSE Linux Enterprise Point of Service 11 SP3 zsh Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS zsh Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS zsh Not affected
SUSE Linux Enterprise Server 12 LTSS zsh Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS zsh Not affected
SUSE Linux Enterprise Server 12 SP2 zsh Not affected
SUSE Linux Enterprise Server 12 SP2 BCL zsh Not affected
SUSE Linux Enterprise Server 12 SP3 zsh Not affected
SUSE Linux Enterprise Server 12 SP3 BCL zsh Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS zsh Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS zsh Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS zsh Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS zsh Not affected
SUSE Linux Enterprise Server 12 SP5 zsh Not affected
SUSE Linux Enterprise Server 15 ESPOS zsh Not affected
SUSE Linux Enterprise Server 15 LTSS zsh Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS zsh Not affected
SUSE Linux Enterprise Server 15 SP2 zsh Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 15 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 zsh Not affected
SUSE Linux Enterprise Storage 7 zsh Not affected
SUSE Manager Proxy 4.0 zsh Not affected
SUSE Manager Proxy 4.1 zsh Not affected
SUSE Manager Retail Branch Server 4.0 zsh Not affected
SUSE Manager Retail Branch Server 4.1 zsh Not affected
SUSE Manager Server 4.0 zsh Not affected
SUSE Manager Server 4.1 zsh Not affected
SUSE OpenStack Cloud 8 zsh Not affected
SUSE OpenStack Cloud 9 zsh Not affected
SUSE OpenStack Cloud Crowbar 8 zsh Not affected
SUSE OpenStack Cloud Crowbar 9 zsh Not affected