Upstream information

CVE-2018-7262 at MITRE

Description

In Ceph before 12.2.3 and 13.x through 13.0.1, the rgw_civetweb.cc RGWCivetWeb::init_env function in radosgw doesn't handle malformed HTTP headers properly, allowing for denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1081379 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform ALL
  • ceph-common >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libcephfs2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librados2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libradosstriper1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librbd1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librgw2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rados >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
Patchnames:
SUSE-CAASP-ALL-2018-980
SUSE Enterprise Storage 4
  • ceph >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • ceph-base >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • ceph-common >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • ceph-fuse >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • ceph-mds >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • ceph-mon >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • ceph-osd >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • ceph-radosgw >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • ceph-test >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • libcephfs1 >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • librados2 >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • libradosstriper1 >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • librbd1 >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • librgw2 >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • python-ceph-compat >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • python-cephfs >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • python-rados >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • python-rbd >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • rbd-fuse >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • rbd-mirror >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
  • rbd-nbd >= 10.2.11+git.1531487710.3a12911a2e-12.14.2
Patchnames:
SUSE-Storage-4-2018-1537
SUSE Enterprise Storage 5
  • ceph >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • ceph-base >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • ceph-common >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • ceph-fuse >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • ceph-mds >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • ceph-mgr >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • ceph-mon >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • ceph-osd >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • ceph-radosgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • libcephfs2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • librados2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • libradosstriper1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • librbd1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • librgw2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python-ceph-compat >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python-rados >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python3-ceph-argparse >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python3-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python3-rados >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python3-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • python3-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • rbd-fuse >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • rbd-mirror >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
  • rbd-nbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.13.3
Patchnames:
SUSE-Storage-5-2018-1092
SUSE Linux Enterprise Desktop 12 SP3
  • ceph-common >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libcephfs2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librados2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libradosstriper1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librbd1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librgw2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rados >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-980
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
  • ceph-common >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • libcephfs2 >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • librados2 >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • libradosstriper1 >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • librbd1 >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • librgw2 >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • python-cephfs >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • python-rados >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • python-rbd >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • python-rgw >= 12.2.8+git.1536505967.080f2248ff-2.15.1
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • ceph-common >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • libcephfs2 >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • librados2 >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • libradosstriper1 >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • librbd1 >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • librgw2 >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • python-cephfs >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • python-rados >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • python-rbd >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • python-rgw >= 12.2.12+git.1568024032.02236657ca-2.39.1
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ceph-common >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libcephfs2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librados2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libradosstriper1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librbd1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librgw2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rados >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-980
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcephfs-devel >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librados-devel >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librbd-devel >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-980
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libcephfs-devel >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • librados-devel >= 12.2.8+git.1536505967.080f2248ff-2.15.1
  • librbd-devel >= 12.2.8+git.1536505967.080f2248ff-2.15.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libcephfs-devel >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • librados-devel >= 12.2.12+git.1568024032.02236657ca-2.39.1
  • librbd-devel >= 12.2.12+git.1568024032.02236657ca-2.39.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 ceph Released
SUSE Container as a Service Platform 2.0 ceph Released
SUSE Enterprise Storage 3 ceph Unsupported
SUSE Enterprise Storage 4 ceph Released
SUSE Enterprise Storage 5 ceph Released
SUSE Linux Enterprise Desktop 12 SP2 ceph Unsupported
SUSE Linux Enterprise Desktop 12 SP3 ceph Released
SUSE Linux Enterprise High Performance Computing 12 SP5 ceph Released
SUSE Linux Enterprise Server 11 SP3 LTSS ceph Not affected
SUSE Linux Enterprise Server 11 SP4 ceph Not affected
SUSE Linux Enterprise Server 12 SP2 ceph Unsupported
SUSE Linux Enterprise Server 12 SP3 ceph Released
SUSE Linux Enterprise Server 12 SP3 BCL ceph Released
SUSE Linux Enterprise Server 12 SP3 ESPOS ceph Released
SUSE Linux Enterprise Server 12 SP3 LTSS ceph Released
SUSE Linux Enterprise Server 12 SP4 ESPOS ceph Released
SUSE Linux Enterprise Server 12 SP4 LTSS ceph Released
SUSE Linux Enterprise Server 12 SP5 ceph Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ceph Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ceph Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ceph Released
SUSE Linux Enterprise Software Development Kit 11 SP4 ceph Not affected
SUSE Linux Enterprise Software Development Kit 12 ceph Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 ceph Released
SUSE Linux Enterprise Software Development Kit 12 SP5 ceph Released
SUSE OpenStack Cloud 8 ceph Released
SUSE OpenStack Cloud 9 ceph Released
SUSE OpenStack Cloud Crowbar 8 ceph Released
SUSE OpenStack Cloud Crowbar 9 ceph Released