Upstream information

CVE-2018-6767 at MITRE

Description

A stack-based buffer over-read in the ParseRiffHeaderConfig function of cli/riff.c file of WavPack 5.1.0 allows a remote attacker to cause a denial-of-service attack or possibly have unspecified other impact via a maliciously crafted RF64 file.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1079746 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-186
SUSE Enterprise Storage 6
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-Storage-6-2021-186
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-186
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-186
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libwavpack1 >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-186
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libwavpack1 >= 5.1.0-4.3.5
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libwavpack1 >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-186
SUSE Linux Enterprise Module for Basesystem 15
  • libwavpack1 >= 5.1.0-2.17
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • wavpack >= 5.1.0-4.3.5
  • wavpack-devel >= 5.1.0-4.3.5
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-186
SUSE Linux Enterprise Module for Desktop Applications 15
  • wavpack >= 5.1.0-2.17
  • wavpack-devel >= 5.1.0-2.17
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • libwavpack1-32bit >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-186
SUSE Linux Enterprise Server 15 SP1-BCL
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-186
SUSE Linux Enterprise Server 15 SP1-LTSS
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-186
SUSE Linux Enterprise Server 15-LTSS
  • libwavpack1 >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-186
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-186
SUSE Linux Enterprise Server for SAP Applications 15
  • libwavpack1 >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-186
SUSE Manager Proxy 4.0
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-186
SUSE Manager Retail Branch Server 4.0
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-186
SUSE Manager Server 4.0
  • libwavpack1 >= 5.4.0-4.9.1
  • wavpack >= 5.4.0-4.9.1
  • wavpack-devel >= 5.4.0-4.9.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-186
openSUSE Leap 15.0
  • libwavpack1 >= 5.1.0-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libwavpack1
openSUSE Leap 15.1
  • libwavpack1 >= 5.4.0-lp151.5.6.1
  • libwavpack1-32bit >= 5.4.0-lp151.5.6.1
  • libwavpack1-32bit-debuginfo >= 5.4.0-lp151.5.6.1
  • libwavpack1-debuginfo >= 5.4.0-lp151.5.6.1
  • wavpack >= 5.4.0-lp151.5.6.1
  • wavpack-debuginfo >= 5.4.0-lp151.5.6.1
  • wavpack-debugsource >= 5.4.0-lp151.5.6.1
  • wavpack-devel >= 5.4.0-lp151.5.6.1
Patchnames:
openSUSE-2021-154
openSUSE Leap 15.2
  • libwavpack1 >= 5.4.0-lp152.7.3.1
  • libwavpack1-32bit >= 5.4.0-lp152.7.3.1
  • libwavpack1-32bit-debuginfo >= 5.4.0-lp152.7.3.1
  • libwavpack1-debuginfo >= 5.4.0-lp152.7.3.1
  • wavpack >= 5.4.0-lp152.7.3.1
  • wavpack-debuginfo >= 5.4.0-lp152.7.3.1
  • wavpack-debugsource >= 5.4.0-lp152.7.3.1
  • wavpack-devel >= 5.4.0-lp152.7.3.1
Patchnames:
openSUSE-2021-153


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications wavpack Analysis
SUSE CaaS Platform 4.0 wavpack Released
SUSE Enterprise Storage 6 wavpack Released
SUSE Linux Enterprise Desktop 12 wavpack Analysis
SUSE Linux Enterprise Desktop 12 SP2 wavpack Affected
SUSE Linux Enterprise Desktop 12 SP3 wavpack Analysis
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search wavpack Analysis
SUSE Linux Enterprise High Performance Computing 15 LTSS wavpack Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS wavpack Released
SUSE Linux Enterprise Module for Basesystem 15 wavpack Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP1 wavpack Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 wavpack Released
SUSE Linux Enterprise Module for Desktop Applications 15 wavpack Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 wavpack Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 wavpack Released
SUSE Linux Enterprise Server 11 SP1 wavpack Analysis
SUSE Linux Enterprise Server 11 SP1 LTSS wavpack Analysis
SUSE Linux Enterprise Server 11 SP2 wavpack Analysis
SUSE Linux Enterprise Server 11 SP2 LTSS wavpack Analysis
SUSE Linux Enterprise Server 11 SP3 wavpack Analysis
SUSE Linux Enterprise Server 11 SP3 LTSS wavpack Analysis
SUSE Linux Enterprise Server 11 SP4 wavpack Analysis
SUSE Linux Enterprise Server 12 LTSS wavpack Analysis
SUSE Linux Enterprise Server 12 SP1 LTSS wavpack Analysis
SUSE Linux Enterprise Server 12 SP2 wavpack Analysis
SUSE Linux Enterprise Server 12 SP2 LTSS wavpack Analysis
SUSE Linux Enterprise Server 12 SP3 wavpack Analysis
SUSE Linux Enterprise Server 15 LTSS wavpack Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux wavpack Released
SUSE Linux Enterprise Server 15 SP1 LTSS wavpack Released
SUSE Linux Enterprise Server ESPOS 15 wavpack Released
SUSE Linux Enterprise Server for SAP Applications 15 wavpack Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 wavpack Released
SUSE Linux Enterprise Server for SAP Business All-in-One wavpack Analysis
SUSE Linux Enterprise Server for the Raspberry Pi wavpack Analysis
SUSE Linux Enterprise Software Development Kit 11 SP4 wavpack Analysis
SUSE Linux Enterprise Software Development Kit 12 wavpack Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 wavpack Not affected
SUSE Manager Proxy 4.0 wavpack Released
SUSE Manager Retail Branch Server 4.0 wavpack Released
SUSE Manager Server 4.0 wavpack Released