Upstream information

CVE-2018-5729 at MITRE

Description

MIT krb5 1.6 or later allows an authenticated kadmin with permission to add principals to an LDAP Kerberos database to cause a denial of service (NULL pointer dereference) or bypass a DN container check by supplying tagged data that is internal to the database module.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.7 7.2
Vector AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required High High
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low High
Integrity Impact Low High
Availability Impact Low High
SUSE Bugzilla entry: 1083926 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • krb5 >= 1.12.5-40.23.2
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-567
SUSE CaaS Platform ALL
  • krb5 >= 1.12.5-40.23.2
Patchnames:
SUSE-CAASP-ALL-2018-567
SUSE Linux Enterprise Build System Kit 12 SP2
  • krb5-mini >= 1.12.5-40.23.1
  • krb5-mini-devel >= 1.12.5-40.23.1
Patchnames:
SUSE-SLE-BSK-12-SP2-2018-567
SUSE Linux Enterprise Build System Kit 12 SP3
  • krb5-mini >= 1.12.5-40.23.1
  • krb5-mini-devel >= 1.12.5-40.23.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2018-567
SUSE Linux Enterprise Desktop 12 SP2
  • krb5 >= 1.12.5-40.23.2
  • krb5-32bit >= 1.12.5-40.23.2
  • krb5-client >= 1.12.5-40.23.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-567
SUSE Linux Enterprise Desktop 12 SP3
  • krb5 >= 1.12.5-40.23.2
  • krb5-32bit >= 1.12.5-40.23.2
  • krb5-client >= 1.12.5-40.23.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-567
SUSE Linux Enterprise Server 11 SP4
  • krb5 >= 1.6.3-133.49.113.7.1
  • krb5-32bit >= 1.6.3-133.49.113.7.1
  • krb5-apps-clients >= 1.6.3-133.49.113.7.1
  • krb5-apps-servers >= 1.6.3-133.49.113.7.1
  • krb5-client >= 1.6.3-133.49.113.7.1
  • krb5-server >= 1.6.3-133.49.113.7.1
  • krb5-x86 >= 1.6.3-133.49.113.7.1
Patchnames:
slessp4-krb5-13541
SUSE Linux Enterprise Server 12 SP2
  • krb5 >= 1.12.5-40.23.2
  • krb5-32bit >= 1.12.5-40.23.2
  • krb5-client >= 1.12.5-40.23.2
  • krb5-doc >= 1.12.5-40.23.2
  • krb5-plugin-kdb-ldap >= 1.12.5-40.23.2
  • krb5-plugin-preauth-otp >= 1.12.5-40.23.2
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.23.2
  • krb5-server >= 1.12.5-40.23.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-567
SUSE Linux Enterprise Server 12 SP3
  • krb5 >= 1.12.5-40.23.2
  • krb5-32bit >= 1.12.5-40.23.2
  • krb5-client >= 1.12.5-40.23.2
  • krb5-doc >= 1.12.5-40.23.2
  • krb5-plugin-kdb-ldap >= 1.12.5-40.23.2
  • krb5-plugin-preauth-otp >= 1.12.5-40.23.2
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.23.2
  • krb5-server >= 1.12.5-40.23.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-567
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • krb5 >= 1.12.5-40.23.2
  • krb5-client >= 1.12.5-40.23.2
  • krb5-doc >= 1.12.5-40.23.2
  • krb5-plugin-kdb-ldap >= 1.12.5-40.23.2
  • krb5-plugin-preauth-otp >= 1.12.5-40.23.2
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.23.2
  • krb5-server >= 1.12.5-40.23.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-567
SUSE Linux Enterprise Software Development Kit 11 SP4
  • krb5 >= 1.6.3-133.49.113.7.1
  • krb5-devel >= 1.6.3-133.49.113.7.1
  • krb5-devel-32bit >= 1.6.3-133.49.113.7.1
  • krb5-server >= 1.6.3-133.49.113.7.1
Patchnames:
sdksp4-krb5-13541
SUSE Linux Enterprise Software Development Kit 12 SP2
  • krb5 >= 1.12.5-40.23.2
  • krb5-devel >= 1.12.5-40.23.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-567
SUSE Linux Enterprise Software Development Kit 12 SP3
  • krb5 >= 1.12.5-40.23.2
  • krb5-devel >= 1.12.5-40.23.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-567
openSUSE Leap 42.3
  • krb5 >= 1.12.5-16.1
  • krb5-32bit >= 1.12.5-16.1
  • krb5-client >= 1.12.5-16.1
  • krb5-client-debuginfo >= 1.12.5-16.1
  • krb5-debuginfo >= 1.12.5-16.1
  • krb5-debuginfo-32bit >= 1.12.5-16.1
  • krb5-debugsource >= 1.12.5-16.1
  • krb5-devel >= 1.12.5-16.1
  • krb5-devel-32bit >= 1.12.5-16.1
  • krb5-doc >= 1.12.5-16.1
  • krb5-mini >= 1.12.5-16.1
  • krb5-mini-debuginfo >= 1.12.5-16.1
  • krb5-mini-debugsource >= 1.12.5-16.1
  • krb5-mini-devel >= 1.12.5-16.1
  • krb5-plugin-kdb-ldap >= 1.12.5-16.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.12.5-16.1
  • krb5-plugin-preauth-otp >= 1.12.5-16.1
  • krb5-plugin-preauth-otp-debuginfo >= 1.12.5-16.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-16.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.12.5-16.1
  • krb5-server >= 1.12.5-16.1
  • krb5-server-debuginfo >= 1.12.5-16.1
Patchnames:
openSUSE-2018-328


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 krb5 Affected
OpenStack Cloud Magnum Orchestration 7.0 krb5 Affected
SUSE Linux Enterprise Desktop 12 SP2 krb5 Released
SUSE Linux Enterprise Desktop 12 SP3 krb5 Affected
SUSE Linux Enterprise Module for Basesystem 15 GA krb5 Affected
SUSE Linux Enterprise Module for Server Applications 15 GA krb5 Affected
SUSE Linux Enterprise SDK 11 SP4 krb5 Released
SUSE Linux Enterprise SDK 12 SP2 krb5 Released
SUSE Linux Enterprise SDK 12 SP3 krb5 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS krb5 Affected
SUSE Linux Enterprise Server 11 SP4 krb5 Released
SUSE Linux Enterprise Server 12 SP2 krb5 Released
SUSE Linux Enterprise Server 12 SP3 krb5 Affected