Upstream information

CVE-2018-5146 at MITRE

Description

An out of bounds memory write while processing Vorbis audio data was reported through the Pwn2Own contest. This vulnerability affects Firefox

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entries: 1085671 [IN_PROGRESS], 1085687 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • MozillaFirefox >= 52.7.3esr-109.25.1
  • MozillaFirefox-translations >= 52.7.3esr-109.25.1
  • libvorbis >= 1.3.3-10.6.1
  • libvorbis0 >= 1.3.3-10.6.1
  • libvorbis0-32bit >= 1.3.3-10.6.1
  • libvorbisenc2 >= 1.3.3-10.6.1
  • libvorbisenc2-32bit >= 1.3.3-10.6.1
  • libvorbisfile3 >= 1.3.3-10.6.1
  • libvorbisfile3-32bit >= 1.3.3-10.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-531
SUSE-SLE-DESKTOP-12-SP2-2018-569
SUSE Linux Enterprise Desktop 12 SP3
  • MozillaFirefox >= 52.7.3esr-109.25.1
  • MozillaFirefox-translations >= 52.7.3esr-109.25.1
  • libvorbis >= 1.3.3-10.6.1
  • libvorbis0 >= 1.3.3-10.6.1
  • libvorbis0-32bit >= 1.3.3-10.6.1
  • libvorbisenc2 >= 1.3.3-10.6.1
  • libvorbisenc2-32bit >= 1.3.3-10.6.1
  • libvorbisfile3 >= 1.3.3-10.6.1
  • libvorbisfile3-32bit >= 1.3.3-10.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-531
SUSE-SLE-DESKTOP-12-SP3-2018-569
SUSE Linux Enterprise Module for Basesystem 15
  • libvorbis-devel >= 1.3.6-2.16
  • libvorbis0 >= 1.3.6-2.16
  • libvorbisenc2 >= 1.3.6-2.16
  • libvorbisfile3 >= 1.3.6-2.16
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libvorbis-devel
SUSE Linux Enterprise Module for Desktop Applications 15
  • MozillaFirefox >= 52.7.3-1.35
  • MozillaFirefox-devel >= 52.7.3-1.35
  • MozillaFirefox-translations-common >= 52.7.3-1.35
  • MozillaFirefox-translations-other >= 52.7.3-1.35
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA MozillaFirefox
SUSE Linux Enterprise Point of Sale 11 SP3
  • MozillaFirefox >= 52.7.3esr-72.27.2
  • MozillaFirefox-translations >= 52.7.3esr-72.27.2
Patchnames:
sleposp3-MozillaFirefox-13555
SUSE Linux Enterprise Server 11 SP3-LTSS
  • MozillaFirefox >= 52.7.3esr-72.27.2
  • MozillaFirefox-translations >= 52.7.3esr-72.27.2
Patchnames:
slessp3-MozillaFirefox-13555
SUSE Linux Enterprise Server 11 SP4
  • MozillaFirefox >= 52.7.3esr-72.27.2
  • MozillaFirefox-translations >= 52.7.3esr-72.27.2
  • libvorbis >= 1.2.0-79.20.6.1
  • libvorbis-32bit >= 1.2.0-79.20.6.1
  • libvorbis-doc >= 1.2.0-79.20.6.1
  • libvorbis-x86 >= 1.2.0-79.20.6.1
Patchnames:
slessp4-MozillaFirefox-13555
slessp4-libvorbis-13529
SUSE Linux Enterprise Server 12 SP2
  • MozillaFirefox >= 52.7.3esr-109.25.1
  • MozillaFirefox-translations >= 52.7.3esr-109.25.1
  • libvorbis >= 1.3.3-10.6.1
  • libvorbis-doc >= 1.3.3-10.6.1
  • libvorbis0 >= 1.3.3-10.6.1
  • libvorbis0-32bit >= 1.3.3-10.6.1
  • libvorbisenc2 >= 1.3.3-10.6.1
  • libvorbisenc2-32bit >= 1.3.3-10.6.1
  • libvorbisfile3 >= 1.3.3-10.6.1
  • libvorbisfile3-32bit >= 1.3.3-10.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-531
SUSE-SLE-SERVER-12-SP2-2018-569
SUSE Linux Enterprise Server 12 SP3
  • MozillaFirefox >= 52.7.3esr-109.25.1
  • MozillaFirefox-translations >= 52.7.3esr-109.25.1
  • libvorbis >= 1.3.3-10.6.1
  • libvorbis-doc >= 1.3.3-10.6.1
  • libvorbis0 >= 1.3.3-10.6.1
  • libvorbis0-32bit >= 1.3.3-10.6.1
  • libvorbisenc2 >= 1.3.3-10.6.1
  • libvorbisenc2-32bit >= 1.3.3-10.6.1
  • libvorbisfile3 >= 1.3.3-10.6.1
  • libvorbisfile3-32bit >= 1.3.3-10.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-531
SUSE-SLE-SERVER-12-SP3-2018-569
SUSE Linux Enterprise Server 12 SP4
  • MozillaFirefox >= 52.9.0esr-109.38.2
  • MozillaFirefox-translations >= 52.9.0esr-109.38.2
  • libvorbis-doc >= 1.3.3-10.14.1
  • libvorbis0 >= 1.3.3-10.14.1
  • libvorbis0-32bit >= 1.3.3-10.14.1
  • libvorbisenc2 >= 1.3.3-10.14.1
  • libvorbisenc2-32bit >= 1.3.3-10.14.1
  • libvorbisfile3 >= 1.3.3-10.14.1
  • libvorbisfile3-32bit >= 1.3.3-10.14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA MozillaFirefox
SUSE Linux Enterprise Server 12 SP4 GA libvorbis-doc
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • MozillaFirefox >= 52.7.3esr-109.25.1
  • MozillaFirefox-translations >= 52.7.3esr-109.25.1
  • libvorbis >= 1.3.3-10.6.1
  • libvorbis-doc >= 1.3.3-10.6.1
  • libvorbis0 >= 1.3.3-10.6.1
  • libvorbisenc2 >= 1.3.3-10.6.1
  • libvorbisfile3 >= 1.3.3-10.6.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-531
SUSE-SLE-RPI-12-SP2-2018-569
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • MozillaFirefox >= 52.7.3esr-72.27.2
  • MozillaFirefox-translations >= 52.7.3esr-72.27.2
Patchnames:
slessp3-MozillaFirefox-13555
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • MozillaFirefox >= 52.7.3esr-72.27.2
  • MozillaFirefox-translations >= 52.7.3esr-72.27.2
  • libvorbis >= 1.2.0-79.20.6.1
  • libvorbis-32bit >= 1.2.0-79.20.6.1
  • libvorbis-doc >= 1.2.0-79.20.6.1
  • libvorbis-x86 >= 1.2.0-79.20.6.1
Patchnames:
slessp4-MozillaFirefox-13555
slessp4-libvorbis-13529
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • MozillaFirefox >= 52.7.3esr-109.25.1
  • MozillaFirefox-translations >= 52.7.3esr-109.25.1
  • libvorbis >= 1.3.3-10.6.1
  • libvorbis-doc >= 1.3.3-10.6.1
  • libvorbis0 >= 1.3.3-10.6.1
  • libvorbis0-32bit >= 1.3.3-10.6.1
  • libvorbisenc2 >= 1.3.3-10.6.1
  • libvorbisenc2-32bit >= 1.3.3-10.6.1
  • libvorbisfile3 >= 1.3.3-10.6.1
  • libvorbisfile3-32bit >= 1.3.3-10.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-531
SUSE-SLE-SERVER-12-SP2-2018-569
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • MozillaFirefox >= 52.7.3esr-109.25.1
  • MozillaFirefox-translations >= 52.7.3esr-109.25.1
  • libvorbis >= 1.3.3-10.6.1
  • libvorbis-doc >= 1.3.3-10.6.1
  • libvorbis0 >= 1.3.3-10.6.1
  • libvorbis0-32bit >= 1.3.3-10.6.1
  • libvorbisenc2 >= 1.3.3-10.6.1
  • libvorbisenc2-32bit >= 1.3.3-10.6.1
  • libvorbisfile3 >= 1.3.3-10.6.1
  • libvorbisfile3-32bit >= 1.3.3-10.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-531
SUSE-SLE-SERVER-12-SP3-2018-569
SUSE Linux Enterprise Software Development Kit 11 SP4
  • MozillaFirefox >= 52.7.3esr-72.27.2
  • MozillaFirefox-devel >= 52.7.3esr-72.27.2
  • libvorbis >= 1.2.0-79.20.6.1
  • libvorbis-devel >= 1.2.0-79.20.6.1
Patchnames:
sdksp4-MozillaFirefox-13555
sdksp4-libvorbis-13529
SUSE Linux Enterprise Software Development Kit 12 SP2
  • MozillaFirefox >= 52.7.3esr-109.25.1
  • MozillaFirefox-devel >= 52.7.3esr-109.25.1
  • libvorbis >= 1.3.3-10.6.1
  • libvorbis-devel >= 1.3.3-10.6.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-531
SUSE-SLE-SDK-12-SP2-2018-569
SUSE Linux Enterprise Software Development Kit 12 SP3
  • MozillaFirefox >= 52.7.3esr-109.25.1
  • MozillaFirefox-devel >= 52.7.3esr-109.25.1
  • libvorbis >= 1.3.3-10.6.1
  • libvorbis-devel >= 1.3.3-10.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-531
SUSE-SLE-SDK-12-SP3-2018-569
SUSE Linux Enterprise Workstation Extension 15
  • MozillaThunderbird >= 52.8-1.2
  • MozillaThunderbird-devel >= 52.8-1.2
  • MozillaThunderbird-translations-common >= 52.8-1.2
  • MozillaThunderbird-translations-other >= 52.8-1.2
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA MozillaThunderbird
SUSE Package Hub for SUSE Linux Enterprise 12
  • MozillaThunderbird >= 52.7-57.1
  • MozillaThunderbird-buildsymbols >= 52.7-57.1
  • MozillaThunderbird-debuginfo >= 52.7-57.1
  • MozillaThunderbird-debugsource >= 52.7-57.1
  • MozillaThunderbird-devel >= 52.7-57.1
  • MozillaThunderbird-translations-common >= 52.7-57.1
  • MozillaThunderbird-translations-other >= 52.7-57.1
Patchnames:
openSUSE-2018-313
openSUSE Leap 15.0
  • MozillaFirefox >= 60.0-lp150.2.2
  • MozillaFirefox-translations-common >= 60.0-lp150.2.2
  • MozillaFirefox-translations-other >= 60.0-lp150.2.2
  • MozillaThunderbird >= 52.7-lp150.2.16
  • MozillaThunderbird-translations-common >= 52.7-lp150.2.16
  • MozillaThunderbird-translations-other >= 52.7-lp150.2.16
  • libvorbis0 >= 1.3.6-lp150.2.4
  • libvorbisenc2 >= 1.3.6-lp150.2.4
  • libvorbisfile3 >= 1.3.6-lp150.2.4
Patchnames:
openSUSE Leap 15.0 GA MozillaFirefox
openSUSE Leap 15.0 GA MozillaThunderbird
openSUSE Leap 15.0 GA libvorbis0
openSUSE Leap 42.3
  • MozillaFirefox >= 52.7.2-81.1
  • MozillaFirefox-branding-upstream >= 52.7.2-81.1
  • MozillaFirefox-buildsymbols >= 52.7.2-81.1
  • MozillaFirefox-debuginfo >= 52.7.2-81.1
  • MozillaFirefox-debugsource >= 52.7.2-81.1
  • MozillaFirefox-devel >= 52.7.2-81.1
  • MozillaFirefox-translations-common >= 52.7.2-81.1
  • MozillaFirefox-translations-other >= 52.7.2-81.1
  • MozillaThunderbird >= 52.7-60.1
  • MozillaThunderbird-buildsymbols >= 52.7-60.1
  • MozillaThunderbird-debuginfo >= 52.7-60.1
  • MozillaThunderbird-debugsource >= 52.7-60.1
  • MozillaThunderbird-devel >= 52.7-60.1
  • MozillaThunderbird-translations-common >= 52.7-60.1
  • MozillaThunderbird-translations-other >= 52.7-60.1
  • libvorbis >= 1.3.3-11.1
  • libvorbis-debugsource >= 1.3.3-11.1
  • libvorbis-devel >= 1.3.3-11.1
  • libvorbis-doc >= 1.3.3-11.1
  • libvorbis0 >= 1.3.3-11.1
  • libvorbis0-32bit >= 1.3.3-11.1
  • libvorbis0-debuginfo >= 1.3.3-11.1
  • libvorbis0-debuginfo-32bit >= 1.3.3-11.1
  • libvorbisenc2 >= 1.3.3-11.1
  • libvorbisenc2-32bit >= 1.3.3-11.1
  • libvorbisenc2-debuginfo >= 1.3.3-11.1
  • libvorbisenc2-debuginfo-32bit >= 1.3.3-11.1
  • libvorbisfile3 >= 1.3.3-11.1
  • libvorbisfile3-32bit >= 1.3.3-11.1
  • libvorbisfile3-debuginfo >= 1.3.3-11.1
  • libvorbisfile3-debuginfo-32bit >= 1.3.3-11.1
Patchnames:
openSUSE-2018-278
openSUSE-2018-308
openSUSE-2018-313


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 MozillaFirefox Released
SUSE Linux Enterprise Desktop 12 SP3 MozillaFirefox Released
SUSE Linux Enterprise SDK 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise SDK 12 SP2 MozillaFirefox Released
SUSE Linux Enterprise SDK 12 SP3 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP3 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise Server 12 GA LTSS MozillaFirefox Affected
SUSE Linux Enterprise Server 12 SP1 LTSS MozillaFirefox Affected
SUSE Linux Enterprise Server 12 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 12 SP3 MozillaFirefox Released