Upstream information

CVE-2018-21010 at MITRE

Description

OpenJPEG before 2.3.1 has a heap buffer overflow in color_apply_icc_profile in bin/common/color.c.

SUSE information

Overall state of this security issue: Analysis

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 7.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1149789 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLE-HPC (12) ghostscript Not affected
SLE-HPC (12) openjpeg2 Not affected
SLED (12) ghostscript Not affected
SLED (12) openjpeg2 Not affected
SLED-10-SP3 (n/a) ghostscript-library Not affected
SLED-10-SP4 (n/a) ghostscript-library Not affected
SLES (12) ghostscript Not affected
SLES (12) openjpeg2 Not affected
SLES-10-SP3 (n/a) ghostscript-library Not affected
SLES-10-SP4 (n/a) ghostscript-library Not affected
SLES-BCL (12) ghostscript Affected
SLES-ESPOS (12) ghostscript Affected
SLES-LTSS (12) ghostscript Not affected
SLES-LTSS (12) openjpeg2 Not affected
SLES-LTSS-ERICSSON (12) ghostscript Affected
SLES-LTSS-SAP (12) ghostscript Affected
SLES-for-VMware (11) ghostscript-library Not affected
SLES_LTSS-10-SP4 (n/a) ghostscript-library Not affected
SLES_RPI (12) ghostscript Not affected
SLES_SAP (12) ghostscript Not affected
SLES_SAP (12) openjpeg2 Not affected
SUSE_SLED (11) ghostscript-library Not affected
SUSE_SLES (11) ghostscript-library Not affected
SUSE_SLES_LTSS (11) ghostscript-library Not affected
SUSE_SLES_SAP (11) ghostscript-library Not affected
hpe-helion-openstack (8) ghostscript Affected
sap-aio (11) ghostscript-library Not affected
sap-es (11) ghostscript-library Not affected
sle-module-basesystem (15) ghostscript Unsupported
sle-module-basesystem (15) openjpeg2 Affected
sle-sdk (11) ghostscript-library Not affected
sle-sdk (12) ghostscript Not affected
suse-openstack-cloud (8) ghostscript Affected
suse-openstack-cloud (9) ghostscript Affected
suse-openstack-cloud-crowbar (8) ghostscript Affected
suse-openstack-cloud-crowbar (9) ghostscript Affected