Upstream information

CVE-2018-20725 at MITRE

Description

A cross-site scripting (XSS) vulnerability exists in graph_templates.php in Cacti before 1.2.0 due to lack of escaping of unintended characters in the Graph Vertical Label.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently not rated by SUSE as it is not affecting the SUSE Enterprise products.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.5
Vector AV:N/AC:M/Au:S/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 4.8
Vector CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required High
User Interaction Required
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entry: 1122243 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 12
  • cacti >= 1.2.11-5.1
  • cacti-spine >= 1.2.11-2.1
Patchnames:
openSUSE-2020-558
SUSE Package Hub 15 SP1
  • cacti >= 1.2.11-bp151.4.6.1
  • cacti-spine >= 1.2.11-bp151.4.6.1
Patchnames:
openSUSE-2020-284
openSUSE-2020-565
openSUSE Leap 15.1
  • cacti >= 1.2.11-lp151.3.6.1
  • cacti-spine >= 1.2.11-lp151.3.6.1
Patchnames:
openSUSE-2020-272
openSUSE-2020-558
openSUSE Tumbleweed
  • cacti >= 1.2.18-1.2
Patchnames:
openSUSE Tumbleweed GA cacti-1.2.18-1.2