Upstream information

CVE-2018-19760 at MITRE

Description

cfg_init in confuse.c in libConfuse 3.2.2 has a memory leak.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 4
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1117952 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 libconfuse0 Not affected
SUSE Linux Enterprise Desktop 15 SP4 libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libconfuse0 Not affected
SUSE Linux Enterprise Module for HPC 12 libconfuse0 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 libconfuse0 Not affected
SUSE Linux Enterprise Server 12 SP5 libconfuse0 Not affected
SUSE Linux Enterprise Server 15 SP4 libconfuse0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libconfuse0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libconfuse0 Not affected
SUSE Manager Proxy 4.2 libconfuse0 Not affected
SUSE Manager Proxy 4.3 libconfuse0 Not affected
SUSE Manager Retail Branch Server 4.2 libconfuse0 Not affected
SUSE Manager Retail Branch Server 4.3 libconfuse0 Not affected
SUSE Manager Server 4.2 libconfuse0 Not affected
SUSE Manager Server 4.3 libconfuse0 Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP4 libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS libconfuse0 Not affected
SUSE Linux Enterprise Module for HPC 15 SP1 libconfuse0 Not affected
SUSE Linux Enterprise Module for HPC 15 SP2 libconfuse0 Not affected
SUSE Linux Enterprise Module for HPC 15 SP3 libconfuse0 Not affected
SUSE Linux Enterprise Server 12 SP4 libconfuse0 Not affected
SUSE Linux Enterprise Server 15 SP3 libconfuse0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libconfuse0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libconfuse0 Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP4 libconfuse0 Not affected
SUSE Linux Enterprise Desktop 15 SP3 libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 libconfuse0 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP3 libconfuse0 Not affected
SUSE Linux Enterprise Module for HPC 15 libconfuse0 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 libconfuse0 Not affected
SUSE Linux Enterprise Server 11 SP4 libconfuse0 Not affected
SUSE Linux Enterprise Server 12 SP2 libconfuse0 Not affected
SUSE Linux Enterprise Server 12 SP3 libconfuse0 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libconfuse0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libconfuse0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libconfuse0 Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 libconfuse0 Not affected
Products at an unknown state of their lifecycle.
SUSE Linux Enterprise Module for HPC 12 SP2 libconfuse0 Not affected


SUSE Timeline for this CVE

CVE page created: Fri Nov 30 14:53:05 2018
CVE page last modified: Fri Jan 20 14:33:02 2023