Upstream information

CVE-2018-18928 at MITRE

Description

International Components for Unicode (ICU) for C/C++ 63.1 has an integer overflow in number::impl::DecimalQuantity::toScientificString() in i18n/number_decimalquantity.cpp.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1114629 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration icu Not affected
SLES for SAP Applications icu Not affected
SUSE CaaS Platform 3.0 icu Not affected
SUSE Container as a Service Platform 2.0 icu Not affected
SUSE Linux Enterprise Desktop 12 SP3 icu Not affected
SUSE Linux Enterprise Desktop 12 SP4 icu Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 icu Not affected
SUSE Linux Enterprise Module for Basesystem 15 icu Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS icu Not affected
SUSE Linux Enterprise Server 11 SP4 icu Not affected
SUSE Linux Enterprise Server 12 LTSS icu Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS icu Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS icu Not affected
SUSE Linux Enterprise Server 12 SP3 icu Not affected
SUSE Linux Enterprise Server 12 SP4 icu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 icu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 icu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 icu Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 icu Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 icu Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 icu Not affected
SUSE Linux Enterprise Workstation Extension 12 SP3 icu Not affected
SUSE Linux Enterprise Workstation Extension 12 SP4 icu Not affected