Upstream information

CVE-2018-17957 at MITRE

Description

The YaST2 RMT module for configuring the SUSE Repository Mirroring Tool (RMT) before 1.1.2 exposed MySQL database passwords on process commandline, allowing local attackers to access or corrupt the RMT database.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 3.4
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low High
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1117602 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • yast2-rmt >= 1.2.1-1.25
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • yast2-rmt >= 1.3.0-1.43
SUSE Linux Enterprise Module for Server Applications 15
  • yast2-rmt >= 1.1.2-3.11.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2018-3012
openSUSE Leap 15.0
  • yast2-rmt >= 1.1.2-lp150.2.12.1
Patchnames:
openSUSE-2019-1036


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 yast2-rmt Already fixed
SUSE Enterprise Storage 6 yast2-rmt Already fixed
SUSE Linux Enterprise High Performance Computing 15 LTSS yast2-rmt Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS yast2-rmt Already fixed
SUSE Linux Enterprise Module for Server Applications 15 yast2-rmt Released
SUSE Linux Enterprise Server 15 LTSS yast2-rmt Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux yast2-rmt Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS yast2-rmt Already fixed
SUSE Linux Enterprise Server ESPOS 15 yast2-rmt Released
SUSE Linux Enterprise Server for SAP Applications 15 yast2-rmt Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 yast2-rmt Already fixed
SUSE Manager Proxy 4.0 yast2-rmt Already fixed
SUSE Manager Retail Branch Server 4.0 yast2-rmt Already fixed
SUSE Manager Server 4.0 yast2-rmt Already fixed