Upstream information

CVE-2018-16878 at MITRE

Description

A flaw was found in pacemaker up to and including version 2.0.1. An insufficient verification inflicted preference of uncontrolled processes can lead to DoS

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 5.5
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1131353 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
  • libpacemaker3 >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker-cli >= 1.1.19+20181105.ccd6b5b10-3.13.1
Image SLES15-SAP-Azure
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SAP-EC2-HVM
Image SLES15-SAP-EC2-HVM-BYOS
Image SLES15-SAP-GCE
Image SLES15-SAP-GCE-BYOS
Image SLES15-SAP-OCI-BYOS
  • libpacemaker3 >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker-cli >= 1.1.18+20180430.b12c320f5-3.9.4
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpacemaker-devel >= 1.1.16-6.14.1
  • pacemaker-cts >= 1.1.16-6.14.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1108
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libpacemaker-devel >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker-cts >= 1.1.19+20181105.ccd6b5b10-3.13.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1047
SUSE-SLE-SDK-12-SP4-2019-2268
SUSE Linux Enterprise High Availability 12 SP2
SUSE Linux Enterprise High Performance Computing 12 SP2
SUSE Linux Enterprise Server 12 SP2
  • libpacemaker3 >= 1.1.15-23.9.1
  • pacemaker >= 1.1.15-23.9.1
  • pacemaker-cli >= 1.1.15-23.9.1
  • pacemaker-cts >= 1.1.15-23.9.1
  • pacemaker-remote >= 1.1.15-23.9.1
Patchnames:
SUSE-SLE-HA-12-SP2-2020-1072
SUSE Linux Enterprise High Availability 12 SP3
SUSE Linux Enterprise High Performance Computing 12 SP3
  • libpacemaker3 >= 1.1.16-6.14.1
  • pacemaker >= 1.1.16-6.14.1
  • pacemaker-cli >= 1.1.16-6.14.1
  • pacemaker-cts >= 1.1.16-6.14.1
  • pacemaker-remote >= 1.1.16-6.14.1
Patchnames:
SUSE-SLE-HA-12-SP3-2019-1108
SUSE Linux Enterprise High Availability 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP4
  • libpacemaker3 >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker-cli >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker-cts >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker-remote >= 1.1.19+20181105.ccd6b5b10-3.13.1
Patchnames:
SUSE-SLE-HA-12-SP4-2019-1047
SUSE-SLE-HA-12-SP4-2019-2268
SUSE Linux Enterprise High Availability 12 SP5
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libpacemaker3 >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cli >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cts >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-remote >= 1.1.21+20190809.bf34b44fa-1.17
Patchnames:
SUSE Linux Enterprise High Availability 12 SP5 GA libpacemaker3-1.1.21+20190809.bf34b44fa-1.17
SUSE Linux Enterprise High Availability 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libpacemaker-devel >= 2.0.1+20190417.13d370ca9-1.2
  • libpacemaker3 >= 2.0.1+20190417.13d370ca9-1.2
  • pacemaker >= 2.0.1+20190417.13d370ca9-1.2
  • pacemaker-cli >= 2.0.1+20190417.13d370ca9-1.2
  • pacemaker-cts >= 2.0.1+20190417.13d370ca9-1.2
  • pacemaker-remote >= 2.0.1+20190417.13d370ca9-1.2
Patchnames:
SUSE Linux Enterprise High Availability 15 SP1 GA libpacemaker-devel-2.0.1+20190417.13d370ca9-1.2
SUSE Linux Enterprise High Availability 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libpacemaker-devel >= 1.1.18+20180430.b12c320f5-3.9.4
  • libpacemaker3 >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker-cli >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker-cts >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker-remote >= 1.1.18+20180430.b12c320f5-3.9.4
Patchnames:
SUSE-SLE-Product-HA-15-2019-1209
SUSE Linux Enterprise Server 12 SP3
  • libpacemaker-devel >= 1.1.16-6.14.1
  • libpacemaker3 >= 1.1.16-6.14.1
  • pacemaker >= 1.1.16-6.14.1
  • pacemaker-cli >= 1.1.16-6.14.1
  • pacemaker-cts >= 1.1.16-6.14.1
  • pacemaker-remote >= 1.1.16-6.14.1
Patchnames:
SUSE-SLE-HA-12-SP3-2019-1108
SUSE-SLE-SDK-12-SP3-2019-1108
SUSE Linux Enterprise Server 12 SP4
  • libpacemaker-devel >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • libpacemaker3 >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker-cli >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker-cts >= 1.1.19+20181105.ccd6b5b10-3.13.1
  • pacemaker-remote >= 1.1.19+20181105.ccd6b5b10-3.13.1
Patchnames:
SUSE-SLE-HA-12-SP4-2019-1047
SUSE-SLE-HA-12-SP4-2019-2268
SUSE-SLE-SDK-12-SP4-2019-1047
SUSE-SLE-SDK-12-SP4-2019-2268
SUSE Linux Enterprise Server 12 SP5
  • libpacemaker-devel >= 1.1.21+20190809.bf34b44fa-1.17
  • libpacemaker3 >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cli >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cts >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-remote >= 1.1.21+20190809.bf34b44fa-1.17
Patchnames:
SUSE Linux Enterprise High Availability 12 SP5 GA libpacemaker3-1.1.21+20190809.bf34b44fa-1.17
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libpacemaker-devel-1.1.21+20190809.bf34b44fa-1.17
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libpacemaker-devel >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cts >= 1.1.21+20190809.bf34b44fa-1.17
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libpacemaker-devel-1.1.21+20190809.bf34b44fa-1.17
openSUSE Leap 15.0
  • libpacemaker-devel >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • libpacemaker3 >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-cli >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-cts >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-remote >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
Patchnames:
openSUSE-2019-1400


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications pacemaker Unsupported
SUSE Linux Enterprise Desktop 12 SP3 pacemaker Released
SUSE Linux Enterprise Desktop 12 SP4 pacemaker Released
SUSE Linux Enterprise High Availability Extension 11 SP4 pacemaker Unsupported
SUSE Linux Enterprise High Availability Extension 12 pacemaker Unsupported
SUSE Linux Enterprise High Availability Extension 12 SP2 pacemaker Released
SUSE Linux Enterprise High Availability Extension 12 SP3 pacemaker Released
SUSE Linux Enterprise High Availability Extension 12 SP4 pacemaker Released
SUSE Linux Enterprise High Availability Extension 12 SP5 pacemaker Already fixed
SUSE Linux Enterprise High Availability Extension 15 pacemaker Released
SUSE Linux Enterprise High Availability Extension 15 SP1 pacemaker Already fixed
SUSE Linux Enterprise High Availability Extension 15 SP2 pacemaker Already fixed
SUSE Linux Enterprise High Availability Extension 15 SP3 pacemaker In progress
SUSE Linux Enterprise High Availability Extension 15 SP4 pacemaker Already fixed
SUSE Linux Enterprise High Performance Computing 12 pacemaker Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP2 pacemaker Released
SUSE Linux Enterprise High Performance Computing 12 SP3 pacemaker Released
SUSE Linux Enterprise High Performance Computing 12 SP4 pacemaker Released
SUSE Linux Enterprise High Performance Computing 12 SP5 pacemaker Already fixed
SUSE Linux Enterprise High Performance Computing 15 pacemaker Released
SUSE Linux Enterprise High Performance Computing 15 SP1 pacemaker Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 pacemaker Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 pacemaker In progress
SUSE Linux Enterprise High Performance Computing 15 SP4 pacemaker Already fixed
SUSE Linux Enterprise Server 11 SP4 pacemaker Unsupported
SUSE Linux Enterprise Server 12 pacemaker Unsupported
SUSE Linux Enterprise Server 12 SP2 pacemaker Released
SUSE Linux Enterprise Server 12 SP3 pacemaker Released
SUSE Linux Enterprise Server 12 SP4 pacemaker Released
SUSE Linux Enterprise Server 12 SP5 pacemaker Already fixed
SUSE Linux Enterprise Server 15 pacemaker Released
SUSE Linux Enterprise Server 15 SP1 pacemaker Already fixed
SUSE Linux Enterprise Server 15 SP2 pacemaker Already fixed
SUSE Linux Enterprise Server 15 SP3 pacemaker In progress
SUSE Linux Enterprise Server 15 SP4 pacemaker Already fixed
SUSE Linux Enterprise Server for SAP All-in-One 11 SP4 pacemaker Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 pacemaker Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP1 pacemaker Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 pacemaker Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 pacemaker Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 pacemaker Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 pacemaker Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 pacemaker Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 pacemaker Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 pacemaker Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 pacemaker In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP4 pacemaker Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP3 pacemaker Released
SUSE Linux Enterprise Software Development Kit 12 SP4 pacemaker Released
SUSE Linux Enterprise Software Development Kit 12 SP5 pacemaker Already fixed
SUSE Manager Proxy 4.0 pacemaker Already fixed
SUSE Manager Proxy 4.1 pacemaker Already fixed
SUSE Manager Proxy 4.2 pacemaker In progress
SUSE Manager Proxy 4.3 pacemaker Already fixed
SUSE Manager Retail Branch Server 4.0 pacemaker Already fixed
SUSE Manager Retail Branch Server 4.1 pacemaker Already fixed
SUSE Manager Retail Branch Server 4.2 pacemaker In progress
SUSE Manager Retail Branch Server 4.3 pacemaker Already fixed
SUSE Manager Server 4.0 pacemaker Already fixed
SUSE Manager Server 4.1 pacemaker Already fixed
SUSE Manager Server 4.2 pacemaker In progress
SUSE Manager Server 4.3 pacemaker Already fixed