Upstream information

CVE-2018-16468 at MITRE

Description

In the Loofah gem for Ruby, through v2.2.2, unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.5
Vector AV:N/AC:M/Au:S/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.4 6.4
Vector AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low Low
User Interaction Required None
Scope Changed Changed
Confidentiality Impact Low None
Integrity Impact Low Low
Availability Impact None Low
SUSE Bugzilla entry: 1113969 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • ruby2.1-rubygem-loofah >= 2.0.2-3.5.1
  • rubygem-loofah >= 2.0.2-3.5.1
Patchnames:
SUSE-Storage-4-2019-394
SUSE Linux Enterprise High Availability 15
  • ruby2.5-rubygem-loofah >= 2.2.2-4.3.1
  • rubygem-loofah >= 2.2.2-4.3.1
Patchnames:
SUSE-SLE-Product-HA-15-2018-2797
SUSE Linux Enterprise High Availability 15 SP1
  • ruby2.5-rubygem-loofah >= 2.2.2-4.3.1
Patchnames:
SUSE Linux Enterprise High Availability 15 SP1 GA ruby2.5-rubygem-loofah
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • ruby2.5-rubygem-loofah-doc >= 2.2.2-4.3.1
  • ruby2.5-rubygem-loofah-testsuite >= 2.2.2-4.3.1
  • rubygem-loofah >= 2.2.2-4.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2797
SUSE Linux Enterprise Module for Public Cloud 15 SP1
  • rmt-server-pubcloud >= 1.2.2-1.15
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP1 GA rmt-server-pubcloud
SUSE Linux Enterprise Module for Server Applications 15
  • rmt-server >= 1.1.1-3.13.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-272
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • rmt-server >= 1.2.2-1.15
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA rmt-server
SUSE OpenStack Cloud 7
  • ruby2.1-rubygem-loofah >= 2.0.2-3.5.1
  • rubygem-loofah >= 2.0.2-3.5.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-394
SUSE OpenStack Cloud Crowbar 8
  • ruby2.1-rubygem-loofah >= 2.0.2-3.5.1
  • rubygem-loofah >= 2.0.2-3.5.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-394
openSUSE Leap 15.0
  • rmt-server >= 1.1.1-lp150.2.12.1
  • rmt-server-debuginfo >= 1.1.1-lp150.2.12.1
  • rmt-server-pubcloud >= 1.1.1-lp150.2.12.1
  • ruby2.5-rubygem-loofah >= 2.2.2-lp150.3.3.1
  • ruby2.5-rubygem-loofah-doc >= 2.2.2-lp150.3.3.1
  • ruby2.5-rubygem-loofah-testsuite >= 2.2.2-lp150.3.3.1
Patchnames:
openSUSE-2019-185
openSUSE-2019-963


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability 15 GA rubygem-loofah Released
SUSE Openstack Cloud 6 rubygem-loofah Affected
SUSE Openstack Cloud 7 rubygem-loofah Released
SUSE Openstack Cloud 8 rubygem-loofah Released
SUSE Storage 4 rubygem-loofah Released