Upstream information

CVE-2018-15664 at MITRE

Description

In Docker through 18.06.1-ce-rc2, the API endpoints behind the 'docker cp' command are vulnerable to a symlink-exchange attack with Directory Traversal, giving attackers arbitrary read-write access to the host filesystem with root privileges, because daemon/archive.go does not do archive operations on a frozen filesystem (or from within a chroot).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.2
Vector AV:L/AC:H/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity High
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.1
Vector CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Access Vector Local Local
Access Complexity High Low
Privileges Required Low Low
User Interaction Required None
Scope Changed Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1096726 [RESOLVED / FIXED], 1139649 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP2-CHOST-BYOS-Aliyun
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP2-CHOST-BYOS-OpenStack
Image SLES15-SP3-CHOST-BYOS-Aliyun
Image SLES15-SP3-CHOST-BYOS-Azure
Image SLES15-SP3-CHOST-BYOS-EC2
Image SLES15-SP3-CHOST-BYOS-GCE
  • docker >= 18.09.6_ce-6.20.3
Openstack Cloud Magnum Orchestration 7
  • docker >= 18.09.6_ce-98.40.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-1514
SUSE CaaS Platform 3.0
  • docker-kubic >= 18.09.6_ce-98.40.1
Patchnames:
SUSE-CAASP-3.0-2019-1514
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libcontainers-common >= 20190401-3.3.5
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2223
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libcontainers-common >= 20200306-3.9.2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libcontainers-common >= 20200727-3.12.1
SUSE Linux Enterprise Module for Containers 12
  • docker >= 18.09.6_ce-98.40.1
Patchnames:
SUSE-SLE-Module-Containers-12-2019-1514
SUSE Linux Enterprise Module for Containers 15 SP1
  • docker >= 18.09.6_ce-6.20.3
  • docker-bash-completion >= 18.09.6_ce-6.20.3
  • fuse-overlayfs >= 0.4.1-3.3.8
  • fuse3 >= 3.6.1-3.3.8
  • libfuse3-3 >= 3.6.1-3.3.8
  • podman >= 1.4.4-4.8.1
  • podman-cni-config >= 1.4.4-4.8.1
  • slirp4netns >= 0.3.0-3.3.3
Patchnames:
SUSE-SLE-Module-Containers-15-SP1-2019-1562
SUSE-SLE-Module-Containers-15-SP1-2019-2223
SUSE Linux Enterprise Module for Containers 15 SP2
  • docker >= 19.03.5_ce-6.31.1
  • docker-bash-completion >= 19.03.5_ce-6.31.1
SUSE Linux Enterprise Module for Containers 15 SP3
  • docker >= 19.03.15_ce-6.46.1
  • docker-bash-completion >= 19.03.15_ce-6.46.1
  • docker-fish-completion >= 19.03.15_ce-6.46.1
SUSE Linux Enterprise Module for Containers 15
  • docker >= 18.09.6_ce-6.20.3
  • docker-bash-completion >= 18.09.6_ce-6.20.3
Patchnames:
SUSE-SLE-Module-Containers-15-2019-1562
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • docker-test >= 18.09.6_ce-6.20.3
  • docker-zsh-completion >= 18.09.6_ce-6.20.3
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1562
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • docker-test >= 18.09.6_ce-6.20.3
  • docker-zsh-completion >= 18.09.6_ce-6.20.3
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1562
openSUSE Leap 15.0
  • docker >= 18.09.6_ce-lp150.5.20.1
  • docker-bash-completion >= 18.09.6_ce-lp150.5.20.1
  • docker-test >= 18.09.6_ce-lp150.5.20.1
  • docker-zsh-completion >= 18.09.6_ce-lp150.5.20.1
Patchnames:
openSUSE-2019-1621
openSUSE Leap 15.1
  • docker >= 18.09.6_ce-lp151.2.6.1
  • docker-bash-completion >= 18.09.6_ce-lp151.2.6.1
  • docker-test >= 18.09.6_ce-lp151.2.6.1
  • docker-zsh-completion >= 18.09.6_ce-lp151.2.6.1
  • fuse-overlayfs >= 0.4.1-lp151.2.1
  • fuse3 >= 3.6.1-lp151.2.1
  • fuse3-devel >= 3.6.1-lp151.2.1
  • fuse3-doc >= 3.6.1-lp151.2.1
  • libcontainers-common >= 20190401-lp151.2.3.1
  • libfuse3-3 >= 3.6.1-lp151.2.1
  • podman >= 1.4.4-lp151.3.3.1
  • podman-cni-config >= 1.4.4-lp151.3.3.1
  • slirp4netns >= 0.3.0-lp151.2.3.1
Patchnames:
openSUSE-2019-1621
openSUSE-2019-2044
openSUSE Tumbleweed
  • docker >= 20.10.6_ce-2.1
  • docker-bash-completion >= 20.10.6_ce-2.1
  • docker-fish-completion >= 20.10.6_ce-2.1
  • docker-zsh-completion >= 20.10.6_ce-2.1
  • libcontainers-common >= 20210626-5.1
Patchnames:
openSUSE Tumbleweed GA docker-20.10.6_ce-2.1
openSUSE Tumbleweed GA libcontainers-common-20210626-5.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration docker Released
SUSE CaaS Platform 3.0 docker Released
SUSE CaaS Platform 4.0 docker Released
SUSE CaaS Platform 4.0 libcontainers-common Released
SUSE Container as a Service Platform 2.0 docker Ignore
SUSE Enterprise Storage 6 docker Released
SUSE Enterprise Storage 6 libcontainers-common Released
SUSE Linux Enterprise High Performance Computing 15 LTSS docker Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS docker Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS libcontainers-common Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 libcontainers-common Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 fuse3 Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 libcontainers-common Released
SUSE Linux Enterprise Module for Containers 12 docker Released
SUSE Linux Enterprise Module for Containers 15 docker Released
SUSE Linux Enterprise Module for Containers 15 SP1 docker Released
SUSE Linux Enterprise Module for Containers 15 SP1 fuse-overlayfs Released
SUSE Linux Enterprise Module for Containers 15 SP1 fuse3 Released
SUSE Linux Enterprise Module for Containers 15 SP1 podman Released
SUSE Linux Enterprise Module for Containers 15 SP1 slirp4netns Released
SUSE Linux Enterprise Module for Containers 15 SP2 docker Released
SUSE Linux Enterprise Module for Containers 15 SP2 fuse-overlayfs Released
SUSE Linux Enterprise Module for Containers 15 SP2 podman Released
SUSE Linux Enterprise Module for Containers 15 SP2 slirp4netns Released
SUSE Linux Enterprise Server 15 ESPOS docker Released
SUSE Linux Enterprise Server 15 LTSS docker Released
SUSE Linux Enterprise Server 15 SP1 LTSS docker Released
SUSE Linux Enterprise Server 15 SP1 LTSS libcontainers-common Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 docker Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libcontainers-common Released
SUSE Linux Enterprise Server for SAP Applications 15 docker Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 docker Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libcontainers-common Released
SUSE Manager Proxy 4.0 docker Released
SUSE Manager Proxy 4.0 libcontainers-common Released
SUSE Manager Retail Branch Server 4.0 docker Released
SUSE Manager Retail Branch Server 4.0 libcontainers-common Released
SUSE Manager Server 4.0 docker Released
SUSE Manager Server 4.0 libcontainers-common Released
SUSE OpenStack Cloud 6 LTSS docker Affected