Upstream information

CVE-2018-14348 at MITRE

Description

libcgroup up to and including 0.41 creates /var/log/cgred with mode 0666 regardless of the configured umask, leading to disclosure of information.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 5.1
Vector CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1100365 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Legacy 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libcgroup-devel >= 0.41.rc1-1.10.1
  • libcgroup-tools >= 0.41.rc1-1.10.1
  • libcgroup1 >= 0.41.rc1-1.10.1
  • libcgroup1-32bit >= 0.41.rc1-1.10.1
Patchnames:
SUSE Linux Enterprise Module for Legacy 15 SP3 GA libcgroup-devel-0.41.rc1-1.10.1
SUSE Enterprise Storage 7
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Legacy 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libcgroup-devel >= 0.41.rc1-1.10.1
  • libcgroup-tools >= 0.41.rc1-1.10.1
  • libcgroup1 >= 0.41.rc1-1.10.1
  • libcgroup1-32bit >= 0.41.rc1-1.10.1
Patchnames:
SUSE Linux Enterprise Module for Legacy 15 SP2 GA libcgroup-devel-0.41.rc1-1.10.1
SUSE Liberty Linux 7
SUSE Liberty Linux 7 LTSS
  • libcgroup >= 0.41-21.el7
  • libcgroup-devel >= 0.41-21.el7
  • libcgroup-pam >= 0.41-21.el7
  • libcgroup-tools >= 0.41-21.el7
Patchnames:
RHSA-2019:2047
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libcgroup-devel >= 0.41.rc1-7.1
  • libcgroup1 >= 0.41.rc1-7.1
Patchnames:
sdksp4-libcgroup1-13708
SUSE Linux Enterprise Desktop 12 SP3
  • libcgroup-devel >= 0.41.rc1-10.9.1
  • libcgroup1 >= 0.41.rc1-10.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1453
SUSE-SLE-DESKTOP-12-SP3-2018-1732
SUSE-SLE-SDK-12-SP3-2018-1453
SUSE-SLE-SDK-12-SP3-2018-1732
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Legacy 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libcgroup-devel >= 0.41.rc1-1.10.1
  • libcgroup-tools >= 0.41.rc1-1.10.1
  • libcgroup1 >= 0.41.rc1-1.10.1
  • libcgroup1-32bit >= 0.41.rc1-1.10.1
Patchnames:
SUSE Linux Enterprise Module for Legacy 15 SP4 GA libcgroup-devel-0.41.rc1-1.10.1
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Legacy 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libcgroup-devel >= 0.41.rc1-1.10.1
  • libcgroup-tools >= 0.41.rc1-1.10.1
  • libcgroup1 >= 0.41.rc1-1.10.1
  • libcgroup1-32bit >= 0.41.rc1-1.10.1
Patchnames:
SUSE Linux Enterprise Module for Legacy 15 SP5 GA libcgroup-devel-0.41.rc1-1.10.1
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libcgroup-devel >= 0.41.rc1-7.1
  • libcgroup1 >= 0.41.rc1-7.1
Patchnames:
sdksp4-libcgroup1-13708
slessp4-libcgroup1-13708
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libcgroup-devel >= 0.41.rc1-10.9.1
  • libcgroup-tools >= 0.41.rc1-10.9.1
  • libcgroup1 >= 0.41.rc1-10.9.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1453
SUSE-SLE-SDK-12-SP3-2018-1732
SUSE-SLE-SERVER-12-SP3-2018-1453
SUSE-SLE-SERVER-12-SP3-2018-1732
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcgroup-devel >= 0.41.rc1-10.9.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1453
SUSE-SLE-SDK-12-SP3-2018-1732


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 libcgroup Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 libcgroup Not affected
SUSE Linux Enterprise High Performance Computing 15 SP6 libcgroup Not affected
SUSE Linux Enterprise Module for Legacy 15 SP5 libcgroup Not affected
SUSE Linux Enterprise Module for Legacy 15 SP6 libcgroup Not affected
SUSE Linux Enterprise Server 15 SP5 libcgroup Not affected
SUSE Linux Enterprise Server 15 SP6 libcgroup Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 libcgroup Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 libcgroup Not affected
SUSE Manager Proxy 4.3 libcgroup Not affected
SUSE Manager Retail Branch Server 4.3 libcgroup Not affected
SUSE Manager Server 4.3 libcgroup Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 libcgroup Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 libcgroup Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS libcgroup Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS libcgroup Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libcgroup Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS libcgroup Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS libcgroup Not affected
SUSE Linux Enterprise Module for Legacy 15 SP2 libcgroup Not affected
SUSE Linux Enterprise Module for Legacy 15 SP3 libcgroup Not affected
SUSE Linux Enterprise Module for Legacy 15 SP4 libcgroup Not affected
SUSE Linux Enterprise Server 15 SP2 libcgroup Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS libcgroup Not affected
SUSE Linux Enterprise Server 15 SP3 libcgroup Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS libcgroup Not affected
SUSE Linux Enterprise Server 15 SP4 libcgroup Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS libcgroup Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libcgroup Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libcgroup Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libcgroup Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 libcgroup Released
SUSE CaaS Platform 4.0 libcgroup Not affected
SUSE Enterprise Storage 5 libcgroup Released
SUSE Enterprise Storage 6 libcgroup Unsupported
SUSE Enterprise Storage 7 libcgroup Not affected
SUSE Linux Enterprise Desktop 11 SP4 libcgroup1 Released
SUSE Linux Enterprise Desktop 12 libcgroup Affected
SUSE Linux Enterprise Desktop 12 SP1 libcgroup Affected
SUSE Linux Enterprise Desktop 12 SP2 libcgroup Affected
SUSE Linux Enterprise Desktop 12 SP3 libcgroup Released
SUSE Linux Enterprise High Performance Computing 15 SP1 libcgroup Unsupported
SUSE Linux Enterprise Module for Legacy 15 SP1 libcgroup Unsupported
SUSE Linux Enterprise Point of Service 11 SP3 libcgroup1 Released
SUSE Linux Enterprise Point of Service Image Server 12 SP2 libcgroup Released
SUSE Linux Enterprise Server 11 SP3 libcgroup1 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS libcgroup1 Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS libcgroup1 Affected
SUSE Linux Enterprise Server 11 SP4 libcgroup1 Released
SUSE Linux Enterprise Server 11 SP4 LTSS libcgroup1 Affected
SUSE Linux Enterprise Server 11 SP4-LTSS libcgroup1 Unsupported
SUSE Linux Enterprise Server 12 libcgroup Affected
SUSE Linux Enterprise Server 12 SP1 libcgroup Affected
SUSE Linux Enterprise Server 12 SP1-LTSS libcgroup Unsupported
SUSE Linux Enterprise Server 12 SP2 libcgroup Affected
SUSE Linux Enterprise Server 12 SP2-BCL libcgroup Released
SUSE Linux Enterprise Server 12 SP2-ESPOS libcgroup Released
SUSE Linux Enterprise Server 12 SP2-LTSS libcgroup Released
SUSE Linux Enterprise Server 12 SP3 libcgroup Released
SUSE Linux Enterprise Server 12 SP3-BCL libcgroup Released
SUSE Linux Enterprise Server 12 SP3-ESPOS libcgroup Released
SUSE Linux Enterprise Server 12 SP3-LTSS libcgroup Released
SUSE Linux Enterprise Server 12-LTSS libcgroup Unsupported
SUSE Linux Enterprise Server 15 SP1 libcgroup Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL libcgroup Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS libcgroup Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libcgroup Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libcgroup1 Released
SUSE Linux Enterprise Server for SAP Applications 12 libcgroup Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libcgroup Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libcgroup Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libcgroup Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libcgroup Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP4 libcgroup1 Released
SUSE Linux Enterprise Software Development Kit 12 libcgroup Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libcgroup Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libcgroup Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libcgroup Released
SUSE Manager Proxy 4.0 libcgroup Unsupported
SUSE Manager Proxy 4.1 libcgroup Not affected
SUSE Manager Proxy 4.2 libcgroup Not affected
SUSE Manager Retail Branch Server 4.0 libcgroup Unsupported
SUSE Manager Retail Branch Server 4.1 libcgroup Not affected
SUSE Manager Retail Branch Server 4.2 libcgroup Not affected
SUSE Manager Server 4.0 libcgroup Unsupported
SUSE Manager Server 4.1 libcgroup Not affected
SUSE Manager Server 4.2 libcgroup Not affected
SUSE OpenStack Cloud 7 libcgroup Released
SUSE OpenStack Cloud 8 libcgroup Released
SUSE OpenStack Cloud Crowbar 8 libcgroup Released


SUSE Timeline for this CVE

CVE page created: Fri Jul 6 11:15:30 2018
CVE page last modified: Sun Jun 16 00:10:00 2024