Upstream information

CVE-2018-1305 at MITRE

Description

Security constraints defined by annotations of Servlets in Apache Tomcat 9.0.0.M1 to 9.0.4, 8.5.0 to 8.5.27, 8.0.0.RC1 to 8.0.49 and 7.0.0 to 7.0.84 were only applied once a Servlet had been loaded. Because security constraints defined in this way apply to the URL pattern and any URLs below that point, it was possible - depending on the order Servlets were loaded - for some security constraints not to be applied. This could have exposed resources to users who were not authorised to access them.

SUSE information

Overall state of this security issue: Does not affect SUSE products

SUSE Bugzilla entries: 1082481 [RESOLVED / FIXED], 1112097 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
  • tomcat >= 9.0.21-3.13.2
  • tomcat-admin-webapps >= 9.0.21-3.13.2
  • tomcat-docs-webapp >= 9.0.21-3.13.2
  • tomcat-el-3_0-api >= 9.0.21-3.13.2
  • tomcat-javadoc >= 9.0.21-3.13.2
  • tomcat-jsp-2_3-api >= 9.0.21-3.13.2
  • tomcat-lib >= 9.0.21-3.13.2
  • tomcat-servlet-4_0-api >= 9.0.21-3.13.2
  • tomcat-webapps >= 9.0.21-3.13.2
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA tomcat-9.0.21-3.13.2
SUSE Linux Enterprise Server 12 SP1-LTSS
  • tomcat >= 8.0.53-10.35.1
  • tomcat-admin-webapps >= 8.0.53-10.35.1
  • tomcat-docs-webapp >= 8.0.53-10.35.1
  • tomcat-el-3_0-api >= 8.0.53-10.35.1
  • tomcat-javadoc >= 8.0.53-10.35.1
  • tomcat-jsp-2_3-api >= 8.0.53-10.35.1
  • tomcat-lib >= 8.0.53-10.35.1
  • tomcat-servlet-3_1-api >= 8.0.53-10.35.1
  • tomcat-webapps >= 8.0.53-10.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2433
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • tomcat >= 8.0.50-29.8.2
  • tomcat-admin-webapps >= 8.0.50-29.8.2
  • tomcat-docs-webapp >= 8.0.50-29.8.2
  • tomcat-el-3_0-api >= 8.0.50-29.8.2
  • tomcat-javadoc >= 8.0.50-29.8.2
  • tomcat-jsp-2_3-api >= 8.0.50-29.8.2
  • tomcat-lib >= 8.0.50-29.8.2
  • tomcat-servlet-3_1-api >= 8.0.50-29.8.2
  • tomcat-webapps >= 8.0.50-29.8.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-543
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • tomcat >= 8.0.50-29.8.2
  • tomcat-admin-webapps >= 8.0.50-29.8.2
  • tomcat-docs-webapp >= 8.0.50-29.8.2
  • tomcat-el-3_0-api >= 8.0.50-29.8.2
  • tomcat-javadoc >= 8.0.50-29.8.2
  • tomcat-jsp-2_3-api >= 8.0.50-29.8.2
  • tomcat-lib >= 8.0.50-29.8.2
  • tomcat-servlet-3_1-api >= 8.0.50-29.8.2
  • tomcat-webapps >= 8.0.50-29.8.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-543
SUSE Linux Enterprise Server 12 SP4
  • tomcat >= 9.0.12-1.7
  • tomcat-admin-webapps >= 9.0.12-1.7
  • tomcat-docs-webapp >= 9.0.12-1.7
  • tomcat-el-3_0-api >= 9.0.12-1.7
  • tomcat-javadoc >= 9.0.12-1.7
  • tomcat-jsp-2_3-api >= 9.0.12-1.7
  • tomcat-lib >= 9.0.12-1.7
  • tomcat-servlet-4_0-api >= 9.0.12-1.7
  • tomcat-webapps >= 9.0.12-1.7
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA tomcat-9.0.12-1.7
SUSE Linux Enterprise Server 12 SP5
  • tomcat >= 9.0.21-3.13.2
  • tomcat-admin-webapps >= 9.0.21-3.13.2
  • tomcat-docs-webapp >= 9.0.21-3.13.2
  • tomcat-el-3_0-api >= 9.0.21-3.13.2
  • tomcat-javadoc >= 9.0.21-3.13.2
  • tomcat-jsp-2_3-api >= 9.0.21-3.13.2
  • tomcat-lib >= 9.0.21-3.13.2
  • tomcat-servlet-4_0-api >= 9.0.21-3.13.2
  • tomcat-webapps >= 9.0.21-3.13.2
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA tomcat-9.0.21-3.13.2
SUSE Linux Enterprise Server 12-LTSS
  • tomcat >= 7.0.90-7.23.1
  • tomcat-admin-webapps >= 7.0.90-7.23.1
  • tomcat-docs-webapp >= 7.0.90-7.23.1
  • tomcat-el-2_2-api >= 7.0.90-7.23.1
  • tomcat-javadoc >= 7.0.90-7.23.1
  • tomcat-jsp-2_2-api >= 7.0.90-7.23.1
  • tomcat-lib >= 7.0.90-7.23.1
  • tomcat-servlet-3_0-api >= 7.0.90-7.23.1
  • tomcat-webapps >= 7.0.90-7.23.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2339
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • tomcat >= 8.0.50-29.8.2
  • tomcat-admin-webapps >= 8.0.50-29.8.2
  • tomcat-docs-webapp >= 8.0.50-29.8.2
  • tomcat-el-3_0-api >= 8.0.50-29.8.2
  • tomcat-javadoc >= 8.0.50-29.8.2
  • tomcat-jsp-2_3-api >= 8.0.50-29.8.2
  • tomcat-lib >= 8.0.50-29.8.2
  • tomcat-servlet-3_1-api >= 8.0.50-29.8.2
  • tomcat-webapps >= 8.0.50-29.8.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-543
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • tomcat >= 8.0.53-10.35.1
  • tomcat-admin-webapps >= 8.0.53-10.35.1
  • tomcat-docs-webapp >= 8.0.53-10.35.1
  • tomcat-el-3_0-api >= 8.0.53-10.35.1
  • tomcat-javadoc >= 8.0.53-10.35.1
  • tomcat-jsp-2_3-api >= 8.0.53-10.35.1
  • tomcat-lib >= 8.0.53-10.35.1
  • tomcat-servlet-3_1-api >= 8.0.53-10.35.1
  • tomcat-webapps >= 8.0.53-10.35.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-2433


SUSE Timeline for this CVE

CVE page created: Fri Oct 7 12:48:53 2022
CVE page last modified: Tue Nov 29 14:12:25 2022