Upstream information

CVE-2018-11710 at MITRE

Description

soundlib/pattern.h in libopenmpt before 0.3.9 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted AMS file because of an invalid write near address 0 in an out-of-memory situation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 1095644 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
  • libmodplug-devel >= 0.3.9-3.3.1
  • libmodplug1 >= 0.3.9-3.3.1
  • libopenmpt >= 0.3.9-3.3.1
  • libopenmpt-devel >= 0.3.9-3.3.1
  • libopenmpt0 >= 0.3.9-3.3.1
  • libopenmpt_modplug1 >= 0.3.9-3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-1323
openSUSE Leap 15.0
  • libmodplug-devel >= 0.3.9-lp150.2.3.1
  • libmodplug1 >= 0.3.9-lp150.2.3.1
  • libmodplug1-32bit >= 0.3.9-lp150.2.3.1
  • libmodplug1-32bit-debuginfo >= 0.3.9-lp150.2.3.1
  • libmodplug1-debuginfo >= 0.3.9-lp150.2.3.1
  • libopenmpt >= 0.3.9-lp150.2.3.1
  • libopenmpt-debugsource >= 0.3.9-lp150.2.3.1
  • libopenmpt-devel >= 0.3.9-lp150.2.3.1
  • libopenmpt0 >= 0.3.9-lp150.2.3.1
  • libopenmpt0-32bit >= 0.3.9-lp150.2.3.1
  • libopenmpt0-32bit-debuginfo >= 0.3.9-lp150.2.3.1
  • libopenmpt0-debuginfo >= 0.3.9-lp150.2.3.1
  • libopenmpt_modplug1 >= 0.3.9-lp150.2.3.1
  • libopenmpt_modplug1-32bit >= 0.3.9-lp150.2.3.1
  • libopenmpt_modplug1-32bit-debuginfo >= 0.3.9-lp150.2.3.1
  • libopenmpt_modplug1-debuginfo >= 0.3.9-lp150.2.3.1
  • openmpt123 >= 0.3.9-lp150.2.3.1
  • openmpt123-debuginfo >= 0.3.9-lp150.2.3.1
Patchnames:
openSUSE-2018-742


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Desktop Applications 15 GA libopenmpt Released