Upstream information

CVE-2018-1116 at MITRE

Description

A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polkitd allows to test for authentication and trigger authentication of unrelated processes owned by other users. This may result in a local DoS and information disclosure.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.6
Vector AV:L/AC:L/Au:N/C:P/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.4 3.3
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low None
Integrity Impact None None
Availability Impact Low Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1099031 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libpolkit0 >= 0.113-5.9.1
  • libpolkit0-32bit >= 0.113-5.9.1
  • polkit >= 0.113-5.9.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1468
SUSE Linux Enterprise Desktop 12 SP4
  • libpolkit0 >= 0.113-5.12.1
  • libpolkit0-32bit >= 0.113-5.12.1
  • polkit >= 0.113-5.12.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.12.1
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libpolkit0 >= 0.114-3.6.1
  • polkit >= 0.114-3.6.1
  • polkit-devel >= 0.114-3.6.1
  • typelib-1_0-Polkit-1_0 >= 0.114-3.6.1
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libpolkit0 >= 0.116-1.51
  • polkit >= 0.116-1.51
  • polkit-devel >= 0.116-1.51
  • typelib-1_0-Polkit-1_0 >= 0.116-1.51
SUSE Linux Enterprise Module for Basesystem 15
  • libpolkit0 >= 0.114-3.3.1
  • polkit >= 0.114-3.3.1
  • polkit-devel >= 0.114-3.3.1
  • typelib-1_0-Polkit-1_0 >= 0.114-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1469
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libpolkit0 >= 0.113-5.9.1
  • polkit >= 0.113-5.9.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1468
SUSE Linux Enterprise Server 12 SP4
  • libpolkit0 >= 0.113-5.12.1
  • polkit >= 0.113-5.12.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.12.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • polkit-devel >= 0.113-5.9.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1468
SUSE Linux Enterprise Software Development Kit 12 SP4
  • polkit-devel >= 0.113-5.12.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • polkit-devel >= 0.113-5.18.1
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libpolkit0-32bit >= 0.113-5.9.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-1468
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libpolkit0-32bit >= 0.113-5.12.1
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libpolkit0-32bit >= 0.113-5.18.1
openSUSE Leap 15.0
  • libpolkit0 >= 0.114-lp150.2.3.1
  • libpolkit0-32bit >= 0.114-lp150.2.3.1
  • polkit >= 0.114-lp150.2.3.1
  • polkit-devel >= 0.114-lp150.2.3.1
  • polkit-doc >= 0.114-lp150.2.3.1
  • typelib-1_0-Polkit-1_0 >= 0.114-lp150.2.3.1
Patchnames:
openSUSE-2019-579
openSUSE Tumbleweed
  • libpolkit0 >= 0.118-7.2
  • libpolkit0-32bit >= 0.118-7.2
  • polkit >= 0.118-7.2
  • polkit-devel >= 0.118-7.2
  • polkit-doc >= 0.118-7.2
  • typelib-1_0-Polkit-1_0 >= 0.118-7.2
Patchnames:
openSUSE Tumbleweed GA libpolkit0-0.118-7.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 polkit In progress
SUSE CaaS Platform 4.0 polkit In progress
SUSE Enterprise Storage 6 polkit In progress
SUSE Linux Enterprise Desktop 12 SP3 polkit Released
SUSE Linux Enterprise High Performance Computing 12 SP5 polkit Released
SUSE Linux Enterprise High Performance Computing 15 LTSS polkit In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS polkit In progress
SUSE Linux Enterprise Module for Basesystem 15 polkit Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 polkit Already fixed
SUSE Linux Enterprise Server 12 LTSS polkit Affected
SUSE Linux Enterprise Server 12 SP1 LTSS polkit Affected
SUSE Linux Enterprise Server 12 SP2 BCL polkit In progress
SUSE Linux Enterprise Server 12 SP2 LTSS polkit Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON polkit In progress
SUSE Linux Enterprise Server 12 SP2 LTSS SAP polkit In progress
SUSE Linux Enterprise Server 12 SP3 polkit Released
SUSE Linux Enterprise Server 12 SP3 BCL polkit In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS polkit In progress
SUSE Linux Enterprise Server 12 SP3 LTSS polkit In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS polkit In progress
SUSE Linux Enterprise Server 12 SP4 LTSS polkit In progress
SUSE Linux Enterprise Server 12 SP5 polkit Released
SUSE Linux Enterprise Server 15 LTSS polkit In progress
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux polkit In progress
SUSE Linux Enterprise Server 15 SP1 LTSS polkit In progress
SUSE Linux Enterprise Server ESPOS 15 polkit In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 polkit In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 polkit In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 polkit Released
SUSE Linux Enterprise Server for SAP Applications 15 polkit In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 polkit In progress
SUSE Linux Enterprise Software Development Kit 12 SP3 polkit Released
SUSE Linux Enterprise Workstation Extension 12 polkit Released
SUSE Manager Proxy 4.0 polkit In progress
SUSE Manager Retail Branch Server 4.0 polkit In progress
SUSE Manager Server 4.0 polkit In progress
SUSE OpenStack Cloud 8 polkit In progress
SUSE OpenStack Cloud 9 polkit In progress
SUSE OpenStack Cloud Crowbar 8 polkit In progress
SUSE OpenStack Cloud Crowbar 9 polkit In progress